SAT>IP settings for DIGIBIT R1 and tvheadend

SAT>IP settings for DIGIBIT R1 (Firmware Version V1.25.0.157) and tvheadend

I have seen that some people have problems with SAT>IP tuners that for me have a perfect performance with tvheadend server.

My settings are:

DIGIBIT R1:

  • miniDLNA server: disabled
  • SAMBA server: disabled
  • RTSP multicast: disabled

TVHEADEND SERVER:

- SAT> IP device:

  • Signal scale: 255
  • Maximum PIDs: 16 (very important) (*)
  • Maximum length of PIDs: 512
  • addpids/delpids supported: off (very important) (*)
  • FE supported: on
  • Force pilot for DVB-S2: off
  • PIDs 21 in setup: off
  • Disable workarounds: off

- SAT>IP tuners:

  • Initial scan = off
  • Idle scan = off

- Networks:

  • Network discovery = off
  • Skip startup scan = on
  • Idle scan muxes = off

In the event that tvheadend server is late in recognizing the tuner, it is most likely that it is busy in other tasks (mux scan, epg scan, …), check the tvheadend server configuration on this.

Note (*): Without this some muxes are not scanned correctly or with errors or with missing channels, and with other mux there is no problem.

1 Like

Are you using the standard Firmware Version V1.24.0.156 ?

I suspect not, which is why I ask, thanks.

Why kind of LNB are you using … Quad or Unicable I or Unicable II?

I use it now for years with 1.16.0.120 and a Quattro LNB. I do use DVBViewer Media Server without any issue for ~5 years now.

I just discovered that assigning a fixed IP (with the SAT>IP boxes settings) for my Digitwin makes detection erratic with the TVheadend server. This is a function of how TVH detects tuners.
Otherwise things work very well in Coreelec

Shoog

I have modified some things, I have put the download link of the latest available firmware (Telestar DIGIBIT R1, Inverto IDL-400s and Grundig GSS.BOX) and corrected Maximum PIDs after scanning HotBird. The configuration data works well in Astra 19.2E, HotBird 13.0E, and Hellas 39.0E.

This configuration should work with any Universal LNB but my tests have been done with a Unicable DUR-line UK 124 LNB for 24 tuners with a single coaxial cable. To move the antenna motor I use the conventional Mecool KIII Pro tuner or my old LG TV.

As regards the allocation of IP within a local network, it is always the same, it is not convenient to assign fixed IP addresses inside the devices, since this may lead to malfunctioning. The fixed IP addresses should be assigned from the DHCP server inside the router, this also allows to easily verify that there are no duplications in the IP address.

Not all routers allow access to the DHCP settings, so in this case the only option is to let the router do its own thing with regard to IP’s and live with it.

From what I can determine, the firmware you linked to from Inverto with version number
V1.25.0.157
is the same as the Telestar firmware
V1.24.0.156

The release notes are exact duplicates of each other it seems.

Have you had both those firmwares installed?
Is there a difference?
The link to the Telestar V1.24 firmware
https://telestar.de/custom/downloads/asset_dab80b09ff7ba70bc9d274abc0edb292_soft_Digibit_R1_005.zip

I would like to know if there is a good reason to change the firmware before doing anything.
Thanks.

The hardware of Telestar DIGIBIT R1, Inverto IDL-400S and Grundig GSS.BOX is the same so that the same firmware can be used. Among the three brands Telestar, Inverto and Grundig the best, without a doubt, is Inverto, and it is the one that has endeavored to update the firmware. Telestar and Grundig are really bad brands.

You can use the Inverto IDL-400S firmware on your DIGIBIT R1 if you feel like it.

OK the firmware can be used … but the release notes indicate that it is the same firmware with a different number.
Have you any information about this?

I have no more information, I just know that the firmware of Inverto is used to create alternative firmwares (satip-ax) identical for the three devices mentioned (the last one is dated October 23, 2018) but the configuration is much more difficult.

I can only add that the firmware of Inverto works well for me. If you are worried about the guarantee, continue with your current firmware.

Thanks.
No, not worried about guarantee or such, just that if they are the same firmware there is no real point in using one version in place of the other.

All routers have a DHCP server but not all allow you to assign fixed IP addresses. If this is your case, there is no other solution than to assign a fixed IP address on the device outside the automatic IP assignment range of the DHCP server, and verify that this works.

I guarantee that this approach will upset TVHeadends autodetection.

Shoog

IGMP snooping in the router configuration may interfere, disable IGMP snooping and try, check that the fixed addresses are within the same network range (xxx.xxx.xxx.1-254). If you assign a fixed IP address within the automatic allocation range of the DHCP server, sooner or later it will fail.

If nothing works look for a forum that talks about your router because the problem is there.

My issues regarding SAT > IP detection persisted so I revisited the solutions and came up with this set of detailed instructions:

Here is my solution to achieve reliable SAT>IP detection within TVH on my Digibit Twin.

The problem I was facing was that each time I had to switch off the box the rebooted system more often than not failed to detect my Digibit Twin and I had to reboot the Digibit and my box, sometimes multiple times to restore the tuners.

Step One:
First thing is to get you TVH server to detect the Digibit at least once, you need this so that you can go into the TVH web interface and extract the xml location on your SAT>IP tuner box.

Goto
TVHServer > Configuration TAB > TV Adapters > SAT > IP folder.

Go to the top level of the SAT > IP folder and select the Read-only Info, scroll down to the Location field and copy its contents.
eg in my case this contains:
http://192.168.1.3:38400/description.xml

Step two:
Log into the web interface of the Digibit Twin and select fixed IP address and make certain it matches the IP address that you copied in step one.

Doing this will likely crash TVH and Kodi so you will probably have to reboot your box.

Step Three:
SSH into you Coreelec box

  1. Launch a terminal on your main comp

  2. issue command “ssh root@192.168.1.14” replacing the IP address with the IP address of your box

  3. Enter password of “coreelec”

  4. Issue command “cd /storage/.kodi/addons/service.tvheadend42/bin”

  5. Issue command “nano tvheadend42.start”

  6. After line “chmod a+x $ADDON_DIR/bin/*”
    add the line
    TVH_ARGS_EXTRA=”–satip_xml the location you copied in step one
    Take careful note of the fact the there is a double dash infront of satip_xml
    eg in my case
    TVH_ARGS_EXTRA="–satip_xml http://192.168.1.3:38400/description.xml"
    Copying and pasting the last line will not work since there are added formating remove the 1 from the end of the line.

  7. Save and close Nano

  8. Issue command “reboot”

That should be it and everytime you reboot it should always find you SAT > IP box.

Just a warning, the latest TVH nightlies seem to completely break SAT > IP support.

Shoog

I can not answer you because I do not use nightlies. A few weeks ago I downloaded from linuxsat-support.com an addon ‘service.tvheadend43-9.1.466a014.zip’ for CoreELEC and it worked fine with SAT> IP.

I do not know what firmware version you use. The version V1.25.0.157 that I mentioned in this topic solves the following problems:

Bug fixes in 1.25.0.157

  • SAT> IP server was not working with TVheadend software. This has been fixed.
  • Sometimes the SAT> IP server was not reachable, if the network cable has been plugged after the SAT> IP server did already boot-up.
  • Some special character did not work for the login password. Now the password support all characters from character set ISO-8859-1.

Apparently the problem is only with Digibit dual tuner model and not the quad Digibit R1 model, which I have running here using the most recent nightly.

If nothing works, there is always the option to export the playlist of your SAT> IP server, edit it, and include it in tvheadend server.

Latest nightlies break my fix.
This is getting to be a right pain in the arse.

Cannot recommend the Digibit TVtwin - its broken because it doesn’t implement the SAT > IP standard correctly and the manufacturer seems to have abandoned it in terms of updates. These problems have existed with this product for 3 years at this stage - but the only useful info is all in German.

Update: after all that messing about i discovered that the only reliable way to get TVH to detect the Digibit after a CE reboot is to switch on and off the CE box, the Digibit Twin and the Router - all simultaneously. Its worked 4 times in a row.
To me this points to the router as messing up the pathway in some obscure way so maybe a simpler switch would solve the problem ?

UPDATE: After moving to the new nightlies I have been getting consistent detection’s of the Digibit with the boot line added. However I think I have got to the bottom of what was causing the erratic detection’s before. I have a VPN running and it seemed as thougfh the VPN was coming online just at the time that the SAT > IP was been configured. What I did was delay the VPN coming online for 40sec - pushing it out to well beyond the point where the SAT > IP handshakes had happened. It seems that what was probably happening was that the SAT > IP was half way through establishing a connection when the VPN switched the internet away and left the SAT > IP hanging.

Shoog