Solution to "no HDMI signal" black screen on TV kind

I’m posting a solution I found to a problem I had been having with a previously working S905x box.
I was about to bin the box but I managed to figure out the cause and fix - I’m sharing it in case it helps anyone else in the future.

A box that was previously working 100%, suddenly would no longer produce a picture on my 4k tv. I would get a “no signal” error on the TV. I tried different HDMI cables, and ports on the TV, but stlll a black screen on the TV. I don’t know of anything that would cause this.

Anyhow, I then tried re-installing the stock Android image, but still no luck. I tried using an older 1080p small screen TV and everything worked. Still it would not work with the 4k tv. I set up the internet connection using the small TV and then I SSH’ed into the box.

Just for grins, I thought I’d check the following :- “fw_printenv hdmi_mode” and “fw_printenv output_mode”. The returned message for both commands was "hdmi_mode not defined" and “output_mode not defined”. I have no idea how these u-boot variables were wiped, but that was the cause of my problem. I fixed the issue with “fw_setenv hdmi_mode 1080p60Hz” and repeated the command for “output_mode”. Now everything is working 100% again.

So, if you are faced with a black screen in the future and have tried swapping HDMI cables and ports, then SSH into your box, and run the “fw_printenv” command for “hdmi_mode” and “output_mode”, to see if your issue is caused by wiped out variables. It may save your box from being thrown in the trash - as it did for mine, :grinning:

As I said, I have no recollection of any reason why these values would be wiped - maybe I had a power surge on the box - but this happened several months ago, and I only managed to stumble upon the solution today. Fortunately this was a ‘reserve’ box. For some reason, the older 1080p tv did not “care” that these variables were wiped (but the 4k tv did care) - otherwise I may not have been able to guess at a solution.

1 Like

I have had the same issue for 2 or 3 weeks on Samsung KS9000 and also on an old Samsung LCD but only with N2 and all operating systems.It happens the same with all of them,you see it boot on the tv then no signal.Connecting to msi and Viewsonic monitors works as expected,almost ordered another N2 and butchered the other one for spares.Nice spot cheers

I am having similar problems. what exactly is the “fw_printenv” command for “hdmi_mode” and “output_mode. Where do I find hdmi_mode and **output_mode in order to make the recommended changes.

Had the same issue, and this helped me:

Copy file disp_cap (64 Bytes) to directory “/storage/.kodi/userdata”.

Sometimes I had to turn off the tv and turn in on again, but never got to restart the corelec.

You must SSH into your box (there are lots of tutorials about doing that if you are unfamiliar with it).
When you arrive at the command line after SSH’ing to your box, just type this:-
fw_printenv hdmi_mode and enter. Then repeat for fw_printenv output_mode.
These commands show what the box setting is for these values. If your problem was the same as mine, you should receive “mode not defined”.
To change the values type:-
fw_setenv hdmi_mode 1080p60Hz then enter
and
fw_setenv output_mode 1080p60Hz and enter again.

Reboot your box and that should fix it.

1 Like

I was able to install the SSH helper on my android box but I can not load it onto my computer. I tried with a Mac and every tutorial eventually has me enter a command into “terminal” The directions indicate when I enter the listed code I will come to another page. The reality is that when I enter the code listed into terminal I get either a warning that this is an invalid code or I am asked for a password; I tried using “admin” and I tried using the password I changed to when I downloaded the SSH helper on my android box and I tried my Apple ID password. I get a message that says these are incorrect. I was successful in downloading MacPorts 2.6.2.2, Xcodes and command line tools for Xcode’s but I am not sure what to do with those. I have a pc and when I try to download PuTTY and run it I get as far as the command line. When I type in admin as instructed and hit enter I get a PuTTY Fatal Error that says No supported authentication methods available (server sent:publickey, keyboard-interative). When I close that box the command line disappears. Can you offer any help as to how to download the SSH server onto my computer? Thanks.

I use the free program “WinSCP”

image

password is coreelec

Once you login to WinSCP, I then use the built in putty terminal (from the WinSCP main window) to SSH into coreelec box. I think you can also use shortcut “Ctrl + P” keys to open SSH session once you login to WinSCP.

For SSH, user id is root and password is coreelec.

Thanks for all of your help but nothing I try works. I have a Beeline GT King android box. It comes with an SD card that has coreELEC installed. When I turn on the box it opens up to Kodi within coreELEC. It is in the safe mode so I can not put any add-on on it. I do not know how to get it out of safe mode… Anyway, if I want to use the box like a standard android box I have to essentially log out of coreELEC. When I do that is when I get the black screen or flickering or a message that there is no connection. I unplug and plug back in the HDMI over and over until I get a stable connection. I never have this problem when I am on the coreELEC side. I have downloaded the SSH helper on the regular android side but I can not load it onto either of my computers. When I logged into WinSCP, the dialog box did not have coreELEC listed and I am not sure that is what I want anyway. Still I put in coreELEC s the host name but I get a message that says Host CoreELEC does not exist. If you have any more suggestions I would appreciate it but I am thinking there is no solution to my problem. Thanks

Open CoreELEC Settings addon and navigate to Hard Reset .
Select it and wait for the box to wipe and it will reboot with a clean install.

I do not have a CoreELEC settings add on but I was able t reset the app to defaults and it fixed the problem. Thanks.

CoreELEC Settings. ( It’s a Program Add-on. )

What is an App. No Apps in Kodi.
CoreELEC is an Operating System running Kodi.
Please learn to use correct terminology of what you are using otherwise we have no idea what is going on…
You used the CoreELEC Settings to do a reset as i advised you.
A hard reset is what i asked you to do.

I apologize, this is all new to me. Here is what my screen shows when I go to apps on the CoreELEC system. I clicked on CoreELEC Configuration. I can only upload one picture per post so I will send a second post with what the screen showed next.

Also, is there a way to use a VPN with Kodi in the CoreELEC operating system. I do not think my VPN on the android side is active in the CoreELEC system side. Thank you.

I clicked on CoreELEC configuration and it came to this screen

, I scrolled down to reset to defaults and it fixed my problem. I never saw an option to do a hard reset but it is OK now.

The picture you posted had banned add-ons in it. There’s no support for systems running banned add-ons. Pay attention to what you post.

Yes you can add a VPN to CoreELEC just Google for VPN manager for Kodi. And second the picture you posted is from CoreELEC settings.

Thank you very much. I will attempt to add the VPN.

I am still trying to get this problem fixed. I now have the SSH client installed on both my android box and my Mac computer. I assume (though I am not sure) that SSH’ing into my box consists of only clicking on the SSH icon on my computer. After I do this I open terminal and type in what you listed above. I hit enter and I get the following message. zsh: command not found: fw_printenv. Also, I tried to install WinSCP but after getting the download when I tried to install it I get the following message. "The contents of “WinSCP-5.17.3-Setup exe cannot be extorted with the Unarchiver”. Any suggestions on what I should do from here.

Turn on your box with CE running.
As an example the IP of my box using CE is 192.168.8.128
Change the IP address in the example to your IP address of the box.
Using your Mac open the inbuilt application Terminal to SSH into your CE box.
To log in to the box you log in using the following command below replacing my ip with yours.

ssh root@192.168.8.128

You’ll be asked for a password in the terminal command screen.
Password is coreelec.

Now follow the commands given to you by ukmark62

Here is what happened when I did as you suggested. I got the following message
“ldupree@ssh-ldupree192168147 ~ % ssh root@192.168.1.47
root@192.168.1.47’s password:”

When I tried to type in the password, nothing happened. No characters were displayed. I hit enter and got

“Permission denied, please try again.
root@192.168.1.47’s password:”

I remembered I changed the password when I initially set up CreELEC so I tried my new password and I got the following

ldupree@ssh-ldupree192168147 ~ % ssh root@192.168.1.47
root@192.168.1.47’s password:
##############################################

CoreELEC

https://coreelec.org

##############################################

CoreELEC (official): 9.2.1 (Amlogic-ng.arm)
I then typed in what I was instructed to earlier and below is what I got.

CoreELEC:~ # fw_printenv hdmi_mode

Error: “hdmi_mode” not defined

CoreELEC:~ #.

I feel I am making real progress, I feel like I am so close but just not quite there yet. Your help is really appreciated.

Please take the time to read.