SOLVED::: TOX3 video issue Mpeg 2 and VC-1

Hate keep beating this old horse to death, but found another issue of video play back.

When I play a live TV stream with 480i mpeg2, I get the same issue as the VC-1 issue. See pics and log.

Started a new thread, but same issue as before, so I did not clog up the other thread.
ix.io-4swk.url (43 Bytes)





thanks

Cool Pictures. But it be might more helpful when you attach a short sample to reproduce the issue?

Here is a short clip of a live TV stream. It plays perfectly on my Windows PC using VLC, but it looks like the above photos when it is playing on my TOX3 and CoreELEC. This issue is only using CE running on a microSD card. No issues while running under Android.

Easter Parade.ts (6.7 MB)

By this pictures I don’t understand what is wrong, but this sample plays fine for me on another s905x4 box.
You could try clean setup on another sd/usb card to compare.
Or you can also try to limit video output to 10-bits in CE settings.

I will give those a try, thank you. I am only having problem with this specific device. I have/had several different devices running coreELEC, never had this issue.

I have this box and with the provided clip I also got a bad image. Turning off hardware decoding yielded a good image. Just to confirm it’s not an bug unique to @clarkss12

Thank you Frank, for confirming that I am not the only one experienceing this issue. I will test with the hardware decoding disabled…

According to the log, there’s a new SOC revision ‘D’ used in your box
Maybe that’s the difference…

Amlogic Meson SC2 (S905X4/C2) Revision 32:d (2:1) Detected

Turning off hardware decoding solved issue live TV issues… thanks

Hope that ‘D’ doesn’t cause too many issues that can’t be solved. I make a video clip of what I see. I did notice from the information at the top of the video, it shows "dc-am-vc-1, 1920x1080i, I don’t think that video is interlaced. I added the Mediainfo for that video, Back to the Future. Also a clip of what I see.
I am testing on a different 4k TV, but same issue.

Back to the Future.txt (8.6 KB)

Link to the video clip. https://drive.google.com/file/d/1Fn-tpelHN_6b3OeLANCGd_X-apo8PUCj/view?usp=share_link

Edit: I checked another device and Back to the Future also shows “1920x1080i”, so guess that means nothing.

Logs http://ix.io/4sB0

My TOX3 plays the Easter parade clip perfectly with HW acceleration. It has revision ‘B’ though. Also, the log shows you are using Ugoos_x4 dtb. Have you tried with generic tree? Also, test with the Display whitelist set to blank.

Yes, I have tried multiple things, different device trees, different ROMs, etc… I have tried every trick in the book that I know. I think something is different with this box. Also, the stock firmware as I recall, using Aida64, shows it is using Ugoos firmware, can you verify that for me?? Thanks.
BTW, if you are not aware, Ugoos is the king of these “cheap” boxes firmware. Ugoos is the grandfather of all of these Android boxes. They have been around since the beginning of these type of media players. Other devices, steal their code. Don’t know if this TOX3 is part of Ugoos or they borrowed Ugoos firmware.

My stock firmware according to Device Info HW shows Builder: ugoos@UG-PC3. I got mine from Vontar Official Store when it first came out in Oct 2022. Guess I got lucky, newer revisions do not always mean better.

I will need to check if we have a rev.d in our hands. But if not you might need to wait until a kernel rebase solve your issue. Did you try also ce-21?

I think I tried CE-21, but I will do it again with a different microSD card.

VC-1 video files are playing now.

Using this device tree >> sc2_s905x4_4g_1gbit.dtb

This CE-21 nightly build >> CoreELEC-Amlogic-ng.arm-20.1-Nexus-Generic.img.gz from April 1, 2023

Don’t know if it made a difference. I connected to the bedroom TV (4k, no surround system). It froze up a few times as I added videos from my networked storage devices.

I then brought the box to the Livingroom TV, that has a Yamaha AVR for surround sound. For testing purposes, I only used the TV speakers and turned off the Yamaha AVR. Back to the Future played very well.

Now, I will turn on the audio surround sound system and see what happens…

I am using this microSD card >>
Sandisk Extreme Plus 128GB
Red/Brown
Writing speed: 66.6 MByte/s
Reading speed: 72.5 MByte/s

Thanks getting it to work.

I will update when I test everything.

Don’t know how or what, but videos with the VC-1 video codec are working.
Mark this thread SOLVED.

Thanks again.

I did that hoping to VC-1 to work but no difference with other builds, still black and white with stripes. I have it also with a old serie of Columbo ( MPEG4 Video (H264) 720x576 (4:3) 25fps [V: h264 high L3.0, yuv420p, 720x576) and some more low res movies/series. I have also the revision D

clarkss12 which firmware do you have on the box ??
I still have the original firmware on it

To do more testing, I put back the microSD card running 20.1 Nexus and the same problem exist. So, I can confirm, this box runs best on the Omega 21.0


The original firmware should work. For our “D” device we have to use the Omega 21.0 version… It works great.

https://relkai.coreelec.org/Amlogic-ne/ce-21/CoreELEC-Amlogic-ne.aarch64-21.0-Omega_nightly_20230402-Generic.img.gz

Once you get CE on your box, @Jas88 has created the remote config… TrustOnX Player (TOX3) S905X4 - ETH not working on NE but working on NG! FIXED - Solution available! - #31 by Jas88

and Display config… TrustOnX Player (TOX3) S905X4 - ETH not working on NE but working on NG! FIXED - Solution available! - #35 by Jas88