Spidev @ Khadas vim3

Hello to the community,

At Khadas Vim3 (CoreELEC 19.3), i want to activate SPI / spidev by dtb overlay:
mount -o remount,rw /flash
fdtput -t s /flash/dtb.img /soc/cbus@ffd00000/spi@13000/spidev@0 status “okay”
fdtput -t s /flash/dtb.img /soc/cbus@ffd00000/spi@13000 status “okay”,
but the proposed method does not work:
fdtput -t s /flash/dtb.img /soc/cbus@ffd00000/spi@13000/spidev@0 status “okay”
Error at ‘/soc/cbus@ffd00000/spi@13000/spidev@0’: FDT_ERR_NOTFOUND

Is there any other possible way, or do I have to recompile kernel and/or dtb?



Search SPI

SPI in Settings - Hardware set to ON.

Will no one answer my question?

Log files pasted to http://ix.io/3Ofs

Please update to last 19.4_rc2 release, I will prepare a new dtb.img for you. It looks like a double usage of GPIOH_5.

Please update to 19.4_rc2 and use this dtb and test SPI again:
g12b_a311d_khadas_vim3.dtb (73.1 KB)

Thank you very much! Everyone is working!

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.