SSH cannot be enabled after installation

Have fiddled with my t95z plus (S912) with the latest stable CE (9.2.1) on dual boot with memory card, but I am unable to get ssh connections.

smb and web ui are working as expected and I have checked my firewalls. As far as I understand from logs there is no service listening to port 22. have tried ssh and putty from windows 10 but give me “connection refused”

Have enabled ssh from:
Settings -> System -> CoreELEC
Services -> SSH: Enable SSH

Also I have (re)burned image and started from scratch with no luck.

Any help or tips would be greatly appreciated.

side note there seems to be a bug in the installation wizard:
ssh cannot be enabled at all when installation wizard runs also it falsely turns smb off when it is trying to enable ssh. This can be corrected by going to another step and coming back again to this wizard page.

I would start by trying with a different SD card. This sort of problem shouldn’t occur. It’s pretty basic, and none of us have seen this issue before.

Something really weird is definitely going on since everytime I visit
CoreELEC -> Services
all the settings seem to be disabled although I can access samba and web UI.
Therefore UI is not reflecting the real configuration values
Can I see and set real values of these settings with some method than ssh/bash, plugin/extension perhaps?

Hello guys, I have the same problem with SSH, see my post Magicsee N5

1 Like

After clean install and few reboots settings are bound to UI as well and I was able to enable SSH again so that setting would stick (at least is shown like that in the UI).

If I am reading network.log (as an attachment) correctly there is still no service listening to port 22.
05_Network.log (15.7 KB)

Bad memory card as has already been said to you.

Had the same issue - i flashed system again and it worked. Was looking for many answers but there is not to many other options.

I have now flashed this five (5) times on a two different brand new SD cards with no luck.

I believe this proves that it is rather compatibility/software than hardware issue.

What are my options to investigate this further? Or should I try some other distributions suitable for s912

Also recorded UI misbehavior but video was 102MB and therefore was unable to attach it here.

Use a Filehosting site like Google Drive or Mega NZ and supply link.
Different issue to the SSH topic here so open a new one.

Please upload logs with a link.
Devs hate downloading logs.

https://pastebin.com/xPfeqVD3

Can you please confirm you use 1 Router in your Network setup ?

1. # Generated by Connection Manager

2. nameserver 193.229.0.40

3. nameserver 193.229.0.42


1. Kernel IP routing table

2. Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface

3. 0.0.0.0         192.168.0.1     0.0.0.0         UG        0 0          0 eth0

4. 192.168.0.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0

5. 192.168.0.1     0.0.0.0         255.255.255.255 UH        0 0          0 eth0

6. 193.229.0.40    192.168.0.1     255.255.255.255 UGH       0 0          0 eth0

7. 193.229.0.42    192.168.0.1     255.255.255.255 UGH       0 0          0 eth0

As you say it doesn’t really look like SSH is running based on the netstat logs and it’s not possible to tell based on the networking logs why it doesn’t turn on.

A bit far fetched but I’ve seen the CoreELEC Configuration menus behave strangely due to some poorly coded video addon. But I suppose since you’ve flashed it multiple times you’ve already tried to enable SSH right after clean install and before installing any additional addons?

@vipasane
I just copped the port 22 refused connection on Vim2 S912 fresh Nightly install SD Card CE
I did a Hard Reset via the CE Configuration and enabled SSH Via the wizard using default Password and connection was established after that.
We’re looking into it.

1 Like

Yes, there is only one router, but DNS services are set statically to gain better connection

Thanks for the workaround,
I did the hard reset as well and got SSH working straight away when running installation wizard.

@Rascal
Video with the issue on clean first installation:

Thank You @vipasane
First thing i noticed from your video is that SMB is not Enabled by Default.
It should have been Enabled by Default.
Something is definitely wrong with CE configurator after your install.
Again we’re looking into it.

Well actually it is enabled and working but as I wrote before UI will show it as disabled when enabling ssh fails, therefore I left the part that I visit another wizard step to regain real value of smb being enabled.

I had similar problem (no sshd accessible on 22 port on CoreELEC running from CF card). The reason is this:

journalctl -u sshd

Jan 01 00:00:25 CoreELEC ssh-keygen[3078]: ssh-keygen: generating new host keys: RSA Could not save your public key in /storage/.cache/ssh/ssh_host_rsa_key.Kp3BJI6nwD: No such file or directory

With absence of sshd on CoreELEC host, I’ve been able to login via ‘Web SSH Terminal’ (in addon/services/) which is accessible on port 11111 from web browser.
SOLUTION:
mkdir /storage/.cache/ssh
systemctl start sshd

That is it.

1 Like

I had the very same issue and can fully confirm that this was the root cause. I used the same solution (login via webssh addon and then create the missing folder). Thanks for pointing the out!