Subtitle stutter 8.90.3


#22

Look here: Smart Redraw


#23

Smart Redrow does not work, ie it does not eliminate subtitle stutter on my X92_S912 box.


#24

What about dirtyregions then? As far as I know it does work, and gets rid of this issue.


#25

dirtyregions also does not work


#26

Dirty regions work for me, so it’s still my only option on S912, because I have to use subtitles extensively.


#27

I have just set Smart Redraw, but stutter still remains. It seems that a little less, but still very noticeable when a subtitle is about to appear or it has just appeared and the scene moves.

I also use subtitles in all videos, since I watch everything in original version.

I have a Vorke z6 (S912) box.

Thsnks


#28

Do you have stutter also with dirty regions enabled? That option solves the stutter completely on my S912 box, except on one video, 720p/50Hz coded with h265, where the slight stutte is still (not frequently) noticeable.


#29

Yes,I tried dirty regions and smart redraw, but both not work.

As I said,This issue not happened on all codec video files but some special kind.
Have you playbacked the sample.mkv I uploaded?
on my case, odriod c2 and S905D box with the lastest release version and nightbuild coreelec,the stutter all noticeable. But with Raybuntu’s rb-krypton19 build for odroid c2, no stutter,very smooth.
So, I think maybe Raybuntu can fix this issue.


#30

Yes, I tried it and answered to you on LE forum…

Maybe you didn’t implement the commands properly, or your C2 does not like disabling dirty regions…


#31

I typed these code in advancedsettings.xml

<gui>
<smartredraw>true</smartredraw>
<algorithmdirtyregions>0</algorithmdirtyregions>
</gui>

reboot ,no work.
and the CPU’s temperature raise high.


#32

8.95.5 the issue remains.


#33

This is my advancedsettings.xml:

<advancedsettings>
  <gui>
    <algorithmdirtyregions>0</algorithmdirtyregions>
    <smartredraw>true</smartredraw>
  </gui>
</advancedsettings>

First line stops stutter on files like this sample
Second line eliminates stutter on files like this sample, which first line does not eliminate.

So I keep both lines and CPU temp does not rise at all.


#34

I tried already, no matter which line first ,all stutter.
Anybody who have odroid c2 Please playback the sample mkv, confirm stuttering or not.
Thank you


#35

I have the same problem, stuttering with subttiles, seems that a frame is lost or doubled when sub appears.


#36

Yes, that’s what I said stutter meanings.


#37

What box? On all video formats and frame rates?
Do you have dirty regions in advacedsettings.xml disabled?

Do you have stutter with an overlay (like CodecInfo or PlayerProcessInfo) on the screen when you watch the video?


#38

Minix U9-H CoreELEC 8.95.5. It happens on H264/265 codec video file.
Dirty region is not modified in advancedsettings.xml.
I have a stutter also when CodecInfo is displayed.


#39

This is the only way to stop subtitle stutter on S912 boxes that I know of; put these lines in your .userdata/advancedsettings.xml file:

<advancedsettings>
  <gui>
    <algorithmdirtyregions>0</algorithmdirtyregions>
  </gui>
</advancedsettings>

#40

Seems to work. I didn’t know this settings. Will test it further. Thanks!!


#41

I’ve found on my S912 box that using the above settings does get rid of subtitle stutter, but makes the cpu (checked via top in ssh session) sit at 50% for the kodi.bin process whilst idle.
This causes the boxes cputemp to jump to the mid 70’s celsius.
Removing the above settings drops cputemp back down to the mid 50s, but re-introduces the subtitle judder/stutter.