Support added for S905X2, S922X and A311D!

Yes, x96max 4/32g

@Mobigeek, @ragico
4gb S905x2 users could try this dtb
g12a_s905x2_4g.dtb (71.3 KB)
if it works than please check ethernet

Edit: new link until it will be available in nightly:

try it in pen usb in port usb2 and 3 don´t boot, sd card don´t boot to.

did you rename it to dtb.img?

yes rename it to dtb.img

What method are you using for first start?
If Toothpick method doesn’t work for you, you can try Terminal Emulator method

i use Terminal Emulator method, i will try Toothpick. and report.

I tried. It boots from SD in the USB adapter connected to USB3 slot. No network connection shown in Coreelec settings. Either ethernet and wireless.

the same sd card in sd card slot and pen us in port usb2 and 3 dont boot for me

Does your box have 1gbit speed in Android?

I dont know, it should have it. The box is sold as 1G ethernet

I believe the X96 max S905x2 boxes are 100m ethernet for the 2GB/16GB boxes and 1GB ethernet for the 4GB/32GB and 4GB/64GB boxes - that is the latest I can find. I have just bought the 4GB/32GB model and waiting for it to come before installing CE on it.

I made 1Gbit change for 4GB version, but it doesn’t work.
Ok, we will check later. Something more need to be changed.

On Beelink GT1 mini 4/32 GB ethernet works.

I have Beelink GT1 mini 2/32 with 905x2. the coreelec will work? what file img.gz to use? Thank you for answer.

To me in a tanix tx5 max(S905x2 4/32), I get this error. I have already tried with different SD and DTB with the 2GB and the 4GB that you have put in the thread.

Boot from USB and not from card slot.
You can use a SD card to USB adapter or maybe a USB stick.

i have try o mine USB stick no luck

Perfect, so boot correctly. In my case, wifi does not work either. The wifi of my box is: RTL8822

mi bad as using rong image, boot ok using usb stik, and ethernet is working, ram 4g ok, wifi ins´t, comand powers down ok, but don´t powers on de device