Support added for S905X2, S922X and A311D!

I am asking help for a friend of mine who has bought a K92 s905x2 4g/32g and have installed on sd card the latest nightly. Everything works fine but the remote does not work. I know there are guides in this forum on how to make the necessary files yourself. Unfortunately I am completely ignorant in these things and do not understand what to do and how to do. I ask someone here to give help. I run ssh remoteinfo and I post here the link together with a remote picture. Thank you

Unless someone here has the same box, and creates a remote configuration file, then shares it, we can’t help you.
Following the guide step by step shouldn’t be that hard. All you need to do is copy and paste the commands.

Another option for you is to simply go over all of the already available remote config files, maybe one of them will work.

Thank you. Will try

It’s got more than 50% more power though. :slight_smile:

6 faster vs 4 slow CPU cores.

Ofcourse not we will continue to support all devices as we always have.

@ragico try that one, it’s the same remote control config, posted few post up

As Adam said and you have to recognize, once you’re on board of CoreELEC support, no one gets left behind.


Unlike the one size fits all approach of LE “If it aint mainline it aint supported”.


I posted my remote config here in reply to your query 8 days ago …

Thank you, I did try your remote configuration and does not work.

Thank you. I tried your files and does not work.

I did follow step by step the guide and created the 2 files and put them where appropiate in CE. But at no avail.
Thank you

The only remote that works is my old trusty MCE with Usb dongle.

Please open a thread under the remotes subforum and someone will help you, announcements is not a Q&A place for support related questions.

I have a t95q and my remote looks exactly the same. Not sure if my configuration file will work for your friend, but you can give it a try. If you scroll up, I have posted it earlier. Your friend still needs to ssh into box and create the file.

Sorry for this. My bad.

Installed nightly dated 24/07/2019 on my H96 Max X2 (S905X2 , 4g/32g) using g12a_s905x2_4g.dtb.

Boot: OK
Ethernet: NO
Audio: OK
Remote: NO
Playback: Mostly OK


WiFi chip J6330 is in H96 Max X2 (analog AP6330, MIMO 1x1),
I need wifi. Can the firmware for this wifi chip be included in the next update?

I just got an automatic update to today’s nightly build. I can confirm 4K videos work now on T95Q.

I have also tried H96 Max X2 (S905X2 , 4g/32g) using g12a_s905x2_4g.dtb
I cannot get past Black screen on boot.
I have used Rufus to load CoreELEC-Amlogic.arm-9.0.3-Generic.img
I press in button in audio socket and turn on power with USB/SD in either of the 2 USB ports
and release button but nothing happens .
Any clues please?


I think this is the image you should be loading for s905x2, CoreELEC-Amlogic-ng.arm-9.1-nightly_20190725

Thanks Billv
There are 3 files all have slightly diff names
I will try the generic one.

Everything works well on that device? I’m thinking about buying one for CE.