Tvheadend 4.3 addon

You can choose. Personally, I am using 4.3 quite a time for now. Although, do not use both in the same time.

Please note, all your settings should be compatible between 42<->43 just fine, you can use your configs (like muxes, channels, etc.) from tvheadend42 to tvheadend43 just by copying correct ones to the correct new folder within userdata folder.

1 Like

Try to update CE addon repository for any updates.

Already tried that, and also tried clearing packages.


Looks like addons has not been getting built for nightly for some time, looking into it.

TVH 4.3 is definitely in stable repository though.

Issue has been fixed, TVH 4.3 should appear in nightly addons shortly.


I can confirm it is in the addons now. Unfortunately, after turning off TVH42, TVH43 doesn’t work out of the box, it doesn’t get the old settings from the TVH42 installation. I had to go through the tool I wrote some time ago. Maybe it helps someone else as well to save a lot of time.

Why would it get the old settings?

It’s a separate add-on and not an update.

I was not precise enough. I meant the channel tags. In case you use them it is cool to just copy them instead of adding it manually.

I can open 8K broadcast with Tvheadend 4.2, but not with 4.3 tvheadend.
What setting do I need to make?

TVH 4.3 is a lot flakier on scanning for new channels, will probably stick to 4.2


No channel scanning problem.
I watch with 4.2 but I can’t watch with 4.3.

Thanks, tvheadend43 already works in amlogic version, but the addon doesn’t appear in amlogic-ng. Can you fix it?

It should be there as they both share the same add-ons repo, have you tried to refresh/update your repos?

Although it may seem stupid, the tvheadend43 addon does not appear in amlogic-ng, nor is there any possibility to update addons or repositories (tested on x96air).

It’s definitely there because I just checked.

You need to refresh your repositories.

tvheadend43 is available in the warehouse.

Finally tvheadend43 has appeared on amlogic-ng but I have had to suffer on my x96air with CoreELEC 20200410 installed in the internal memory:

  • ‘Reset System Settings to defaults’ option did not work, surprisingly!
  • ‘Reset CoreELEC to defaults’ option did not work, surprisingly!
  • but full deletion of /storage/.kodi from SSH did work

The 4.3 version has been there for a few days. I already had 4.2, I just disabled that, installed 4.3. Both versions work. I also have a 4.3 version on my synology.

Most problems with tvh, I put down to poor tv signal.

I found that with 43 there were 35 muxes got stuck in the scan que on repeated rescans. Some of those muxes were essential for my needs. Thats got to be a sensitivity issue but unacceptable for my needs.

The funny thing is that 43 is still way behind the current versions of TVH. Every release seems to introduce a whole raft of problems which is the reason why people stick to the tried and tested 4.2 version.


I found a problem with the muxes, Original Network id, it was 65536 so never scanned properly, I edited the muxes, put everything to auto, eventually the id changed to 9018.

I can’t remember the version this was a problem. UK Freeview