Tvheadend 4.3 addon

Issue has been fixed, TVH 4.3 should appear in nightly addons shortly.


I can confirm it is in the addons now. Unfortunately, after turning off TVH42, TVH43 doesn’t work out of the box, it doesn’t get the old settings from the TVH42 installation. I had to go through the tool I wrote some time ago. Maybe it helps someone else as well to save a lot of time.

Why would it get the old settings?

It’s a separate add-on and not an update.

I was not precise enough. I meant the channel tags. In case you use them it is cool to just copy them instead of adding it manually.

I can open 8K broadcast with Tvheadend 4.2, but not with 4.3 tvheadend.
What setting do I need to make?

TVH 4.3 is a lot flakier on scanning for new channels, will probably stick to 4.2


No channel scanning problem.
I watch with 4.2 but I can’t watch with 4.3.

Thanks, tvheadend43 already works in amlogic version, but the addon doesn’t appear in amlogic-ng. Can you fix it?

It should be there as they both share the same add-ons repo, have you tried to refresh/update your repos?

Although it may seem stupid, the tvheadend43 addon does not appear in amlogic-ng, nor is there any possibility to update addons or repositories (tested on x96air).

It’s definitely there because I just checked.

You need to refresh your repositories.

tvheadend43 is available in the warehouse.

Finally tvheadend43 has appeared on amlogic-ng but I have had to suffer on my x96air with CoreELEC 20200410 installed in the internal memory:

  • ‘Reset System Settings to defaults’ option did not work, surprisingly!
  • ‘Reset CoreELEC to defaults’ option did not work, surprisingly!
  • but full deletion of /storage/.kodi from SSH did work

The 4.3 version has been there for a few days. I already had 4.2, I just disabled that, installed 4.3. Both versions work. I also have a 4.3 version on my synology.

Most problems with tvh, I put down to poor tv signal.

I found that with 43 there were 35 muxes got stuck in the scan que on repeated rescans. Some of those muxes were essential for my needs. Thats got to be a sensitivity issue but unacceptable for my needs.

The funny thing is that 43 is still way behind the current versions of TVH. Every release seems to introduce a whole raft of problems which is the reason why people stick to the tried and tested 4.2 version.


I found a problem with the muxes, Original Network id, it was 65536 so never scanned properly, I edited the muxes, put everything to auto, eventually the id changed to 9018.

I can’t remember the version this was a problem. UK Freeview

Didn’t have much luck with this one either.

Been using TVHeadend 4.3 on docker for way more than a year. I haven’t had any major issues with it but I only update it once a month or so. Maybe once I’ve had to rollback because of some issue but mostly I haven’t noticed anything.

I thought I’d give this a shot now that 9.2.2 is out, trying to simplify my setup once again and getting rid of docker.

First issue I noticed was that my primary DVB-C adapter doesn’t find any services. Tried to reboot, unplug everything from power, change drivers back and forth between TBS and latest kernel but without luck.
Then I used my secondary tuner and after initially scanning 3 out of 33 muxes it gets stuck. Tried that multiple times but each time the same thing happened.

Back to troubleshooting my primary adapter and then I noticed that CA client setting in TVH is Red (Disabled) instead of Green. Back in the day when running same tuner on Pi I remembered that if the CI slot has a CAM and it’s not properly initialized it doesn’t tune into any channels. (Not even free ones)
I unplugged the CAM and the card and managed to scan through all the muxes and it did find all/most of the channels. It was a bit slow compared to normal, something like 20 minutes.

I swapped between the addon and docker container to verify that the CAM is ok. Tried to manually start TVHeadend to see for any clues I still get this error

[ ERROR] linuxdvb: unable to query /dev/dvb/adapter0/ca0

I guess I won’t be moving away from docker just yet.

I didn’t have problem with scanning the channels, but the finished recordings (made with TVHeadend 4.2) disappeared from the list after I switched to 4.3.

I haven’t changed the path where recordings are stored.
Is there a way to getTVHeadend to recognize these files?

tvheadend43 is a different addon than tvheadend42, this means that the addon settings will be saved in a different directory. If you have not been careful to move the settings from the old addon to the new one, then you will lose the old settings.

I have a backup with the 4.2 settings. Is there a guide which files should be replaced?.