[Ugoos AM6b+] Help in placing remote.conf and making it work

I have just spent a couple of hours getting the codes and populating remote.conf file, following this guide: 02. Amlogic: Creating remote.conf from scratch · CoreELEC/remotes Wiki · GitHub

I have mapped all the keys from an old Terratec remote I had, which was recognized by dmesg, I plan on learning all the buttons on my Harmony remote and take it from there.

Problem is the instructions in the guide state to put the file in /etc/ but that’s read only on my box. I tried putting it under /storage and under /storage/.config but still it doesn’t seem to work.

I see that there is a remote.conf file under /flash but I can’t move or rename it, as it says it’s Read-only file system.

I attach the remote.conf file I’d like to use, in case I have done something wrong there (but I don’t think we are at the point where that would matter).

The output of remoteinfo: https://paste.coreelec.org/gCX7K

And remoteinfo output with remote2.conf in .config/ : https://paste.coreelec.org/pVnlG

Keymap editor addon doesn’t register any button press from the new remote. What is missing? Do I have to work on rc_maps.cfg too?

remote.conf (2.7 KB)

I had to put
remotecfg /storage/.config/remote2.conf
in my autostart.sh

I learned the power button on my Harmony from the original remote and everything is now working as I want it. “Just” need to program the keymap in Kodi to do the things I want. But at least I know how to do that.

I guess you could have used Windows media center remote as setup in your Harmony remote instead? Thats what i did for my one for all remote. Everything worked out of the box after that .

Why remote2.conf? Use remote.conf and it will be picked automatically.

Make it writable and delete the file

mount -o remount,rw /flash
rm /flash/remote.conf
mount -o remount,ro /flash

As mentioned, that wasn’t the case. It might be because of…

And I could do this now that I know, but now everything works as I want it, with both my Harmony and the original bluetooth remote working perfectly.
Is there a reason why I should change?

It is always better having original solutions if possible than workarounds. Because workaround you forgot and got into troubles next time because you forgot what you did last time.

But what’s the workaround here? Both the remote2.conf thing and the autostart.sh thing are mentioned on the Wiki for remotes (04. Adding a second remote · CoreELEC/remotes Wiki · GitHub).

Looks like wiki is wrong in this details.

You can have /flash/remote.conf and /flash/remote2.conf.
Or /storage/.config/remote.conf and /storage/.config/remote2.conf.
And both remotes would be added.

But not /flash/remote.conf and /storage/.config/remote2.conf - base folder must be the same.

I… what I am missing? I see you listing in three different lines two file positions. All identical, line by line. Yet you write “But not”… and “Or…”

I must definitely be missing something

Sorry, bad copy/paste.

But the wiki is correct - there is next part which tells what I wrote above.

This method works ONLY with CoreELEC:

    Rename the second remote.conf to remote2.conf
    Save in /storage/.config/

Multiple remotes can be added this way.

And this is what I did. The only extra thing I needed was to put remotecfg remote2.conf in autostart.sh. I don’t know why it wasn’t picking it up but it wasn’t.

I wrote a different message for a different problem I have now, not to go offtopic. Since you seem very knowledgeable I’d appreciate immensely if you could read that too. :smiling_face:
And thanks for all the help, it’s much appreciated.

Autostart.sh is not needed.
As I wrote you need to have remote.cfg and remote2.cfg in same path (/flash OR /storage/.config). Mixing the path doesn’t work (and this is what you had).

Ok, maybe I get it now. I could copy remote.conf from /flash and put it alongside remote2.conf in /storage/.config and have it work? As an alternative to deleting the file from /flash, I mean.

exactly like it is written on wiki

Does anybody knows whether Flirc Skip 1s with its own dongle is working on Ugoos AM6B+ with CoreElec? If not, is there any recommend remote other than the provided one which is confirmed to work properly with this device?
Thank you in advance

I’m happy with this remote for Am6b , set up as Windows media center remote . Then used Kodi remote map addon to fine tuned some extra functions

1 Like