Ugoos X4 Pro with Amlogic S905X4

I would be interested in your box and can pay the shipping if it’s going to go to the garbage. I am not allowed to PM, but I can write you my email in this topic if you’d like. Thanks

Are you located in the United States? This can be very doable.

I’m in Canada… USPS First Class to Canada is pretty inexpensive though.

Go to the freaktab forum and PM me. clarkss12

1 Like

Is there any Google certified box with L1 that cam boot CE from micro SD card? I would he interested to know if it exist

Surprisingly, YES.
I could not believe it was possible, but Flette found one that did. The Mecool KM1 Deluxe has been verified by him and I, that CE dual boots on that device.
Mecool KM1 Deluxe ATV Google Certified Android 10 TV Box Amlogic S905X3 Android TV, Prime Video 4K, Dual Wifi Set Top Box 2G 16G

That thread was a bit confusing to me. Does CE work fully on that box and have you found 2G/16G adequate to play media from the LAN if no add-ons are used?

Thanks

I don’t think CE support BT on any S905x4 devices.

One of the confusions in reviews like this are the mix of Android use and CE use. There are have been a lot of general complaints with Kodi on Android with 8GB or less storage so the 16GB emmc helps there. Since CE doesn’t currently use emmc, right now internal storage isn’t a issue.

2GB is pretty good RAM, you say no addons but if you run a PVR backend, Emby or Jellyfin, Docker etc you might want more.

Ugoos appears to be the best CE supported S905x4 device if you want official vendor supported Android firmware updates. Of course you still have to aware that there clones out there.

What I wanted to hear was if the DDR4 memory made things noticeably faster. Now that Team CE added JL2xxx support for cheaper devices with 4GB RAM this would probably be the big reason for going with the Ugoos.

That’s not right, Ugoos X4 and Buzztv X5 (on -ng) have fully working BT. This are only two examples.

Thanks that’s why I put that out there. It’s a pain for users going back and forth with Android though right?

Yep I can confirm that CE does indeed work on the KM1 Deluxe too (came with android 10).
Mine arrived today, got a good deal on it and bought it knowing it may or may not work with CE as my trusty raspberry pi 2 running kodi is showing it’s age.

I used the latest stable image with the sm1_s905x3_4g dtb, boots from either usb port, haven’t been able to get it to boot from sd card for whatever reason.

Got the remote to work easy enough as it’s basically the same as the KM9 Pro remote with 3 extra buttons being the only difference (which I didn’t bother with).
youtube - scancode = 0x71
prime video - scancode = 0x73
google play - scancode = 0x72

Only thing that seems to be missing is bluetooth I think and led control doesn’t seem to do anything (didn’t expect it to tbh).
Boot with the av port reset button.

New to coreelec and was just looking around and thought I’d share my info. :slight_smile:

What about to mecool km6 deluxe?

Mecool is not a supporter of CE.

Where can i find the remote config files for UGOOS X4 Pro. This is the remote I have

Try remotes/MesonIR/Ugoos X2 Cube at main · CoreELEC/remotes · GitHub

I don’t know how use the MesonIR. Have been using the AMRemote remote.conf file with my other box, but the Ugoos X2 Cube don’t have this files on the website

Anyone have the remote.conf file for Ugoos X4 or Ugoos X4 Cube?

I bought the Ugoos X4 Pro 32GB. When I tried CE 19.5-Matrix_rc2 (Stable) with the Ugoos X4 dtb with unique Device Tree, I can get to CE but the USB port don’t work so I cannot complete the CE setup.

But when I tried CE 19.5-Matrix_rc2 with generic Device Tree for X4, it works perfectly and the USB port is working fine too. The wifi and gigabit lan all works fine.

Why is that the Ugoos X4 unique device won’t have working USB yet the generic dtb have working USB?

I also tried booting CE from the USB with generic device dtb and it won’t boot at all. Looks like its not seeing the USB port. I am using a USB SDD. However when I try booting the same USB SDD on my HK1 RBOX, it works. This is really confusing.

So can the Ugoos boot CE from USB? If yes, how?

Please try with latest nightly

The ne nightly with Ugoos X4 unique Device Tree on microSD card fixed the usb port so now i can setup kodi with usb keyboard and remote.

But both ne & ng nightly still won’t boot with the USB SSD drive. Is this because the Ugoos X4 bootloader can’t boot from USB port?