USB Dac Coreelec integration

Hello guys just bought a topping d90 wich btw kicks the sh*t out of my denon AVR.
im writing you guys to ask you what are the best audio settings so my dac can receive the signal untouched. I only have an S/PDIF and one Analog output and it appears that the passthrough is not working since i can chance the volume on the coreelec gui.
The dac is connected to an odroid N2 via USB.
Thanks in advance guys!

any help? the audio on moode sounds a lot lot better so i guess i’m doing something wrong on the audio settings, I’m on D90 SPDIF best match.

Your question is too hardware specific. Best to ask in a forum that features your dac hardware.

What audio devices do you see in the list? If you only see ALSA devices like HDMI and PCM, it’s possible that the linux kernel doesn’t have a driver for your DAC and just doesn’t pick it up as an audio device.
Also try running lsusb | paste in SSH and post the link, maybe that will have some clues.

Its not too hardware specific i guess.
The Dac is detected by the Coreelec build on my N2, i can select D90 SPDIF or Analog. outputs with no problem plus D90 SPDIF Passhtrough, the problem is that the audio appears to be “touched” by the software, since the audio quality is incomparable against volumio or moode builds.
So i guess i’m doing something wrong on coreelec i just don’t know what…
probably with an HDMI extractor that converts the signal to i2s the problem is solved easilly. still i’d apreciate your input.

Have you tried to set in kodi audio setting the bitrate to 192kbit and fixed?

As far as I remember this is what I am using for my Dac, but i only use stereo, as I like music

thanks for you answer @tavoc i’ll try that but i guess if you fixed it to 192kbit it will upsample signals with 44, 48 etc.
I’m using only two channels atm too, mainly music and movies.

As this is the sample rate, it’s a higher resolution for reconstruction of the audio wave. Therefore a higher value is more precise. It’s not a reencoding.
But I only own flac with 192 or 384 khz, don’t have any mp3

48 for example is 1/4 of 192 and therefore no loss here. 44.1 is more problematic, but as I said do t have any 44.1.

You could also try best match and dynamic. Then the DAC will get the exact sample rate from the music you are playing.

I am not aware of any way to bypass the software volume control when using a DAC with Kodi.

Shoog

@tavoc yeah no mp3 here either, but a lot of 44.1 flac files, anyway you are setting your output to analog or spidif?

Shoog probably with something like this if your DAC have an I2S input.
https://www.aliexpress.com/item/33029578710.html , passthrough the hdmi signal convert it to IIS and sent him to the dac.
anyway with D90 analogue output on the coreelec the audio seems much much better now, but im not receiving the correct signal, it always ouptuts on 48khz instead of 44.1 or 192 on any mode, fixed, best match or optimized.

Update: Bought the hdmi i2s converter, and now i have exactly the same audio quality on coreelec that i have on moode or volumio via usb. there is just more detail and transparency, , maybe it is a driver problem or some buggy usb output implemantain on coreelec software? i’d love not to use this converter. Any ideas?
i will test with the nightly matrix today if i have time. Best regards

You didn’t answer my question.

If it uses the ALSA driver, it’s possible we can do something about it.

ho sorry @TheCoolest i didn’t saw your question, i can see an ALSA; D90, Analog and an ALSA:D90 S/PDIF. The analog can’t output properly the different khz (don’t have the info about the bits), both sound bad, compared to the volumio distro or with and HDMI converter to I2S on coreelec.
i will run lsusb when i arrive home.
best regards.

I’m veering off topic bit here @mcintosh but could I ask a favour of you? Could you test the sound output from the N2’s onboard DAC if you happen to have the right lead to do so. CoreELEC will still “touch” the sound tho with control over volume.

For me, it sounds superb but I’ve nothing else to compare it to.

hi @sonofdibnah i know that the internal dac meausres pretty well, but atm i dont have any pre-amplifier so i can plug it and test it and give you an subjective opinion abou it vs the d90!

In that case, I think you should see D90 S/PDIF as an option in the passthrough list of playback devices.
You can pick it, and select the audio formats the DAC supports.

No problem. Got to say that I don’t understand why you’d need a preamp. I’d have thought you’d just have to connect to RCA audio inputs on your AVR using a 3.5mm jack to twin RCA lead. That’s how I connect to my amp. Not true line level cause CoreELEC volume control applies but it can be set at max without any distortion.

None of my business, just curious.

@sonofdibnah i connect the n2 to the dac via usb them to my power amp wich connects to the speakers, if i connect directly the power amp to the N2 dac i lose the hability to control the volume, wich can lead to a speaker blow

btw since you have and avr, i sold my maratnz sr6011 after i bought the d90, is just iso much better… i lost the hability for multichannel but fk it, i prefer quality instead of quantity.
i believe that even a topping d30 can beat a top notch avr atm.

http://ix.io/2Oi8

Here it is!

About | FAQ | Terms of Service | Privacy Policy | Legal Notice