❓ Which DTB do I use?

According to some sources, this box needs to be rooted to let it boot anything else than Android.
At least I think so as nearly all websites I’ve found were in Indonesian language.

Still same relkai, won’t boot

It could have a locked bootloader. Or you’re not using the correct DTB for it, maybe it’s not a S905X but something else.

here is the log
i use gxl_p212_2g.dtb and renamed to dtb.img
s905x.log (68.0 KB)

please help

Have you tried S905 or S905D or S905W DTBs?

Never, i just tried gxl p212 xxx
I’ve give the log… hope you can tell what i should to do

You should try the other DTBs.

Have you seen my log?
The problem is dtb file?
I’ve trie all s905x dtb

Any idea for an Alfawise S92 ?


I confirm!

Alfawise S92 boots using gxm_q201_2G_1gbit

Many thanks!!!

@TheCoolest: I humbly suggest you use “or” instead of “/” when there are more than one options: I pulled my hair for 2 minutes trying to find your suggested file in the tree folder until I realized you meant one or the other. :laughing:

PS: Damn, this is a lean and efficient build! I love it for an Kodi only box!!!


Wonder if anyone can give me some guidance? I have a Sunvell T95M 2G (s905x) and I am moving over to CoreELEC. I have built an image on a SD card but it won’t boot if I use the p212 dtb files. If I use the p200_2G files, it will boot but the remote won’t work, so I cannot progress past the configuration wizard.


This means you have a box with a S905, not S905X.
You can connect a USB keyboard or mouse to pass the initial setup screen, and enable SSH.
Then you can follow the normal remote setup guides.

1 Like


Got past the config wizard, found the right dtb (as networking wasn’t initially working) and then followed the guide to install the remote codes. Had to use the T95S codes but all working. Many thanks to you and the other contributors on this site for sorting me out.

Hi, I was just about to try LE on some H96 Max (S905X2) boxes with 4G/64G, when I discovered the existance of CoreElec, so I thought I’d give it a go! I can see a DTB for the H96 Max, but do the memory figures matter, as these differ in the DTB description? Is anything hard-coded in the builds, or will it just use all that’s available? If not, can I use the lower spec DTB temporarily and put up with the lost space?

You should use the correct DTB for your device, taking into account RAM size and Ethernet speed.

OK, So from that I take it there is no correct DTB, a. So what should I do now, if Iwant to try and run CE on these boxes? I see someone appears to have had some success with g12a_s905x2_4g.dtb which is logical as the chipset and memory size appears to be the same, so in the meantime I’ll try this too.


You can’t compare CE to LE. We have a generic image, and generic DTBs for the S905X2 SoC. Those DTBs start with g12a_s905x2_ and then have the ram size at the end, you need to use a DTB that fits the RAM size your box has. If your box has 1Gbit Ethernet, you need to use the matching 1gbit DTB.

Hello. First post and was coming to ask the same thing. I’m installing to an Odroid C2, but the device tree at https://coreelec.org/dtb/ shows a dash? Does that mean I don’t use one? Sorry for my ignorance.

Never mind. I guess I should have just looked in the device trees sub-directory. Staring me right in the face. Thanks.

i have a Xgody S10 Box with isnt supportet by CE, is it possible to extract the DTB by my self ?