Which mini keyboard to use with Odroid N2?

#1

Hello,
Just ordered the N2 and will be installing CoreELEC on it. I use Rii mini keyboard on my other tv boxes but what I don’t like is the wakeup delay for the keyboard. I have to press a button to wake the keyboard up and it takes a few seconds to connect.
If I get a mx3 that is IR remote, is there a delay like on my Rii keyboard?
Will these type of keyboards be plug and play with the odroid N2?
What remotes/mini keyboards are you guys using to operate CoreELEC on the N2?
Any advice/opinions is appreciated.
Thx!!

#2

I have 2 Rii i25 at home, and they work great for me.
A single click and the keyboard wakes up immediately, there’s no delay that I noticed.

#3

Same here with my Rii mini i8+(original), instant responce…

#4

Ok thx for the info, are these keyboards plug and play on the N2 like they are with android boxes?

#5

Yes, they are.

#6

i use the minix a2 lite air mouse… has ir on off and radio for the rest [dongel] only off setting, not the on works… (doesnt wakeup i think)
how is the rii i25?

#7

I just ordered the a2 lite a couple hours ago. I almost bought a similar cheap brand model but decided to go with the minix, just hoping it lasts a long time and hope I’m happy with it.

#8

I have this minix remote too. For the N2 you can setup the power button to wake it up too. It’s a nice remote and it works ootb with the N2. I want to change some buttons though to be even more ootb.
But normally I don’t use IR remotes.

1 Like
#9

can i ask how to setup to wake on?

#10

You have an N2? You need to edit /flash/config.ini

And add the remotewakeup keycode.

2 Likes
#11

http://ix.io/1HLd
This is my config.ini

Basically just add:
remotewakeup=“0xE718FE01”

2 Likes
#12

sorry for dumb question, where do i locate the config.ini file? i cant find it.
I have the N2 and just received my A2 lite remote, i would just like to get the power button working.

Thanks for any help.

#13

In /flash. You’ll need to ssh to the box or use a tool like winscp.
Or you can connect the SD card to the PC and edit it directly on it.

#14

Sorry im new at this, here is what I did:

  • using putty i made /flash writeable
  • opened winscp went to /flash/config.ini and added remotewakeup=“0xE718FE01” to the bottom
  • using putty i made /flash read only
  • Rebooted

Unfortunately the power button still didnt work.
Anyway im gonna reflash my emmc and start over just in case i screwed something up, when i did a hard reset in the coreelec settings the remote keycode i entered was still there, i thought a hard reset would wipe all that but i guess not.

#15

Maybe your IR code is different:

Ssh to your box
systemctl stop kodi
systemctl stop eventlircd
ir-keytable -u

You should see your wakeup IR code.

#16

I followed steps you said, then pressed power button on remote and the same code u mentioned came up 3 times in putty.
On your N2 the power button will turn the unit on and off? Not quite sure why mine didn’t work. I have already reflashed my emmc I will try and add the code again as you showed above.

#17

I can only advice you to edit config.ini in CE not some windows editors.
If you only add this remotewakeup you can overwrite your config.ini with mine. Be careful it will overwrite your config.ini!!!

mount -o remount,rw /flash
wget http://ix.io/1HLd -O /flash/config.ini
reboot

#18

ok thanks for the advice. i will give it a last try.

#19

i had the same results in putty… two lines with remotewakup code… and remote didnt work
couple of days later i did again a
'Ssh to your box
systemctl stop kodi
systemctl stop eventlircd
ir-keytable -u ’

the result was just one line the same as Ray’s
So i copied from Rays config.ini the remotewakup line and pasted in mine…
After that powerbutton works…
make sure do not put a # befor the line… i had one and i think that was the mistake.

To Ray
i used win 10 notepad… what editor do you recommend? if not windows

#20

ok thanks for the response. I also copied config.ini file as Ray said with this command:

wget http://ix.io/1HLd -O /flash/config.ini
and it did update my config file but still no luck. not sure why it wont turn off my N2. I will play around with it a bit more see if i can get it working. If not, its not too big of a deal, i will just keep my box on 24/7.

On a side note, the N2 is so nice. I love it. Being in Canada i paid too much but im glad i bought it.
The Minix A2 lite is really nice as well. Really happy with both.