Windows 10 stopped seeing CoreELEC on network

Hey guys,

I hope you’re all doing fine.

Well, I just updated my CoreELEC device (Odroid C2) and Windows 10 suddenly stopped seeing it on my network.

I have an external HD attached to C2 and as able to access it from Windows 10 just fine before the update.

I’ve tried the usual…Rebooting, Powering off/on…Rebooting the router…Nothing happened.

What happened? Is there any way to fix it?

Thank you very much in advance,

M.

Did you double check that samba was enabled?
Also you might check the samba security levels.

1 Like

That is an issue I have had from the early days of LibreELEC. LibreELEC hijacks the network master. Run this network scanner and see what your network master is. When LibreELEC hijacks the master, NOTHING shows up under Windows explorer…

Here is the link to the network scanner program, it is freeware and is excellent. The only way to solve your issue, is to remove the power from your CoreELEC device and leave it disconnected until, one of your other devices assumes the network master. I have been fighting this issue for several years, since I moved from OpenELEC to LibreELEC…

1 Like

Maybe this would help?

1 Like

@John Boyz I don’t understand what you are saying?

@clarkss12

Ha! :smiley: Just noticed it was your own thread I linked to :smiley:
I understood a solution to that problem was in the post.

@Morguito

Check the SMB settings in Settings - Services … my PC uses SMB1 which was not set as minimum with similar results to yours.

1 Like

@JohnBoyz, as far as I know, that solution would have taken care of the issue, but I am not sure it has been implemented, I have not tested it with the latest version.

1 Like

I am attaching a couple of screen grabs of what my lanscan looks like and my Windows explorer. If i turn off my Tronsmart (or reboot it), then, CoreELEC running on my Mecool M8S Pro (Amlogic S912), will grab the network *master. Nothing will show up under Windows explorer.

1 Like

@Morguito, are you saying you solved your problem by changing the SMB settings in your Windows 10??

Hey guys,

Thanks everyone for the replies.

Actually, I did find a relatively simple workaround for this issue.

All I had to do is:

  • In Windows 10, double left-click on “This PC”…You know, that usual PC icon that’s usually placed on the Desktop.

  • Then right click anywhere on the empty space under “Network Locations” and select “Add a new network location” on the context menu.

  • Then just type \\CoreElec\ (or whatever is the name of your CoreELEC install) and click “browse”. (In my case it was \\CoreElec\Media Drive)

  • Then you can browse CoreELEC until you find the folder you want to share, and then add it as a shortcut to your “Network Locations”.

Let me know if this works out for you as well…Of course, I’d rather if this was done automatically, but you know, nothing is ever easy when dealing with Linux stuff…:laughing:

Cheers,

M.

That work around works, but is NOT the correct solution. I already have several “links” to my different devices because of this issue.

1 Like

@Morguito, Changed the settings to SMB 1, but did not help…

1 Like

Yes, agreed…The solution is to make it work out of the box, otherwise it will keep driving noobs like me crazy on every new update…lol

Do you have any networked devices that are on 24/7 other than your CoreELEC device?? Did you download that lanscanner app and see what it shows??

1 Like

No, my C2 running CoreElec is the only device I have running 24/7.

That Lanscan app didn’t even work. It says “System error 64 has occurred.The specified network name is no longer available.” when I run it, even as admin.

That is what it shows when CoreELEC or LibreELEC hijacks the network master. If you remove your C2 from the network, another device will become the master and the lanscan will show which device is the master. Look at the two photos that I attached.

I powered off my Tronsmart (Windows 10 microPC) that I leave running 24/7 which was the master. The my CoreELEC device took took over the master so nothing shows, same as yours.

If I did not have the Tronsmart running, then my Synology would take over as the master, and everything would show again in the Windows Explorer and the Lanscan app.

This looks like a script from a Lord of The Rings type of movie, you know, with all these masters taking over each other… lol

Jokes aside, there should be a setting in CoreElec called “do not take over”, or something like that.

Hahaha, Morguito… that was funny. However the cure is simple as I posted in one of my earlier post. I can’t test it because the I can’t change the file because it is locked…

This all they have to do to solve this issue, and I have been fighting this issue for at least 2 years.

The following are default values for the master selection process

local master = yes
preferred master = auto
domain master = auto
os level = 20"

"Insert the following line to ensure that this device doesn’t become the local master browser:

Code:

local master = no"

1 Like

Both
/etc/samba/smb.conf
/run/samba/smb.conf
in this latest install (905 Tanix Tx3 mini 8.95.4.1)
seems to have that option commented out …

 # The following are default values for the master selection process
 # local master = yes
 # preferred master = auto
 # domain master = auto
 # os level = 20

Does this appear in another file?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice