9.2.1 Discussion

On downgraded 9.2.0, I can only select HDMI (no multi ch.) and it sounds very weird. It generates high frequency distortion sounds and doesn’t play audio correctly. With 9.2.1 I tried all the suggested approaches but none of them seems to work. (I think others are still stuck too). The guisettings adjustment gets reset after loading any movie, resetting display calibration is not possible because I can’t see the controls. I’ll try to set the HD video calibration as default tomorrow. Maybe that works…

Oh thanks, that didn’t catch my eyes. I’ll try that tomorrow!

Sorry that is not the case, we are using the Amlogic buildroot kernel presently which is completely different from the Amlogic Android kernel. Video playback is not broken on CE.

This discussion is out of the scope of this thread however I’m fairly confident that your content will work on our upcoming kernel, if you message me a link to some content you have trouble with now then I will be able to confirm it for you.

I also have occasionally experienced an odd audio issue with my N2 running 9.2.0. The very first time I ever attempted to play a 4K .mkv file w/ Atmos, there was a very loud ‘buzzing’ sound. It reminded me of when video/audio drivers would crash on PCs years ago and a buzzing would continuously sound until the PC was forced to shut down.

The most recent time it happened, I confirmed it happened for any 4K Atmos .mkv file I tried to play. I was able to resolve the problem by switching the Sound Mode on my receiver (Denon X8500H) to Dolby Surround while navigating the KODI menus before launching any content. No other system settings were changed. After doing that, each file played correctly in regards to audio. This second occurrence happened after a power cycle of the receiver, so I don’t know if something got fouled up there and if it will continue to behave now that I’ve changed the Sound Mode. I’m not sure what the root cause is, but if it happens again I will try to play varied content (ex. 1080p without Atmos) to see if I can narrow it down.

New guy here. I updated to 9.2.1. and thought all was fine till I went to play UHD movie. The movie appeared too large on my screen and not centered correctly. I tried everything I could but no result. I have now reverted back to 9.2.0 and everything is fine again. I have odroid n2 and LG TV with Onkyo receiver. I have disabled auto updates for now.

Ant suggestions ?

@umbala does turning off Settings > Player > Videos > Adjust Display Refresh Rate make any difference with your problem files?

Thank you. Worked perfectly.

I cannot use the built-in debug log in latest coreelec 9.2.1 on my n2 that’s fresh installed, “pasting log failed, please try again” anyone had this issue?

If the log is too big then it will fail, you have to reboot, reproduce issue and then produce the debug log, this will minimise it’s size and also make it easier to read.

WOL on Odroid N2 seems to be broken since the 9.2.1 update ! Do you have the same issue ?

9.2.1 download and install, working fine. android s905x x96 xgody box.
strange in the menu coreelec updates dosesn’t show. All 9 versions except the current 9.2.1.
Otherwise all good.

Thanks for the reply. I’ve always had that option turned off (as well as Sync playback to display) on both CE and Android version of KODI.

10 posts were split to a new topic: Update notifications

Do you have a sample on that this issue can be always repeated?

No, I don’t. I have to revert to 9.2.0 and do not have a chance to check it again. It was ordinary .mkv files - by the Synology NAS by the nfs share. When I unpause video sound begins immediately but video starts after maybe 3-5+ seconds. Video and audio stay synced. In 9.2.0 video and audio starts together.

@boot2k3 and @victprDUA: I have this exact same issue.
Happens on all my MKV’s, wether it’s something smaller like a series episode or a Blu-ray remux.

Files comes from SMB shared on a FreeBSD ZFS server. SMB shares are mounted using scripts.

How would you like a sample?

1-2 minutes sample on that I can repeat it always… You can share it somewhere and send a link in private message
I can repeat once on my samples but not another 10 attempts… So it takes a lot of time to find where it started…