Booting Odroid-C4 from EMMC

Hi @everyone,
I got stuck with my Odroid-C4 and I don’t know what to do next.
I can install the CE Image to a sd-card and the system will boot. But when I try the same procedure with the EMMC, the SBC will not boot and don’t show anything on the screen. After powering the SBC, the blue light is always on, but does not start the blinking as with a sd-card.
I tried 2 different SBC’s, 2 different EMMC-Modules, the Matrix19_rc2 image and the 9.2.7 image.
I can install an “armbian” on the EMMC and the SBC will boot, so I expect the EMMC is working. I can install the images to an SD-Card and the system is booting. I also tried to boot from sd and “dd” an actual image to the EMMC - same result, not booting, only a steady blue light (red is also on).

Can someone please help me with this problem.

Maybe try this first:

I tried, but the tool tells me, that the platform is not supported

Can you please try to flash Ubuntu Mate on emmc? And use HK Etcher tool variant for flashing. HK Etcher for Odroid

Have you tried this method: insert emmc in a (compatible) USB adapter, burn the image like you would for an SD Card of USB Flash Drive.

image

There is also this: CoreELEC - Ways to install CoreELEC to eMMC without the eMMC module writer, and this: Odroid C4: Installing CE to eMMC via SD card but ymmv.

I flashed “Armbian_21.05.4_Odroidc4_buster” to the emmc and I could boot the SBC from EMMC. Is there a difference when I try the Ubuntu Mate image?
I did all my tests with “Win32DiskImager” and I also tried with “dd” on a Linux Mint. With both methods I could boot from an sd-card, but only Armbian was booting from emmc. Therefore I think the flash-process is working in general.

Thanks for your help.
I already found this topics and tried Method#3, as I wrote " I also tried to boot from sd and “dd” an actual image to the EMMC". The whole procedure was working without an error, but the system didn’t start from emmc.

I want to try to debug the boot process. But I’m not sure which pins I have to use. UART Connector and J2 Pins do not match very well. Please correct me:
VCC → Pin1 (3.3V)
GND → Pin9 (GND)
RX → Pin8 (TXD1)
TX ->Pin10 (RXD1)
(UARTPin → OdroidPin (NetName))

The (I) connector in the image is the UART connector. In the link you posted there’s a description of each pin. Forget about VCC, you only need ground, Rx and Tx.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice