Can't Run Any TVHeadend Add On

#1

Hello, I’m new to Coreelec. I want to use TVheadened Add On. I clicked on Add On Browser/Install from Addon Repository/Coreelec Add-ons/PVR Clients/TVheadened HTPS Client After I installed it I can’t find the click on “Run”. I tried it on several add ons but “Run” on can not be selected in any of them. I’m using Coreelec 9.01. I also had the same problem on Libreelec 8.2.3… I’ve uninstalled and I tried Coreelec but it hasn’t fixed my problem.

0 Likes

#2

In simple terms. Is this a fresh installation?

Have you got tvh server installed? If so leave this with the default settings.

Then install tvh client, in the client config, set the ip address of your server, user name & password

after a reboot, open a browser with the ip address of your server

come back when you have done that

1 Like

#3

You need to read a bit more on how to use these 2 Addons.
Hope this helps.
Tvheadend.pdf (8.4 MB)

1 Like

#4

I have two problems. First, Tvheadand is installed but (run) is not active. (This is the same for all add ons on my Coreelec Kodi, they can be installed and updated but (run) on is not active.) Second on the PC Tvheadend Setup Menu TV Adapters are not listed. However they were listed while Libreelec was installed on my box.

0 Likes

#5

Yes, this is a fresh installation. I have installed tvh server. I set the ip address, so username and password but after the reboot, it doesn’t accept my username and password. So I click on Default login… I click on Configuration… I Click on DVB Inputs… but my TV Adapters are not listed. However they were listed on Libreelec 8.2.3 Krpyton Kodi version.

0 Likes

#6

You need to load the correct dvb drivers.

from the link TVHeadend Server - KIII Pro Tuner not found

load the coreelec module drivers

I have had the problem, with tvh not accepting user name & password. If you can open the page, go to configuration, users & add a user with password.

or try configuration, general, Base, start wizard

1 Like

#7

Yes I’ve made some progress thanks to you. But instead of coreelec module drivers which were previously selected I’ve selected the third option LastKernel drivers and voila it worked and I have continued with the rest of configuration … selected my tv adapter which is Ava Link Universal LNB only … and then I have set my Network …Muxes have come instantly and then I Clicked On Force Scan but they are not being scanned right now. They are all Pending… I still have doubts about my Tvheadend Add on as “Run” doesn’t work… Don’t you think that’s my real problem or it’s not a problem at all?

0 Likes

#8

You don’t need run. Once set up, you then open/turn on live tv, & you should see the channels in Coreelec

As for pending, configuration, dvb inputs, tv adapters, highlight your adapter, (if you only see a folder you have the wrong adapter module)

highlight your adapter, you should see a parameters windows open. enable it, on the networks, from the dropdown select the network, save it, try scanning again.

if that doesn’t work, try config, dvb inputs, network, highlight your network & edit, then choose a predefined mux. then force scan

1 Like

#9

Thanks again… It has just started scanning right now. I’m waiting for the scan to finish now. I hope it works. After this I’m going to search for the remote problem and I hope I can make it because I’ve seen some codes are written there and I don’t have any even know where to write those codes.

0 Likes

#10

for the remote, you don’t need to do anything fancy, from CoreELEC 9.0.x Remote files

in the drop box there is a KIII zip file, read the instructions, that will tell you where to copy the files to.

then just reboot

1 Like

#11

The scan has finally finished but nothing found unfortunately. I reboot the box and clicked on Live Tv … I had a notificaiton from Tvheadend saying that The Access is Denied. I’ve turned back to the PC and typed my address on the browser but a communication box is opened…it asks for username and password…I’m typing them as I did while I first set it up …but it just doesn’t accept… and I can’t default login again… I know I’m being much … but I’m just about to cry…feeling so desperate

0 Likes

#12

try uninstalling the tvh server, not client.

reboot, & try installing again

1 Like

#13

It worked… The services are listed on my pc now… I can click on them and watch them on my PC… but not on my box yet… Do you think I should reboot it? When I click on Live TV… I see the menu only…but no channels yet

0 Likes

#14

did you enable live tv in core settings?

reboot can’t do any harm.

1 Like

#15

I rebooted but nothing has changed… I think I have to add channels first on PC… But there are so many channels to add… I hope it works… because I couldn’t find a way to add all of them at once…

0 Likes

#16

I’ve found something like Service Mapper… I think it’s a where I was going to add channels… Its a bit mapping them automatically right now… Silly me :yum:

0 Likes

#17

under networks, where you have your network name, edit, in the parameters window, select predefined muxes.

I use T2 so select crystal palace in uk. You need to select one, S2 nearest your location in the world.

then force scan, you should see muxes listed

0 Likes

#18

I think I know the answer. after you have scanned.

services, then map all services

1 Like

#19

Finally I can watch the channels on my TV. Thanks for everything. One last thing… Is there a practical way of editing channel list?

0 Likes

#20

only thing I know of, is to edit the webpage delete disable each channel. But it might come back every time you rescan

0 Likes