CoreELEC 19.1-Matrix_rc2 Discussion

CE 19 works n1 so far. I there a plan to move EmuElec Addon to matrix ? Or is it possible via dual boot?

Everything seems to works fine, except when i tried to transfer databases to MySQL, editing advancedsetting.xml and adding entries for SQL connection, from here:
[MySQL/Setting up Kodi - Official Kodi Wiki](https://MySQL/Setting up Kodi)

After restart, Kodi notified about system error, this one is from kodi.log:
2021-04-20 16:36:39.229 T:4818 INFO : Python interpreter stopped
2021-04-20 16:36:39.558 T:4836 ERROR : EXCEPTION Thrown (PythonToCppException) : -->Python callbac
k/script returned the following error<–
Error Type: <class ‘locale.Error’>
Error Contents: unsupported locale setting
Traceback (most recent call last):
File “/usr/share/kodi/addons/service.coreelec.settings/se”, line 7, in
import oe
File “/home/portisch/CE/CoreELEC/build.CoreELEC-Amlogic-n
coreelec.settings/”, line 86, in
File “/usr/lib/python3.8/”, line 660, in getpref
File “/usr/lib/python3.8/”, line 608, in setloca
locale.Error: unsupported locale setting
–>End of Python script error report<–

2021-04-20 16:36:45.774 T:4884     INFO <general>: initializing python engine.
2021-04-20 16:52:21.909 T:4766     INFO <general>: Skipped 1 duplicate messages..
2021-04-20 16:52:21.909 T:4766     INFO <general>: Quitting due to POSIX signal
2021-04-20 16:52:21.954 T:4766     INFO <general>: Stopping player
2021-04-20 16:52:21.954 T:4766     INFO <general>: Storing total System Uptime
2021-04-20 16:52:21.955 T:4766     INFO <general>: Saving settings
2021-04-20 16:52:21.982 T:4766     INFO <general>: Saving skin settings
2021-04-20 16:52:21.994 T:4766     INFO <general>: Stopping all

Something about locale settings, from shell i am getting this output for locale command:

CoreELEC:~ # locale
CoreELEC:~ #

We can not reproduce this error. Do a clean inst and try again, step by step until it breaks.
Then tell us how we can reproduce this error.

After clean install, no errors…

Previously, I was having installed few addons, new skin and I copied all configuration files in userdata/addons from old version of CoreELEC. Probably something there break database connection with MySQL, who knows…

Thank you for quick answer, I appreciate it.

I think the copy/restore of old data cause this locale issue.

Anyway it’s recommended to perform a clean install when upgrade to Matrix!

Hello … @Portisch with the version 19.1-Matrix_nightly_20210421, Mecool s905x2 4gb/32 wont boot.

It seems a problem when import the dtb.

With 19.1-Matrix_nightly_20210420 and 19.1-Matrix_nightly_20210419 works well.

hello. updated to rc2 and coreelec module drivers are gone. when i click on it it says no driver modules found. did something change in the dvb system?

They are moved to the CoreELEC repo and you need to install the addon by yourself.

1 Like

Hi, remains the problem with version 19.1-Matrix_nightly_20210423, in Mecool K9 pro (s905x2 4Gb/32), after update wont boot, stuck in initial logo. When i´m back to 19.1-Matrix_nightly_20210420 or 19.1-Matrix_nightly_20210419 everything is ok.

Nothing changed, no log, no problem.

Try clean install.

hello @Portisch
I did, but how i make a log, if after update wont boot ??

  1. Try a clean install.
  2. If it still doesn’t boot, the only way would be to use UART.
    You will need this CoreELEC Team SDIO Debug Board or open up the box and hook up to the UART pads. And you will need a UART to USB dongle in order to connect it to the PC.

Do you see the vendor logo and also the ce logo/animation?
When you see the ce logo/animation you just can try to open a SSH connection to make a log.

Everything works, with a clean install of version 19.1-Matrix_nightly_20210423.

My mistake was first use 19.1-Matrix_rc2, and then update with other.

Now everything works… Sorry my “noob”

Thanks @Portisch and @TheCoolest

I don’t understand why this release is marked as “stable”. Considering its performance, “alpha” would be a big compliment for it.

If you have some issue then please describe it and upload logs. Also do clean install to confirm that your issue still present.
In most cases you have bad addon or bad config restored from old version.

P.S.: please also be more polite and specific.
Your first post looks very impolite and unfounded

I think your knowledge is in alfa and CE is in BIG stable release
Over two months with S922 box everything works perfect

Good evening, I updated to version 19.1 Matrix RC2 from version Leila 9.2.7 on my Odroid N2, only I no longer find in skin settings the ability to see or hide (Movie out in the cinema) is a small thing but I liked it a lot. Maybe it depends on some addon that doesn’t work anymore. Thanks.problema kodi.bmp (4.9 MB)

rc3 is released, please update and use this new thread for discussion: