CoreELEC 19.2-Matrix_rc3 Discussion

You have the option to turn each option on or off.

Gives you more control to decide how you want each one to function.

Was it automatic? When? Which iteration? :thinking:

You can force HDR to SDR and/or SDR to HDR.
When both of the options are off, the system will run in SDR normally and will automatically switch to the appropriate HDR format when necessary.

I use CoreELEC only for LiveTV from my Enigma2 Receiver.

When I have both options disabled I have the problem for every UHD channel that everytime HDR is enabled and the colors are wrong.

All the channels here in Germany uses HLG for HDR.

The most content on the UHD channels here in Germany is without HDR.

But somestimes HDR is used by the channels.
And then the Automatic option enabled the correct HDR colors and when no HDR content was delivered the correct color without HDR was displayed (in the most cases).

Enable HDR → SDR.

I installed a new version 19.2 rc3 and now I have a problem with IPTV Simple Client switching the channel takes me 30s to the old version 9.2.7 it’s ok.

I am sending a protocol.


Updated my n2 from 9.2.7 to 19.1 rc3,done it in 5mins with odroid emmc module,this little stick makes it much easier and quicker,thought I might have problems as it’s recommended to update pettitboot first and I’m using the original pettitboot fw that came with my n2 but ive not found any problems yet,need to read up on how t o update that,but thx to the Dev,s the update process was easy

Check this: Audio dropouts every 4 minutes in MP4 playback - #7 by RickDB

no, unfortunately it didn’t help. Other PVRs work well.
I have no sound problems. Kodi freezes for a moment with each switch. I noticed some FFMPEG errors in the log.

I searched a little. And I’ve found that a lot of people have a problem with the IPTV simple client freezing under Kodi 19. Can you fix it?

@Portisch Used the above said DTB for AM6B, “Green LED” option came up in CoreELEC > Hardware settings but LED stay only Red. Tried many combinations as you said. Attached the dtb.xml for your reference.
Please help.
dtb.xml (7.3 KB)

Strange behaviour with rc3 , CE Refused to install pvr VDR VNSI. (installation failed)
here are errors from Kodi.log

2021-08-16 16:23:05.559 T:5275    ERROR <general>: GetDirectory - Error getting zip://
2021-08-16 16:23:05.559 T:5275    ERROR <general>: CAddonInstallJob[pvr.vdr.vnsi]: invalid package special://home/addons/packages/
2021-08-16 16:23:06.023 T:5275    ERROR <general>: Could not find suitable input format: x-directory/normal

Looks broken links, Any idea?
Thanks in advance

I got the same thing accessing CE and also Kodi repos in rc3

First try to refresh repository.

I tried installing pvr.vdr.vnsi addon from CoreELEC repo and something from Kodi repo. And both were installed.

I’ll try again later. Might have been temporary…

found it , just go to the left side menu ( in add-on) and make a refresh

refresh did not help. Waiting some more did :wink:

Created a github issue, widevine not usable for at least this addon:

1 Like

Try this command in ssh console

  sed -i "s|return system, arch|return system, 'armv7l'|g" /storage/.kodi/addons/
  sed -i "s|return system, arch|return system, 'armv7l'|g" /storage/.kodi/addons/

If this two files doesn’t exists adjust the path.

Update: Or you can try with tomorrow nightly - we identify the root cause in CoreELEC itself.

1 Like