Coreelec does not work on x3 mini box

Hi
I have a coreelec problem on the mini x3 box, I chose files similar to sm1_905x3_2g and sm1_905x3_4g files to create dtb.img but I couldn’t boot, the screen is black.
my box configuration is 905x3 ram 4gb, thanks.

I had a quick read HERE
The member used the 2gb dtb.img to boot.

No i haven’t installed coreelec i haven’t found the right dtb yet

I moved you here
Looks like same issue.
It has our attention.

@quanghieu @ee3si
What did you do to boot your X3 Mini.

I copy the files sm1_s905x3_2g.dtb and sm1_s905x3_4g.dtb respectively to the root directory of the memory card and rename it to dtb.img then click the reset button and plug in the power

How long do you keep reset button pressed after you plug in the power ?

I hold the reset button for more than 10 seconds after plugging in

I am referencing here, thank you

Try to hold it for 20 seconds. Also make sure that your renamed dtb.img does not have any additional extension like dtb.img.txt or something else

I tried to keep it longer but it booted straight into android, the dtb.img file had absolutely no extension.

you’re lucky

Looks as if your Reset Button does not work as it should. You have to try other methods to boot from the image on your uSD card. It’s usually done from Android, so research those methods.

I tried to find the vfd file first and then installed the CE on the mini X3 box but it also failed. DTB doesn’t accept to install. I have x96 air CE working perfectly. thanks

I will try booting with apk file to see if it succeeds. thank you

If your Android is rooted, then use “Reboot to Libreelec

1 Like

I’m VERY ANNOYED that i have to go SCOURING the INTERNET looking for a solution for this SHITBOX when you guys that own this thing could be wasting YOUR TIME not MINE .

https://arachnoid.com/android/SSHelper/index.html

And these are other issues you MAY have IF you get it to boot.

I finally managed to install coreelec
The installation was done through android with Terminal Emulator and sm1_s905x3_2g.dtb (so it is fake ram 4 gb).
KODI very fast without problems, Problems in coreelec but like

  1. Nothing lights up in front of the tv box
  2. REBOOT TO LIBREELEC from android does not work
  3. The tv box’s remote control does not work