HDMI connection lost with CE 9.0.0

#1

After update to 9.0.0, when I stop playing any video, the TV screen goes black, and the HDMI connection is lost.
My box is a h96 pro +.
Everyhing worked fine with 8.99.2.

0 Likes

#2

You can’t just drop posts like that without any additional information about your setup.
Your TV model, AVR model, what content were you playing (codec, resolution, fps, etc.), what resolution is your Kodi GUI set to.

0 Likes

#3

Follow the guide below and give us the additional information as TheCoolest mentioned in the comment above.

0 Likes

#4

Same here with MECOOL BB2 pro(S912) and TX5 pro(S905X) boxes,it happens while playing streaming live tv or playing videos and then stop them, Samsung display, 3840X2160. I installed all new on formatted SD card. For streaming I use IPTV simple client.

0 Likes

#5

Okey. @guil70, Follow the guide above and post a log so we can look into it. And give us some more information about your setup. We want to reproduce this and have to know every step to do so.

0 Likes

#6

Hi there.
I have the same problem.
I have already tried a clean CoreELEC installation, but after the restart, the problem still occurs.
My device is MECOOL PRO + and the TV is LG 55SK8000PBL.

log: http://ix.io/1BoX

0 Likes

#7

Ok, here is the log. I had to unplug the box after the HDMI lost then plug again. I hope the bug was logged.
Here is the link,

http://ix.io/1BoM

Here is another one,

http://ix.io/1BoT

0 Likes

#8

The builds now include a script that helps provide extra display debug information.
Please log into the box over ssh and when you loose signal run :

dispinfo

This will collect the information about the current state of the display/hdmi sub system in CoreELEC, and pastebins it and providies you a short url that you can post here for easy access to the information.

1 Like

#9

Thank you for your interest and dedication.

Here is some more information:
TV model: Samsung UE50JU6800K
Content: .mkv file with codec h264, resolution: 1920x1080, fps 29.970, audio ac3 192 kb/s
Kodi GUI resolution: 3840x2160, 60 fps
Debug URL: http://ix.io/1BoL

All my thanks to all the developers for this great software.

0 Likes

#11

@miguelgj, Set Kodi GUI to 1080p 60 fps and do the same procedure

0 Likes

#12

@CI6N0Z VIC 353 is normal, it’s because of how the amlogic drivers support the YUV420 modes.
Pretty much the driver makes a new nonstandard VIC number to represent the YUV420 version of the mode by adding 256 to the existing VIC. So 353 is just VIC 97 with YUV420.

0 Likes

#13

Hi.
I’ve set the Kodi gui to 1080p 60 fps and It seems to work, but the Kodi menus do not fit on the screen.
Here is the url: http://ix.io/1Bp1

Thank you.

0 Likes

#14

Everyone, make sure you use 1920x1080p 60 fps for Kodi GUI.

If the issue still persist, run dispinfo as cdu13a mentioned. To be clear: Set GUI to 1080p, run dispinfo before playback, play sample or watch channel and run dispinfo, and run dispinfo again when you get a black screen after stopping the video.

0 Likes

#15

But how to change gui resolution without hdmi signal?

0 Likes

#16

Have to tried to reboot or/and unplugged/plugged the HDMI cable?

0 Likes

#17

Yes, it worked only once but after reboot it is again “No signal”

0 Likes

#18

If you can’t change the resolution, run the following command

echo 1920x1080p60hz > /sys/class/display/mode

0 Likes

#19

Thanx, but I was able to change the resolution using the Kodi web interface.
Is there any update planned to solve this problem?

0 Likes

#20

I’ve just installed CE 9.0.0 on my Mini M8S II (905X box) and had a few display glitches while testing 4K HDR output too, and now display has gone blank when trying to resume playback. LG 65E6 4K OLED TV, running via an Onkyo TX-NR555 amp.

Dispinfo as requested: http://ix.io/1Bp7

[Edit: GUI was set to 1920x1080p 50Hz, will try 60Hz as suggested in later post]

Andre

0 Likes

#21

@miguelgj, If you use 1080p as the resolution for Kodi GUI, reboot and do the same procedure. Do you still get a black screen when pausing/stopping the video?

@remekb, do you still get a black screen even after changing the GUI resolution to 1080p 60fps? (Which is the resolution all you people should use)

@andrewilley, run dispinfo before playback, during playback and after playback so we can see how the resolution, color depth/space etc is switching. Since you have a LG display you should try out the tip cdu13a mention regarding using 4:2:2 as Chroma Subsampling.


Update: I can’t reproduce any of this with my setup. I’ve tried different samples, Kodi GUI resolutions, Chroma Subsampling etc, so we probably need more information on which videos/samples you are having problems with. Is it all 2160p content or just some?

0 Likes