Homatics Box R 4K Plus

Does anyone know how to go about creating a remote.conf for the Dune version?

I tried to follow this: 02. Amlogic: Creating remote.conf from scratch · CoreELEC/remotes Wiki · GitHub

But I cannot find the factory code.

However, if I run the “ir-keytable -p NEC,RC-5,RC-6,JVC,SONY -t” command I do get output with different scan codes if I press some keys on the remote:

Protocols changed to rc-5 jvc sony nec rc-6
Testing events. Please, press CTRL-C to abort.
380.720018: lirc protocol(nec): scancode = 0x8821
380.720038: event type EV_MSC(0x04): scancode = 0x8821
380.720038: event type EV_SYN(0x00).
380.768014: lirc protocol(nec): scancode = 0x8821 repeat
380.768032: event type EV_MSC(0x04): scancode = 0x8821
380.768032: event type EV_SYN(0x00).
383.204017: lirc protocol(nec): scancode = 0x8819
383.204037: event type EV_MSC(0x04): scancode = 0x8819

Factory code (actually whole line like is shown in instructions) is shown at the end what command dmesg returns.

I know, but dmesg -c does not return anything related to the remote, only the ir-keytable command shows responses.

Don’t use -c argument because this clears the log. Or use it only once before pressing anything on remote. After that use only dmesg.

Thanks, but I don’t get anything related to the remote from dmesg. However I took a guess that the factory code is 7788 because that is what all the NEC IR codes on the Dune web page end with and it seems to work!

I only tested with the ENTER key in remote.conf, but Kodi responded to it, so next step is to try and add all the other codes.


Try this:

use config files from: GitHub - CoreELEC/remotes: Repository for AmRemote & Meson IR Remote Controllers

The content must be saved to file /storage/.config/remote.conf.


Someone wrote here that the white list is a relic from past versions but it is actually no longer needed.

So you would prefer that your inferior box does upscaling, instead of a superior TV like G2?
OK, who am I to discourage you to do that…

Thanks, works well. Saves me some time creating it myself :slight_smile:

No no, don’t get me wrong I just said what I read in the forum. If that is so, I will also implement. That’s why I ask here in the forum.

I tried to implement this but get an invalid parameter, segmentation fault Line 16 (mouse_begin) when I SSH command

ir-keytable -a /storage/.config/rc_maps.cfg -s rc0

You need to save the content to file /storage/.config/remote.conf.

It’s really a matter of preference.
I haven’t really seen a difference between viewing 720p or SD content at native resolution (with whitelist) and just letting the box upscale it to 1080p and then having the display upscale from 1080p to the display’s native resolution.
By setting GUI at 1080P 50Hz, you completely avoid AFR switching and the black screen effect when watching live tv.
When watching higher quality content, AFR is still active, and will adjust accordingly.

I saved the Unix text file as remote.conf in the .config directory. It has the correct extension (no .txt)

It doesn’t appear to work…

B21 BT directional functionality has worked since pairing originally, but the OK key (and likely others) do not.

edit: works. Had to disable BT connection to it.

As Arthur said it’s only important for content below 1080p. The rest is upscaled by the tv just the same.

I now have an ethernet issue on the DuneHD box.

Wifi works fine, but wired obtains an odd address (169.xxx.xxx) instead of my local network (192.xxx.xxx).

Samba discovery is not available via wired. I cannot see any shares nor can I see the box from a windows PC.

Its connected to a dumb switch which has no issue with the other devices connected to it.

I can see its MAC ID on my router and it shows a (192.xxx) address. What is being changed and how do I fix it?

I tried manually using the IP my router assigned but there is no change. It seems its maybe a network driver issue?
Any ideas?

Log in with SSH and post url you get by command

dmesg | paste

Or even better: enable terminal sharing - coreelec:term_share [CoreELEC Wiki]

@aszi Thank you for the remote.conf. I use it on my Dune HD also with success.

I also trained my Harmony 350 remote, so that it works, too.

But now I tried to assign some of the other keys on the Harmony remote to further Kodi functionality, e.g. fast forward/backward. For this I learned the fast forward/backward buttons on the Harmony from another remote. And than tried to read the keycode from kodi to add them to the remote.conf. But it seems not to work. It seems that I got a wrong factory code from them.

Maybe someone has idea how to use the other keys from the Harmony?

So this setup works fine while playing individual files, but when I play a blu-ray rip including the full menu, I cannot get the OSD or the main menu of the blu-ray to display. Is there anything I can do about that? I tried to configure various settings through the Keymap Editor addon, but that doesn’t seem to do anything.

By the way the same is true when I use my TV’s remote through HDMI-CEC. All I can do when playing a full blu-ray is to press the Stop-button which stops playback completely.

I guess you can look here for some keymap