IR Remote not working until ir-keytable gets executed

Hello!

I followed this tutorial on how to add an IR remote on CoreELEC 19.

However when I boot the device the remote does not work. When I then SSH into the device and run ir-keytable -p NEC,RC-5,RC-6,JVC,SONY -t (while Kodi is running) it starts working. As expected the cli does not output the pressed keys, but I can navigate the user interface using the remote until I shut down the device again.
I assumed this has to do with meson-ir not running, so I added the force meson file by running

touch /storage/.config/remote.force_meson_ir

but no dice, the remote does not work until I run the ir-keytable command. Any ideas why this could be the case?

Thanks!

Okay, so the issue was that I used the wrong protocol in the meson-ir config file, I used nec when it should have been rc-5. Somehow this didn’t matter and just worked when starting the ir-keytable command, which caused the confusion.

IR Protocol Type
Default IR protocol used for meson_ir

@Portisch The options you linked do not exist on my insallation of CoreELEC, I just have System LED, eMMC Speed Mode and WiFi SoC SDIO Speed.

Also I don’t really understand the context of your response, shouldn’t this setting be ignored anyway when using a config file which specifies a protocol?

Than you have a remote.conf or any other meson-remote config in your ./config folder and meson-ir is disabled.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice