Khadas VIM3 testbuilds

Put your card to your box and copy the remote.conf through the box’ samba share or use winscp.

1 Like

Thanks for your valuable reply

Hi @vpeter
Can you delete this image? As this version still haven’t updated to the latest DDR timing, and the V12 boards cannot run with this image.

The V12 board can only run our latest Android ROM at 1608MHz DDR frequency.

Yes, works well but I updated the uboot from CE to use the correct memory size, now total memory size is 3708MB, without uboot update was 3370MB.

1 Like

Ok Thanks! I restored android pie v190809 with usb upgrade tool then did a fresh install of coreelec latest nightly ng generic and installed to emmc. Unfortunately still have same problems as before with CEC being hit and miss and forgetting sound output settings. It’s a completely fresh install with no addons and not restored from any backup
Here is the link to the debug log
Before the debug log I powered on the vim3 and cec was working then I changed input to TV on my tv and then went back to HDMI1 which is my vim3 input and CEC had stopped working, I then turned my tv off and back on again then CEC worked again and I created the debug link. If you need anything else to help find the cause please let me know, thanks!!

So you have issues with Panasonic & changing the HDMI port?
I remember that you will need special settings for Panasonic:

Check your settings with these once.

And your wake up issue is solved now?
Otherwise please run the bl301 injection and try again:

Thanks for your reply! I tried running inject bl301 command and I get this error

It doesn’t work if your installed to internal.

Does installtoemmc only work for vim3 pro version? because my vim3 basic can not boot after run installtoemmc.

I only have VIM3 basic and it works fine on it, which version board do you have?

My board Vrsion: VIM3 V12 1907

This is the problem then, the current bootloader that we bundle is not compatible with v12 boards, we are working on a solution for this.

1 Like

I am facing this error while compiling what it is due to i changed boot image of coreelec…?

HDR to SDR is not good on vim3(or N2), the picture is dark

HDR to SDR depends on the tone map that the HDMI driver has built-in.
It’s possible that the tone map is different between the two kernels.
@Yoo Can you try it on the VIM3 with Android?

The tone mapping is the hardest part of HDR palyers.
All these HDR players got this issue at preliminary FWs.
So for a new soc, need time to fix, it is normal.

Tone mapping is complex, but the problem with it is that in order for it to look correct on your TV, it needs to be customized for your specific TV and its settings. There is no “one-fits-all” solution here.

Android is the similar:

my NIC is not working. problem with my VIM3 or with CoreElec?
latest Build.

Ah okay, do you have any plans to make it work with emmc installs in the future?