Magicsee N5 Max Poor QC CEC not Working

Hi I am just reporting my tails of woe regarding my latest purchase a Magicsee N5 Max with 4GB RAM and 32 GB EMMC.

Having looked on here people have had various problems with their Magicsee N5 Max.

This one had a bad/failed ethernet port.

This one a failed WIFI Module

I have seen that people have also been configuring the supplied remote. On the suppliers page the feedback shows two people out of about 30 that have had a device failure within a couple of months.

So mine arrived this morning. Plugged it in no picture good start figured the HDMI socket is not good had to re-plug the cable a couple of times to get a picture. Interestingly if you apply any pressure on the socket picture goes off and on. So possibly the HDMI socket is poorly soldered.
So I installed CE 9.2.0 on SD booted using toothpick method it went through the usual partition resizing and booted into CE. Got an error message about CEC failed so my TV remote did not work :frowning:. Plugged in a keyboard as I figured the supplied remote wasn’t going to work without the necessary remote files. Did the setup it connected to my switch at 1000M also it spotted both of my routers at both 5G and 2G.
So far so good.
Connected to a network share to give it a quick test went to play a UHD Movie (First Test) and “No-signal” the blue power light starts flashing. At first I thought the box had gone into some sort of sleep mode that’s why the power LED was flashing. I Unplugged the power re-plugged it and it still flashed. So I grabbed my trusty 5V 4A power supply and the box started working again. So it seems the PSU was cycling from the current draw.
Took the box to the UHD TV to give it a proper test CEC still did not work so I installed the latest version of Android Pie and enabled CEC, CEC did not work in Android. Rebooted to CE Still got the CEC error message and no CEC working.
Updated to the latest nightly but CEC still did not work.:frowning:
Went back to my test bench re-plugged in the box and it took out the 4A PSU. This PSU powered a X92 and 2 XBOX tuners for 6 months without problems. Tried the original power supply and it worked, just needed to cool down It then ran about 5 mins before dying again.

So to sum it up the box has a dodgy HDMI socket. When it runs it draws that much power it overheats its own power after about 5-10 mins. It drew so much power it killed a 4A power supply in a hour. CEC does not work I can’t investigate further without risking yet another 4A PSU. I don’t know if anyone else has got CEC working on these devices it could be the bad soldering on the HDMI.

OK I am now on PSU 3 and I still can’t get CEC working I get the pulse 8 error message at startup every time. 3 TVs 5 different HDMI cables. All work with different Boxes. Here is the pastebin of the DMESG.

http://ix.io/1R27

I have upgraded the android to the latest available 9.0 and enabled CEC in android. It does not work in android either.

Have you seen this?

Yep just tried it it works. :slight_smile: It had done an update today so I thought I was running the latest version. Will the fix get backported to 9.02 I want to use this as my main box if I can get it stable. I suppose I could just freeze the updates.

Ther are no updates in devel version.

Ah I was on Nightly which updated today

OK with CoreELEC-Amlogic-ng.arm-9.2-devel-1570018126 the CEC works also the supplied remote works. I had to reload all the addons an nothing would install and i had to delete the Addon.db. Standby works on Samsung TV. VFD worked after I loaded correct file from this forum. Just wondering if when 9.2.1 comes out I will need to reload the addons.
HDMI socket seems to be cable dependent the socket is a bit sloppy if you move the cable the picture goes off but I have found a couple that work OK.
Not had any problem with the current PSU maybe It was just a coincidence the first ones failed.