N2 Core Elec Will Not Reboot After Shutdown Without Unplugging

I just bought an Odroid N2 Core Elec unit and it will not boot the CE OS after shutdown without unplugging the unit and plugging it back in, even when OS is shut down first from the CE interface before turning off TV and AVR.
Is that normal behavior?
If not, what do I do to correct it?
I have N2 unit connected to Onkyo TX-SR313 AVR and LG 42LV3500 HDTV.
I have One For All 5-Device OARN05G universal remote programmed to turn on TV and HDMI connection to AVR so all I usually have to do is power on and switch TV to HDMI input.
But with the N2 all I get is blank blue screen after shutting system down and powering back up unless I unplug N2 unit and plug it back in.
Only then does it boot when powering up system again.
Is there a way to fix this? or do I have to remember to unplug N2 every time I shut down system?

I think you need to read up on the CoreELEC Bl301 injection tool. The info is in the guides and how to section. Basically you can set a remote code up so that it turns the box on.

No
Don´t use it with the N2.
Have a look at /flash/config.ini and read the instructions found in the forum

This happens to me only when I run CoreELEC Module Drivers, so I can’t reboot the TV Box. Fortunately in my S905X3 the kernel recognizes my old ec168 USB TV tuner device with no problem and no need to install CoreELEC Module Drivers, and in my S912 the tuners have been installed for many months. It was hard for me to find the cause of the problem that occurs in both Amlogic and Amlogic-ng firmware.

I think something is wrong in the CoreELEC Module Driver addon or in the Drivers addons.

(Tested on TV Box S905X3 and S912)

1 Like

What is the CoreELEC Module Driver addon? and how do you go about troubleshooting it?

Search for: Settings->Add-ons->My_add-ons->All->CoreELEC_Module_Drivers
Just run and select another driver package = NO REBOOT WHITHOUT UNPLUGGING

Forgive my complete ignorance; I’m new to all this. Do you mean search for files on N2 via my computer on same network? I’m using Macbook Pro, waiting for ethernet cable and display port to hdmi adapter so I can setup N2 at desktop connected dsl modem and monitor, on same network as Macbook. I presume I’ll have to SMB to N2 in order to connect with it.

Obviously first of all you will have to run CoreELEC on your N2 device, this forum is only for CoreELEC.

I am running CoreELEC on N2.
Found ethernet cable and was able to connect from Macbook Pro, but there is no Settings folder, and I cannot find My_add-ons- in any of the folders.
Only folders in COREELEC drive are -
Addons
Backup
Configfiles
Downloads
Emulators
Logfiles
Music
Picons
Pictures
Recordings
Screenshots
TV Shows
Update
Userdata
Videos

Open the samba shares and look in Configfiles for the samba.conf.sample file.
If there isn’t one , just create one.

Open it in a text editor and add the following:

[Kodi]
  path = /storage/.kodi
  available = yes
  browsable = yes
  public = yes
  writable = yes
  root preexec = mkdir -p /storage/.kodi
[Storage]
  path = /storage
  available = yes
  browsable = yes
  public = yes
  writable = yes
  root preexec = mkdir -p /storage

Save as samba.conf (not samba.conf.txt!).
Reboot.

Settings using Kodi User Interface is what you’re looking ?

For wake up you will need to make a UART log. Hardkernel are selling compatible hardware for a few euros.
The problem is the AVR as each vendor do his own CEC implementation and it maybe working different for yours. Only a UART log can tell what is missing.

OK, I found samba.conf.sample in Configfiles folder (drive?), and was able to edit it in BBEdit.
Saved it as samba.conf to same location, or where is it supposed to go?
I cannot find Settings. See above post. There is only a series of folders that show up in Finder on my Macbook Pro, that are mountable/unmountable as if they are drives.

There is a subfolder named system.d in the Configfiles main folder (drive?).
Contents are cifs.mount.sample, nfs.mount.sample, openvpn.service.sample, and README

Correct…
What is BBEdit ??
Just use text editor in Mac.

Still doesn’t turn unit on after adding your code to samba.conf.sample and saving as samba.conf to same location - Configfiles main folder (or drive?)

Mate i only gave you instructions to access your addons via SMB.

You must read Portisch reply

I do not understan Portisch reply. I need instructions for complete newbie who’s never coded anything but a little html.
Portisch says “Hardkernel are selling compatible hardware for a few euros.”
So does that mean I need to install more hardware on N2 or what?
Where are instructions for how to make a UART log?
Good grief! How am I supposed to know how to do that or what it means?

https://forum.odroid.com/viewtopic.php?f=53&t=841

https://www.hardkernel.com/shop/usb-uart-module-kit/
Some more installation use guide
https://wiki.odroid.com/accessory/development/usb_uart_kit

Hi ds_tx - your head must be spinning right now.
To keep it short if you want the N2 to reboot you need to either completely disable the N2’s inbuilt CEC function or go the way of Uart reporting etc so the dev’s can figure what is going wrong. Unfortunately there isn’t any CEC ‘off’ switch in coreElec so it means editing the config.ini. follow this link: How to Edit config.ini?

Please provide a copy of your dmesg.