Need testers for S912/S905W green/red lines issue

If you have issue with H264 1080i content like green/red lines(like described here Red line appear on live tv(pvr)) and you have S912 or S905W box than please test this build:

https://test.coreelec.org/boot2k3/S905W_912/CoreELEC-Amlogic.arm-9.0-devel-1557994086.tar

If you use workaround like deinterlace disable, than don’t forget to remove it before test.

Also please left your results after testing.

Hi boot2k3,

Just gave it a try but my remote doesn’t get recognised so I can’t do any testing. I’m using a Mecool M8s Pro L box and I was experiencing the red lines issue. Just about to roll back to an older version of CoreELEC to check that the remote works again under it…

What version did you have before?
May be you need this hint


or you have remote.conf file somewhere /flash/remote.conf or /storage/.config/remote.conf

well remote works thanks to all the forum members here who haved help me with this just do it like beneath

Enter WinSCP and place the files in the indicated place
Copy M8SPro + to: /storage/.config/rc_keymaps
Copy rc_maps.cfg to: /storage/.config

Sign in via SSH using PuTTY
Login: root
Password: coreelec
Enter the command:
ir-keytable -a /storage/.config/rc_maps.cfg -s rc0
command: reboot

and here is the remote file with this remote works for mecool m8s pro l

thanks goes to herbas for the files

1 Like

I have an S905W box with the same green/red lines issue when deinterlace is enabled and watching H264 1080i content (TV stream). On an S905X I don’t have any problems with deinterlace.

So could you also provide an build so I can test this on my S905W box? Or is this fix only possible for S912 boxes?

Have a look here. I have a Mecool M8SP with a remote control issue. and running the following from a root shell prompt to create a /storage/.config/rc_maps.cfg fixes the ir-remote control issue.

 echo "meson-ir * mecool" > /storage/.config/rc_maps.cfg

Yes, it possible, but I don’t have such box for test.
I will ping you as version will be ready(today or tomorrow), need to perform some conversion with code…
@Jeroen, also please clarify do you use iptv streams or some DVB hardware to watch on this box?

I use an Tvheadend server with DVB-C hardware to watch 1080i50 streams from my cable provider.

@Jeroen, test version for S905W:
https://test.coreelec.org/boot2k3/S905/CoreELEC-Amlogic.arm-9.0-devel-1557940097.tar
Untested, but should work

@boot2k3 I just tried your build on my S905W box, but unfortunately I still get the green/red lines (or artifacts) when deinterlace is enabled.

Does it help if I provide an sample of the content where this problem occurs? I also noticed that I do not experience this problem on all my DVB-C channels, but still they all look like similar H264 1080i50 streams (maybe some small differences in bitrate or something else?)

Some channels start with the green/red lines right away, and on other channels they ‘popup’ after ~10 sec. watching. And as I already mentioned some channels are just fine with deinterlace enabled, no weird green/red lines are visible.

Thanks for investigating this issue! :slight_smile:

Thanks for the suggestions - got my remote working (had an old remote.conf still in existence that I think was causing problems). I didn’t get a chance to test the deinterlacing yet (travelling for work) - will do so over the weekend though. FYI, I’ve noticed there aren’t any deinterlacing issues on the M8S Pro L when playing back from the tvheadend server on my other Kodi (Libreelec) box - the red lines only ever appeared when also running the tvheadend server locally on the M8s Pro L box itself.

OK, waiting for your results.
This lines usually appear for 1080i50 content. And more easy to repeat them when box is busy with something more like tvh server or file transfer process

@Jeroen, new test version for S905W(can be used for S912 too).
https://test.coreelec.org/boot2k3/S905W_912/CoreELEC-Amlogic.arm-9.0-devel-1557994086.tar

@boot2k3 It looks like your fix works! I don’t have any green/red lines on 1080i50 content right now. I will try to test some more tomorrow, but it looks good! :smile:
Thanks!

2 Likes

@boot2k3 applied onto one of my boxes yesterday morning and so far with testing watching Live TV and Recordings in TVHeadend everything is working fine, so hopefully your fix has done the trick!

I will continue to test over the weekend, as this occurred very randomly for me previously, but I would have expected to have seen this by now.

1 Like

Still looking good after a weekend of testing :slight_smile:

Thank you for testing.
This change is included in today nightly build.

1 Like

Hello,
I installed the last nightly because of the changes to the deinterlacing problem for the S905w boxes.
I have an X96 mini, i tried to watch iptv over the iptv simple client in 1080i 50fps.
There are no more red or green lines but the video starts to flicker ~ every 2s.
After 1 min video stops sound is on repeat from the last 0.5s and the box doesnt respond any more.
I attached the kodi log.
If can provide more informations if u need it.

Log:

2019-05-23 15:43:57.053 T:4086669328  NOTICE: VideoPlayer::OpenFile: pvr://channels/tv/Alle Kanäle/pvr.iptvsimple_974123572.pvr
2019-05-23 15:43:57.057 T:3651285872  NOTICE: Creating InputStream
2019-05-23 15:43:57.495 T:3651285872  NOTICE: Creating Demuxer
2019-05-23 15:43:59.012 T:3651285872  NOTICE: Opening stream: 0 source: 256
2019-05-23 15:43:59.013 T:3651285872 WARNING: OpenStream - Unsupported stream 0. Stream disabled.
2019-05-23 15:43:59.013 T:3651285872  NOTICE: Opening stream: 1 source: 256
2019-05-23 15:43:59.013 T:3651285872  NOTICE: Finding audio codec for: 86019
2019-05-23 15:43:59.014 T:3651285872  NOTICE: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder ac3
2019-05-23 15:43:59.014 T:3651285872  NOTICE: Creating audio thread
2019-05-23 15:43:59.015 T:3608490864  NOTICE: running thread: CVideoPlayerAudio::Process()
2019-05-23 15:43:59.017 T:3651285872  NOTICE: Opening stream: 0 source: 256
2019-05-23 15:43:59.017 T:3651285872  NOTICE: CVideoPlayerVideo::OpenStream - Creating codec: 27
2019-05-23 15:43:59.026 T:3651285872  NOTICE: Creating video thread
2019-05-23 15:43:59.026 T:3600098160  NOTICE: running thread: video_thread
2019-05-23 15:43:59.062 T:3651285872  NOTICE: Opening stream: 1 source: 256
2019-05-23 15:43:59.069 T:3608490864  NOTICE: Creating audio stream (codec id: 86019, channels: 2, sample rate: 48000, no pass-through)
2019-05-23 15:43:59.361 T:3600098160  NOTICE: CAMLCodec::OpenDecoder - using V4L2 pts format: 64Bit
2019-05-23 15:44:00.051 T:4086669328  NOTICE: Whitelist search for: width: 1920, height: 1080, fps: 50.000, 3D: false
2019-05-23 15:44:00.052 T:4086669328  NOTICE: Display resolution ADJUST : 1920x1080 @ 50.00 - Full Screen (29) (weight: 0.000)
2019-05-23 15:44:00.053 T:4086669328  NOTICE: VideoPlayer: OnLostDisplay received
2019-05-23 15:44:00.275 T:4086669328  NOTICE: VideoPlayer: OnResetDisplay received
2019-05-23 15:44:00.516 T:3600098160 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer