Nightly builds (NEW)

I’ve made a fresh install of nightly_20200408 and today also with nightly_20200409, always the same issue.

here are the output of: cat /proc/device-tree/coreelec-dt-id

I have additionally an eMMC installed with the stable version of CoreElec_9.2.1.
The nightly version of CoreElec are installed of a SD-card.

That’s your problem then, it’s because you have stable on the eMMC that is causing this issue as the old bootloader will be loaded first.

The SoC will load the BL from eMMC before SD.

You’re right! :grinning:
The issue is gone if I removed the eMMC and boot only with th SD-card. and with original boot.ini.

Okay, I will change my installation and use the eMMC for the nightly-versions and the SD-card as fallback with the stable-version. :wink:

Thanks for your help and have a good day.
Stay healthy!

Have you done anything else to get it working again?

My X96Air 4/32GB does not wake up with the remote.
Not with the 20200408 build or 20200321 build.

I activated bluetooth and then turned it off, however, I have no sound for some reason through hdmi. I have not changed anything in my sound settings, just turned bluetooth on and off, tried to pair a controller.

When it’s not working with 20200321 then something else is wrong:

Hi, no I have not done anything else to make it work. Tried two boxes and with the changes both now work. I did not use injection. But maybe try that as well.

Waking up works well with my IR remote. But it doesnt using CEC (remote for TV). Any tip?

With latest nightly, archived videos (packed in rars) seem to get locked after watch and I am not able to delete after. Folder deleting fails. I then tried to delete them through windows and it appears on every set, several rars are locked down by Kodi, not all (with windows I can delete the ones that aren’t locked). After rebooting CE, I am able to delete them, but next one I watch presents the same issue again.
Unpacked mkvs delete fine.

Having this issue too with all the latest nightlies. Update channel used to say CE 9.0 and then I could use “Available Versions” to get latest. Now Update channel is empty and clicking on Available Versions just flashes for a sec and turns nothing.

The addons were bumped to their latest versions. Could be a regression upstream. You can always downgrade to an older version of the vfs.rar addon. If that solves the problem, I suggest you open an issue upstream.

With the latest nightly build I have buffering issues playing 4k hdr files. Reverted back to nightly from april 9 , and the issue is gone.
This is on an N2 on wired gigabit LAN playing files from a smb share on my network. Nightly build from april 9 does not have this issue. Coreelec is installer om EMMC

@Dopus can you try latest nightly but boot from petitboot instead and see if you still have the same issue.

Also was you using SMB or NFS?

Smb…Windows share. Before i downgraded to older nightly build, I rebooted the N2 and tried the same file again. IT played for a minute and then startes buffering, played for 10 seconds , then startes buffering again…stopped the movie downgraded to april 9 nightly, startes the movie from where i stoped it. Plays flawless. No glitches, no buffering . Perfect playback. I Will test from petitboot tomorrow

Try boot latest nightly with petitboot then and see if you have any issue, we updated the bootloader but petitboot uses an older one so this will let us know if that is the issue or not.

1 Like

This might sound stupid. But om ny 912 and N2 i have only used EMMC. Is petitboot= boots from Sdcard= me burning newest nightly to Sdcard and boots from IT??

I think i did a bootloader update when I got my N2 in november 2019. Is this the petitboot??. Do I need to update the bootloader again before trying the newest nightly from sd card??

Since the last auto update nightly, my external usb 3 drive with coreelec image , no longer shows in petitboot. I tried updating petitboot to the latest (feb 2020), and still no luck. How can I get my external drive to boot again , or reccognize and show as a bootable drive in petitboot, without having to wipe it and reload an older version of coreelec?

This is the first time this has happened since I setup coreelecon an external. Things had been working well up until the last nightly.

Here is the petitboot log. It gets hung up on “probing from base tftp…” for about 2 minutes before “pxe autoconfig failed” . Then nothing. The coreelec boot doesnt show.

Any help would be appreciated! :slight_smile:

I think you should check the boot.ini of CE in your external storage if it has “ODROIDN2-UBOOT-CONFIG” at the first line. If it does not have or something else, please correct it to have “ODROIDN2-UBOOT-CONFIG”.

I do see it was updated to 2.31, not sure when but I guess recently.
I now switched it back to 2.081 and was able to delete the files. I will test to be sure it works after watching post-update.
I assume I need to disable auto-updates for now on this addon for now or it will upgrade again?

“Open an issue upstream” meaning? On the vfs git page?