Nightly builds (NEW)

I edited my message and added a link to the log file.

Can someone help me out. I’m on a N2 with a USB DVB-S receiver.

Switching to a UHD channel in tvheadend and back leads to the following problems:
UHD channel: I see only 1/4 of the screen. This is the old problem with the overscreen settings. Why is this happening over and over again? I set this already 10 times.

HD channels: switching back after watching an UHD channel keeps showing only 1/4 of the screen and the colors change.

It is not a new issue. Any help is appreciated.

@rosenrot very often needs settings for each resolution and framerate.

The following should fix it. SSH and enter the following.

systemctl stop kodi
rm /storage/.kodi/userdata/guisettings.xml
systemctl start kodi

Next time set picture options correctly in TV menu instead of using Kodi overscan.

@anon88919003 deleting the file helped for the sizing issue.

What do I have to do to counter the color issue? I can’t be the only one seeing it. Do you need any log or anything. I’m more than happy to provide you anything.

Sorry you will have to remind me what your referring to.

Sure.

Since a week or so, I experience the problem that Bluetooth is disabled on my VIM3L after a (re)boot. The switch is “ON” in the services tab, but the Bluetooth page says “Bluetooth is disabled”.
When I turn the switch off/on, it’s working again. I think it changed somewhere around the end of March.
Is somebody else experiencing this? Or is this something you’re already aware of?
I’m on the latest nightly (04/09).
Thanks!

Since update to nightly_20200408 my Odroid-N2 doesn’t boot anymore. It hangs with a permanent blue LED.
I found out, that are some changes in boot.ini. And when I change the first row in the boot.ini
from original:
ODROID-UBOOT-CONFIG
to
ODROIDN2-UBOOT-CONFIG

my Odroid-N2 will boot properly.
Is that an issue only for me as an Odroid-N2 user or is that a general issue?

Paul

Did you boot with petitboot?

The problem with doing what you did will only be erased again on the next update so we need to get to the bottom of this for you.

1 Like

No, I didn’t boot with petitboot.
I boot directly from sd-card and it worked until nightly_20200407.

In changelog for nightly_20200408 are this comments:
5f73869646: Mon Mar 23 07:55:53 2020 +0100 - u-boot-Odroid_C4: add package (Portisch)
f9f74b3b18: Mon Mar 23 07:54:30 2020 +0100 - u-boot-Odroid_N2: bump to dde2b5a8 (Portisch)

And this was for me the reason to look into boot.ini and I compared with an older boot.ini and found the differences in the first row. And with the changes of the first row to the older version I could boot without issues.

After the first update to version nightly_20200408 and with the issue of no booting I made a fresh install, but with the same result of a nonbooting Odroid-N2.

Can you give the output of cat /proc/device-tree/coreelec-dt-id

It looks like the bootloader didn’t update and the only way this would usually happen is if you have done an SPI boot, do you have an eMMC attached also?

I’ve made a fresh install of nightly_20200408 and today also with nightly_20200409, always the same issue.

here are the output of: cat /proc/device-tree/coreelec-dt-id
g12b_s922x_odroid_n2

I have additionally an eMMC installed with the stable version of CoreElec_9.2.1.
The nightly version of CoreElec are installed of a SD-card.

That’s your problem then, it’s because you have stable on the eMMC that is causing this issue as the old bootloader will be loaded first.

The SoC will load the BL from eMMC before SD.

@anon88919003,
You’re right! :grinning:
The issue is gone if I removed the eMMC and boot only with th SD-card. and with original boot.ini.

Okay, I will change my installation and use the eMMC for the nightly-versions and the SD-card as fallback with the stable-version. :wink:

Thanks for your help and have a good day.
Stay healthy!

Have you done anything else to get it working again?

My X96Air 4/32GB does not wake up with the remote.
Not with the 20200408 build or 20200321 build.

Hi.
I activated bluetooth and then turned it off, however, I have no sound for some reason through hdmi. I have not changed anything in my sound settings, just turned bluetooth on and off, tried to pair a controller.

When it’s not working with 20200321 then something else is wrong:


Hi, no I have not done anything else to make it work. Tried two boxes and with the changes both now work. I did not use injection. But maybe try that as well.

Waking up works well with my IR remote. But it doesnt using CEC (remote for TV). Any tip?