Nightly builds (NEW)

cat/proc/device-tree/amlogic-dt-id
should i do this

X3 Amlogic S905X3 4 GB RAM 64GB ROM 1000M LAN 5G WIFI bluetooth 4.0 4K 8K Android 9.0 TV

changing audio output from hdmi to hdmi multichannel pcm fixed the sound

1 Like

Are you refering to what version should you download?

For S905X3 you should use coreelec-ng, the one with img.gz extension to burn it into a sd/usb. And use the device tree with the specs of your box.

1 Like

This is the channel from the playlist with “Pomoyka”. Piracy in question?
PS: on the official firmware this effect is not.
P.P.S. The channels worked on their own, what was it?

English is not my native language. I may have written it wrong.
Yes, which version do I need to download? I asked that.
Thank you for your help…

edit:
Is this the right link for me?
https://relkai.coreelec.org/CoreELEC-Amlogic-ng.arm-9.2-nightly_20200108-Generic.img.gz

Yes the Generic NG is correct.

1 Like

Yes, that’s it.

Now burn that image to a sd/usb with rufus, and take the correct dtb from the device trees folder.

Put it on root folder and rename it to dtb.img

1 Like

With nigthly buil 20200108
the temperature of the x96 air (s905x3) has dropped 10-12º. Thx, great work.

Anybody knows what speed can work the slot of microsd in an TvBox?

Yes, me. Read this:

1 Like

That’s the same issue I mentioned earlier in the thread. It’s like the auto conversion of AAC to PCM doesn’t work when HDMI is selected. When I changed it to PCM everything worked, but my two other boxes don’t exhibit this behaviour on the stable build.

1 Like

@Alestilohomer and @kostaman
Thanks for your help.
Works well…

Hi guys , I’m very please with the latest nightly on my gt king and right now for my use I’m not find any playback and/or other issue .

The only strange thing is that It seems the auto update prompt does not show anymore , I’m on 03/01 nightly and even using custom channel I can’t find the new nightlies , am I missing something ?
Thanks

Where did this image go?

https://relkai.coreelec.org/archive/CoreELEC-Amlogic-ng.arm-9.2-nightly_20200108-Generic.img.gz

@Erario when a new nightly gets built the previous nightly gets moved to the archive folder.

Cool thanks!
But I don’t understand why in the last night build I don’t find support for S905X3, or I can’t find the correct dtb for S905X3 4Gb 1Gbit anymore (filename sm1_s905x3_4g_1gbit).

Did you download the amlogic-ng build? Since if you did download the right build that dtb file should be there.

Unfortunately if you downloaded the 20200110 build there is no right option since there was a technical issue that prevented the amlogic-ng build from compiling last night. so the build I linked to is the newest available build to support your device.

1 Like

I just tried the 20200108 build and my multi-channel audio issue is fixed, unfortunately the display is like this:

Is this a known issue? I couldn’t find anything that would fix this.

I refer to the slot itself. How fast can stand it?