Nightly builds (NEW)

It’s a known issue.

Go to Settings > CoreELEC > Hardware
and toggle the use_yuv_to_rgb setting. then reboot.

1 Like

Can i force kodi to convert hdr to sdr. I want to try something on my 65ru7402 and my s912 box

Yes, in Settings → System → CoreELEC you can select the HDR-to-SDR mode (it’s set to “Automatic” by default) and the reverse.

In my experience it’s still much worse than plain SDR, even if better than without the conversion.

Like i say i have s912 box not ng and i dont have that option

Thanks @cdu13a, that did the trick!

@Doktor-X sorry, dunno, S905X2 here.

Exactly the same problem as me, Also using a Xbox tuner, but i have an N2. For me i have tried every possible configuration, just constant dropouts and pauses, by using exoplayer it seems to pause then pickup again, but using vlc it just drops out.

Live tv for me is just unusable at present. Ive just stopped using it for now.

Have you confirmed that all is ok at 9.2.1 as sonofdibnah said? Xbox tuners are prone to failure if the signal gets weak. Tvheadend and tuners are a bit sensitive to some changes and you should keep them as stable as you can.

No it does it in 9.2.1 to. It’s never worked properly.

Maybe I should try a new tuner?

In nightly 20201010, CoreELEC-Amlogic-ng disappeared. So whether
can be continue updated? Or which image should be used?

Pretty sure it’s been mentioned already somewhere, maybe another thread - the NG version failed to build, so 0108 is the current NG nightly.

Yes, new nightly builds are available already.
It was just build system issue for one ng build.

Same here with “Tictid TX6 Plus” (s905x3 4g/ 64g/ gigabit/ bluetooth).

I agree with you about the sensitivity of the Xbox tuners. I know I’ve said that everything is Ok for me on the latest stable version but it was windy here yesterday. The result of this was that TvHeadend was unusable with channels locking up very frequently, pixelation and distorted sound. My TV’s internal tuner, connected to the same aerial, had no such problems. High winds have stopped and all is well again.

If I’d not seen this for myself I would not have thought it was possible for there to be such a difference. To be honest, I’m backing away from TvHeadend a bit for day to day watching.

Has anyone got the Wi-Fi driver for Mediatek MT7668 for OpenELEC?

I have a A95X F3 Air (V81 - Mediatek MT7668RSN WiFi / Bluetooth module) with Amlogic S905x3 chip and 2GB / 16GB Ram / Rom.

Successfully boot up the device with an SD card using the Nightly build 20200112

Everything looks okay for now but Wi-Fi / Bluetooth and remote are not working. Have ssh enabled and connected via Ethernet.

I am thinking to invest some time to compile the driver from source, any tips appreciated.

The only resources I found is this in github here but I am not sure if this is the right .c file
I can see the mt7668.c file includes mt7668.h and precomp.h which are also presented in the same repository. But are they for Android? To my very limited understanding, it should be platform independent - hence compile from source. Correct me if I am wrong.

Compile and Toolchains
I do need to set up a cross-compile environment - are there good tutorials out there for cross-compile from an x85 64 bit linux environment to the Amlogic S905x3 target system? Should the target system ARCH parameter be aarch64 or arm or arm64?

Is Linaro a good / the right toolchain to be used?

Deployment / Including to nightly build
If I get it all right and successfully get the WiFi / Bluetooth going, how can I contribute to the CoreELEC community?

New with CoreELEC, many thanks.

I have a problem with Nightly build 20200112 - on Stable 9.2.1 I get the same following issue:
If i try to record SD or HD media and try to watch a prevously recorded SD movie.
Stream stops after about 5seconds, if tuners are connected like this:
I got two usb tuner (1x Sundtek Media DVB-C / 1x DVBsky T330)

  • MicroUSB (front): Sundtek Media DVB-C
  • USB3 Port: DVBsky T330
  • USB3 Port via Powered USB3-Hub: USB-HDD 2,5"
    If i change the configuration - the problem is gone:
  • MicroUSB (front): no connection
  • USB3 Port: DVBskyT330
  • USB3 Port via Powered USB3-Hub: USB-HDD 2,5"
  • USB3 Port via Powered USB3-Hub: Sundtek Media DVB-C
    My intention was to use both USB-Lines to speedup data transfer of HDD and dont get into trouble of too much data transfer through one USB-Line inside the S922X but if i do this I get theproblems?

here is a logfile:

PS: reboot not wokring on Odroid N2 here - need to cut and reconnect power to reboot on nlightly 20200114

My X96 air 4/64 works perfect with Nightly builds, Netflix can play in 1080p 3000 kb/s without lag, it’s so amazing for a cheap box with software decoder.
I tried to install to internal to check if Netflix be able to play at a higher bit rate, but the script installtointernal is not supported now.
Is there any way to install to internal NAND/eMMC?
Big thanks to developers!

You should use the newer tool blow, maybe it can work on X96 s905x3…

The only feature that a install to eMMC will give you is more read/write speed. You can try (before doing nothing) the benefits of this speed increase by using a external and fast usb 3.o dongle, or a fast microSD card with an adapter.

After that, if this speed suits your needs, you can install to eMMC (using ceemc) or use the eMMC as storage booting from a microSD.

About the speed of the diferent storage devices …

It can also free up a potentially useful USB port or Micro SD card slot.

1 Like

Try, as it goes it doesn’t work, on my S905X3 it’s fine.