Nightly builds (NEW)

You need to determine right physical address for cec and it will work great.

Since some Leila builds it is no longer possible to watch HEVC films on a S905W box. Instead of an image, only artifacts are displayed. The resolution does not matter. A few builds ago only HEVC films in SD format were affected, now no film can be viewed. Only artifacts are displayed. The problem does not exist in the stable Leila. The problem is with both Matrix Build and Leila Build.
kodi.log (1.8 MB)

Try last nightly, there was a fix in media modules.

The Log i have posted its from the latest leila nightly nightly_20210116

Thank You for tip.
But how? I mean what is physical address?

1 Like

Hello guys! Is it somehow possible to finally fix the issue the the CoreELEC Settings addon is not ready or very slow when Bluetooth Audio Changer is used? I have an enhanced version of this script made by vevs. It not only changes the Audio output but also disables passthough option in audio settings. Otherwise sound still comes through the AVR.
Can we maybe rework this setting? It is not working like it is logical… I mean when you enable passthough in audio settings then there is the device the uncoded signal is being sent to and this is the AVR. Why is this setting on when the bluetooth headphones are connected? Doesn’t make sense to me.

Here are the files which normally are placed in configfiles udev.rules.d.
bluetooth-event.rules with the following code:
ACTION==“add|remove”, SUBSYSTEM==“bluetooth”, RUN+="/bin/sh /storage/.config/udev.rules.d/"

and the script itself
# Bluetooth Autoswitch for CoreElec by vevs

Please visit


sleep 5; pactl info | grep “a2dp_sink” && { device=“PULSE:Default”; passthrough=“false”; }
curl -v -H “Content-type: application/json” -d
‘{“jsonrpc”:“2.0”,“method”:“Settings.SetSettingValue”, “params”:{“setting”:“audiooutput.audiodevice”,“value”:"’"$device"’"},“id”:1}’ http://localhost:8080/jsonrpc
curl -v -H “Content-type: application/json” -d
‘{“jsonrpc”:“2.0”,“method”:“Settings.SetSettingValue”, “params”:{“setting”:“audiooutput.passthrough”,“value”:’$passthrough’},“id”:1}’ http://localhost:8080/jsonrpc
This is the same as Bluetooth audio changer with the exception that it also disables audio passthough.
Is it possible to fix the conflict with the CoreELEC Settings addon??

To know latest nightly working build and first broken may be could help us to find a reason.
But I don’t know if somebody of us have S905W box for test it

Very easy, 20201126 was the build that runs very well.

Go to settings - system - input - peripherals - cec adapter. There you have physical address option. I have there 2400. Because my tv is connected using HDMI2 port of TV with ARC. And the port of the AVR where Kodi connected to is apparently 4. That is why 2400. Try it.

Thank You for support.

Latest build solved issues with Restart option and thumbs in music library.

According to turning on/waking while changing source.
Neither PA 2000 nor PA 0 (deafult) doesnt change this. Both working but changing source in TV doesnt boot/wake box.

Is Kodi connected directly to the TV or is Kodi connected to AVR? If you delete the settings of CEC then it normally detects the settings in there. If it is connected to the TV directly, which port is it?

My box i directly connected to TV, to port 2 (ARC Panasonic). My s905x2 has 1 hdmi.

then adress should work… But Panasonic HDMI implementation is very bad as Portisch said. Try other value, maybe it is mixed up. Try like 1000 or 3000 or 4000.

Yeah, i know it is crap. Ill test some.
But it worked in firmware 4.0.7. Just lost this feature in MatrixCE (fw 5).

In CE settings/CEC there are some IR protocols to choose (default is NEC). Should i consider this?

Why you connect it to ARC port? On the ARC port should be an AVR, not a CE device. So maybe you try another port. Like on my setup I have AVR on HDMI1 as it’s the ARC port. CE device on HDMI3 as HDMI2 does not have native resolution.
It’s very device specific which port is best to use.

I switched to HDMI 1. And nothing changed.

So, i will upload two videos The first is with old 1126 nightly build and the other is with the new nightly build.
it seem, that every nigthly after 1126 have this error with my s905w box.
nightly 20201126
VID_20210116_203146218.mkv (1.8 MB)
nightly since 20201128
VID_20210116_203725402(1).mkv (9.3 MB)

Can you upload a sample of the problematic video?

A problematic video?
I can’t watch any HEVC File since 1128. Every HEVC movie looks like this Video i uploaded.
But only with S905W. With S905X all looks fine.