No Spdif device in system settings


I use a s905x android box at my tv via hdmi for display and optical via spdif to my avr for sound. In Kodi settings I cant choose a spdif output. Just HDMI, PCM and Bluetooth (pulse).

When typing aplay -l, there is one device 0 and the channel 1 hdmi, channel 2 spdif and channel 3 pcm.
So the Spdif is recognized…
When typing aplay -L, there is the same output like in Kodi, respective no spdif output device…

Whats wrong there. Anyone got an idea? Pls help :slight_smile:

I used SPDIF briefly with my s905x, but haven’t for over a year now. However, from what I remember, SPDIF should be active in at least PCM and possibly HDMI modes.

In other words, it outputs a duplicate stream to SPDIF all the time.

I read about that, too. But I dont get sound from any source, for example mp3 song, in all kind of configuration. Via Bluetooth its working. So its neccessary to choose the right device…but there is no spdif…no matter via paththrough or not. With my firetv its working via spdif…so my avr is fine. There is also an optical signal, as the red light at the cable is indicating that…

Additionally I cant change the “Passthrough Output Device”, which is grayed out and used by HDMi output only…because there is no other capable output (as spdif is missing)…

Make sure that you have the # of channels set to 2.0 if you are using spdif.

I set the channels to 2.0.
I guess the problem is another. When I say aplay -L there are the devices shown in Kodi. No SPDIF.
Aplay -l say there is the hardware device SPDIF. So I guess only device 0 and 2 will be targeted by Kodi/corelec.
I need device 1. How I can change config in Corelec that this device is my main one?

CoreELEC:~ # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: AMLM8AUDIO [AML-M8AUDIO], device 0: I2S.40 T9015-audio-hifi-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: AMLM8AUDIO [AML-M8AUDIO], device 1: SPDIF.41 dit-hifi-1 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: AMLM8AUDIO [AML-M8AUDIO], device 2: PCM.42 pcm2bt-pcm-2 []
Subdevices: 1/1
Subdevice #0: subdevice #0

CoreELEC:~ # aplay -L
Discard all samples (playback) or generate zero samples (capture)
Default Audio Device
Default Audio Device
HDMI Audio Output


sorry to resurrect this old thread, but I have the same problem with a MXQ Pro 4k (s905w) box.
Spdif is not available in Coreelec’s settings. Is there a way to get it to work?
Thanks in advance.

It was the first installation on my box.
-Etcher to get the img on sd card (class 10)
-Copied the dtb and remote files according to the guides in this forum
-Booted via toothpick method

No addons were installed. After your reply I updated to nightly build without any change.
Spdif does not show up in the audio settings.

Can you try just plugging in the Spdif cable to see if you get audio out?
It tends to just work on most systems, since it’s output is set as a duplicate of the hdmi audio out.

Booted with just the Spdif cable inserted. It does unfortunately nothing just as pulling the hdmi
cable during playback. Always no audio. Btw the Spdif is coax with RCA (looks like a headphone jack) on the MXQ Pro 4k box side.
I already tried older versions of LibreElec ( and 8.0.2e) and reinstalled the latest stable
version of Coreelec afterwards. Each time only 3 audio options are available:
ALSA: Default (AML-8AUDIO Analog) PCM
PULSE: Default Bluetooth Audio (PULSEAUDIO)

Audio over PCM and HDMI works now It must have been the coaxial cable.
Thanks again to everyone who was trying to help.

Any idea? I have the same problem. On LibreElec/CoreElec.

First, start by reading this easy KODI guide - Audio quickstart guide. Then tell us about your setup. Is your box connected directly to your TV or your AVR?

If you don’t figure this out in the next 48 hours I’ll look into it by connecting my box to my AVR or/and TV with S/PDIF to see if there are any issues with the build.

Yes, I have it, and I have this too.
I have only these choices.

I have debug log here kodi.log (87.7 KB)

Thank you.

@ac3 have you tried just plugging it in and seeing if you get sound through the spdif connector without changing any audio settings from the default configuration?

I tried now and didn’t help it.

The way the audio is currently setup the hdmi, any onboard dac and spdif get the same audio. so as long a you are using the correct device tree for your device it should just work with the default out of the box configuration.

I’ve tried all kinds of CoreElec even older LibreElec and in or one it does not work.

What device do you have? Which device tree/dtb file are you using? coaxial or toslink cable?