Odroid N2 test builds

yes, I meet the remote’s issue too.especially when a media is playing. (I use estuary mod v2 skin)

The videos appear a little bit cartoonish. They appear to have too much sharpness.

I also see a lot of stutter in almost all videos I play. The playback is not as smooth as S912 box.

I meet the wired thing, N2 connect to PC monitor(1080P) via hdmi cable, Playback videos(HD and UHD) no stutter, skip: 0, VSyncoff: 0.0, but when N2 connect to TV(via the same hdmi cable), stutter happened on all videos, skip: numbers increase and VSyncoff: 10+,Who can explain this? switch to odroid c2, no such wired thing.

I think my TV is capable of hdr10+. How to test? Sample file?

Colors also look a little bit weird to me when comparing with my s905.

Also I was wondering why on this powerful hardware I still see lags during the playback when jumping around in the Kodi menu?!

Absolutely no criticism from my side, I’m just interested.

If you are talking about HEVC videos, you need to enable the HEVC seek workaround in CE System settings.

@rosenrot Yes, a HDR10+ sample.
What storage are you using? I don’t see any lags.

1 Like

I do use a recent sdcard for the moment. I will give a try to emmc soon. I had the plan to use the n2 as an ubuntu server running kodi besides. However, it seems kodi running on ubuntu is not quite ready yet. I was playing around a bit with it but it seems hopeless for now so I will use the emmc for coreelec soon.

@rosenrot, here is a HDR10+ sample you can try https://drive.google.com/file/d/1Nz2MPf2FPz3A99ciBSAl3m0U0XBbV1bv/view

Remember to run the test sample both on your N2 and your TV’s internal player to try to see any differences in quality. Also post dispinfo during playback (ssh into your box and run dispinfo)

Mediainfo

General
Complete name : ISS_4k_HDR10plus_ff.mp4
Format : MPEG-4
Format profile : Base Media
Codec ID : isom (isom/iso2/mp41)
File size : 1.61 GiB
Duration : 3mn 8s
Overall bit rate : 73.1 Mbps
Writing application : Lavf58.12.100

Video
ID : 1
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main 10@L5.1@High
HDR format : SMPTE ST 2094 App 4, Version 0
Codec ID : hev1
Codec ID/Info : High Efficiency Video Coding
Duration : 3mn 8s
Bit rate : 72.9 Mbps
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate : 24.000 fps
Color space : YUV
Chroma subsampling : 4:2:0 (Type 2)
Bit depth : 10 bits
Bits/(Pixel*Frame) : 0.366
Stream size : 1.60 GiB (100%)
Color range : Limited
Color primaries : BT.2020
Transfer characteristics : PQ
Matrix coefficients : BT.2020 non-constant
Mastering display color primaries : Display P3
Mastering display luminance : min: 0.0001 cd/m2, max: 1000 cd/m2
Maximum Content Light Level : 1000 cd/m2
Maximum Frame-Average Light Level : 400 cd/m2
Codec configuration box : hvcC

Audio
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Commercial name : Dolby Digital
Codec ID : ac-3
Duration : 3mn 8s
Bit rate mode : Constant
Bit rate : 192 Kbps
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 44.1 KHz
Frame rate : 28.711 fps (1536 SPF)
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 4.32 MiB (0%)
Service kind : Complete Main
Default : Yes
Alternate group : 1

ffmpeg info

{
“streams”: [
{
“index”: 0,
“codec_name”: “hevc”,
“codec_long_name”: “H.265 / HEVC (High Efficiency Video Coding)”,
“profile”: “Main 10”,
“codec_type”: “video”,
“codec_time_base”: “1/24”,
“codec_tag_string”: “hev1”,
“codec_tag”: “0x31766568”,
“width”: 3840,
“height”: 2160,
“coded_width”: 3840,
“coded_height”: 2160,
“has_b_frames”: 2,
“sample_aspect_ratio”: “1:1”,
“display_aspect_ratio”: “16:9”,
“pix_fmt”: “yuv420p10le”,
“level”: 153,
“color_range”: “tv”,
“color_space”: “bt2020nc”,
“color_transfer”: “smpte2084”,
“color_primaries”: “bt2020”,
“refs”: 1,
“r_frame_rate”: “24/1”,
“avg_frame_rate”: “1093658246/45539313”,
“time_base”: “1/1200000”,
“start_pts”: 0,
“start_time”: “0.000000”,
“duration_ts”: 226601813,
“duration”: “188.834844”,
“bit_rate”: “72965385”,
“nb_frames”: “4535”,
“disposition”: {
“default”: 1,
“dub”: 0,
“original”: 0,
“comment”: 0,
“lyrics”: 0,
“karaoke”: 0,
“forced”: 0,
“hearing_impaired”: 0,
“visual_impaired”: 0,
“clean_effects”: 0,
“attached_pic”: 0,
“timed_thumbnails”: 0
},
“tags”: {
“language”: “und”,
“handler_name”: “VideoHandler”
}
},
{
“index”: 1,
“codec_name”: “ac3”,
“codec_long_name”: “ATSC A/52A (AC-3)”,
“codec_type”: “audio”,
“codec_time_base”: “1/44100”,
“codec_tag_string”: “ac-3”,
“codec_tag”: “0x332d6361”,
“sample_fmt”: “fltp”,
“sample_rate”: “44100”,
“channels”: 2,
“channel_layout”: “stereo”,
“bits_per_sample”: 0,
“dmix_mode”: “-1”,
“ltrt_cmixlev”: “-1.000000”,
“ltrt_surmixlev”: “-1.000000”,
“loro_cmixlev”: “-1.000000”,
“loro_surmixlev”: “-1.000000”,
“r_frame_rate”: “0/0”,
“avg_frame_rate”: “0/0”,
“time_base”: “1/44100”,
“start_pts”: 0,
“start_time”: “0.000000”,
“duration_ts”: 8329476,
“duration”: “188.877007”,
“bit_rate”: “192000”,
“nb_frames”: “5423”,
“disposition”: {
“default”: 1,
“dub”: 0,
“original”: 0,
“comment”: 0,
“lyrics”: 0,
“karaoke”: 0,
“forced”: 0,
“hearing_impaired”: 0,
“visual_impaired”: 0,
“clean_effects”: 0,
“attached_pic”: 0,
“timed_thumbnails”: 0
},
“tags”: {
“language”: “und”,
“handler_name”: “SoundHandler”
},
“side_data_list”: [
{
“side_data_type”: “Audio Service Type”
}
]
}
],
“format”: {
“filename”: “ISS_4k_HDR10plus_ff.mp4”,
“nb_streams”: 2,
“nb_programs”: 0,
“format_name”: “mov,mp4,m4a,3gp,3g2,mj2”,
“format_long_name”: “QuickTime / MOV”,
“start_time”: “0.000000”,
“duration”: “188.883000”,
“size”: “1726962727”,
“bit_rate”: “73144231”,
“probe_score”: 100,
“tags”: {
“major_brand”: “isom”,
“minor_version”: “512”,
“compatible_brands”: “isomiso2mp41”,
“encoder”: “Lavf58.12.100”
}
}
}

As seen from Mediainfo, HDR format: SMPTE ST 2094 App 4, Version 0 is indicating that the file is HDR10+ :slight_smile:

1 Like

If you can play your stuff on one Monitor but not the TV it probably means that you are playing in the wrong refreshrate.

Now that you mention it I’m seeing that too.

Lol. You guys got used to the bad 3.14 stuff :smiley:
It is suppose to be that sharp. Compare with a Intel box.

I don’t think so, because I use the same N2(settings no change) / net cable / HDMI cable / PSU , Only monitor and TV difference, Why stutter on TV not on monitor, I can’t figure out, I will try another TV this weekend to see any difference.

Working really well thanks for this OS it’s really great.

One thing I noticed is that using the official Odroid wifi adapter also referred to as “WiFi adapter 5” on hardkernels site was unable to connect at 5ghz but 2.4ghz works fine.

The 5ghz connection works on Android and Ubuntu, just not CoreELEC, but I’m not too fussed as I can still connect using 2.4ghz and don’t need the speed really, I was just wanting to mention it.

The interesting thing is it saw the 5ghz SSID but it didn’t want to complete making the connection.

There are some videos I still cannot play, but I never have been able to play them on Android either or the Odroid C2, yet they play fine on VLC on Android on the same device. I think it’s a Kodi bug on ARM only, it just doesn’t start playing at all for those videos and returns to the menu. I don’t think it’s a CoreELEC issue so will try to send a bug report to Kodi.

The WiFi Module 5A.

Is that just for performance reasons? In my case, the screen was at 1080p, but the elements were sized larger than the visible screen, almost as if the font was sized for 4k (large), so that there was no space to display the content.

Douglas: I have the wifi adapter 5 (not 5a) it’s slightly bigger must be an earlier model. The only thing is I couldn’t connect at 5ghz but 2.4ghz was fine.

1 Like

Regarding Kodi not playing some videos …
I once had the same problem and had to use playercorefactory.xml to get rid of the Problem.

<playercorefactory>
<rules action="prepend">
<rule video="true" player="VideoPlayer"/>
<rule audio="true" player="PAPlayer"/>
</rules>
</playercorefactory>

Then I didn’t need it for quite some time; around a month ago I had to enable it again with my 2 Odroid-C2s … don’t know why, but all is being played again.

We are working on other stutter issues maybe it will fix yours. If those are HEVC files try the HEVC seek workaround settting in CE system settings (you need Expert mode)

Thanks for the tip count.zero, I just tried it but still no luck with some mkv videos that also gave me trouble with the C2. It’s OK though I will keep researching and look at the logs see if I can find anything.

If it helps, though I don’t really see any details why it failed, might need to turn on debugging:

NOTICE: Creating InputStream
ERROR: CVideoPlayer::OpenInputStream - error opening [somefile.mkv]
NOTICE: CVideoPlayer::OnExit()
NOTICE: CVideoPlayer::CloseFile()

But I think this is more a Kodi issue as it happens on Android too.

Ah I finally figured it out count.zero

It has nothing to do with the video format at all the logs revealed it, this has been a mystery for me for so long so it’s good to have finally solved it…

The only difference between my NUC running Kodi and my Odroid is that the NUC uses a mounted NFS share (in /etc/fstab) to the NAS while on the Odroid I am using Kodi to connect the NFS share, it seems that is the problem because when I copied the same video locally it started playing.

Maybe Kodi has an issue streaming over NFS that way when you connect directly through Kodi instead of a mounted share. Or maybe it’s a permission issue on my NAS, I’ll investigate that, but either way I have solved the original issue and discovered it was NFS.

What you describe is called overscan, and you need to disable that on your TV in order to get the image to fit perfectly on screen. Google how to disable overscan for your TV model if you don’t know how to do that, as it’s different for every manufacturer.
But I don’t really see any reason not to use 4K GUI on the N2. The upscaling capability of the new S922X is much, much better than the old S905/S912 hardware was capable of.

1 Like

very interesting … all my content on all my mediaplayers (NUC, C2, RPi2b) is “connected” via NFS through Kodi … maybe that leads/lead to my Problem as well; could try it with an automount via CoreElec and see what happens …

About | FAQ | Terms of Service | Privacy Policy | Legal Notice