[S922X] Bee-link GT King

NF works on 1080p I think.

Yes, Netflix works at 1080p but not all content. Mainly own productions work at 1080p.

The last nightly is rock solid !
The maximum temperature reached while using NF in fHD was around 56°C in a 26°C room.

I do encounter some minor issues, from time to time, as video frames not being refreshed (think of a badly encoded divx where parts of a frame would not be updated and full of pink or green).

Also, I wasn’t able to install inputstream.adaptive from the CoreELEC add-on repo (I add to donwload it manually and install).

I have the problem with emby server, anybody know if the problem is caused by coreelec version, the GT king or emby ?

I found a weird bug, if android resolution is 4K and coreelec kodi is in full hd, CE doesn’t boot.

I don’t know why but if first boot logo is displayed in 4K which is determined by android resolution setting and if CE is in full hd its not working.

I need to have same resolution in both systems to get it working.

Its an annoying problem especially for emuelec the retrogaming fork based on CE because its running in full hd for performance reasons and it limits android side to full hd in order to boot properly. I confirm same issue with standard CE.

Could you please have a look into this ?


I hope the remote and dual boot problems can be fixed immediately before launch. thanks

Thanks for the file it has resolved the power button issues.

Great work being done here as this is now stable enough to use as my daily driver even though it was only released a week ago.:+1:

right, and I just changed to the 201190713 generic version … and I started to feel the stability. I believe the team’s hard work will soon be realized. and GTK users must be impatiently waiting. … :+1::+1:

Let me start with thanking the CoreElec team for their fantastic work.

However I have some serious boot problems.

I received my BeeLink GT King device (with S/N 992X) a couple of days ago. I started with playing around with Android and installed a couple of apps.
After reading all of the info I could find about CoreElec and the BeeLink GT King, I installed the nightly build (20190710-Generic) of CoreElec with a USB stick (64 GB SanDisk Extreme USB 3.1, ExFat) on my BeeLink GT King device. I followed the instructions as given on this site and I encountered no problems what so ever. I installed Oscam and TVHeadEnd42, added a USB disk (WD Green, 2 GB, NTFS) and tested the speed of the wired Ethernet. The speed look promising at first, but after a couple of seconds the speed dropped down from ~60 Mbytes to less then 20 MBytes for the rest of the session. I installed nightly build 20190713 (manually as I do not know how to set the update channel for the nightly builds in CoreElec) without problems and I was able to (re)boot CoreElec at will.
Then I decided to do some tests under Android. At that moment I did not know that you should switch to Android by the “reboot to internal” Power Option Menu option (BTW, I cannot remember seeing such a option in the Power Option Menu). Anyhow, I just removed the USB stick before booting the device. As expected, Android came up and I was able to do some network testing and further (re)booting of Android posed no problems. To do the same network tests with CoreElec, I put back the CoreElec USB stick into the device and rebooted it. To my surprise, the device booted not into CoreElec, but into Android again. Whatever I tried, nothing helped. I even tried as remedy to do the whole installation process again. That resulted not in the installation of CoreElec, but only in the showing of the recovery screen.
Accidentally, I found a workaround. As long as the connected USB disk is accessible for the device during boot, it will boot into Android. When I switch off the USB disk before (re)boot the device will boot into CoreElec. This behaviour was not the case after the initial installation of CoreElec. Only after I booted into Android by removing the CoreElec USB stick before (re)booting, this unwanted behaviour became manifest. Furthermore, the speed of the Ethernet connection is now even lower then before and has become unbearable (only orange led shows, no green led visible).

Question is: what data is stored on the BeeLink GT King device by running Android without the CoreElec stick available for the boot process and where is that data stored that frustrates the boot process. Removing the Android folder from the USB disk is not the solution. I removed this folder already many times in vain.

Please let me know if extra data is needed for solving this boot problem.

TIA Baderks.

Try to put the CE pen to the rear USB 3.0.

Can you share the results of the network tests in Android also?

Switching USB ports worked, I just switched the USB disk and the USB CE pen and it did boot from the CoreElec.USB stick…
The working layout of the three USB ports is:

  • back side USB2 port: Logitech Unified Receiver (mouse/keyboard) + BeeLink Receiver (remote) + Argolus SmartReader V2 (smartcard)
  • left side near the back USB3 port: 64 GB SanDisk Extreme USB 3.1, ExFat (CoreElec pen)
  • left side near card reader USB3 port: WD Green, 2 GB, NTFS (USB3 disk)

Remains the question how to switch between CoreElec and Android as there is still no option in the Power Option Menu to do so.

Yes I will, but I have to wait till the local network is completely free to get useful results.
What I can say already, iperf3 results are more than OK (900+ Mbits/sec)


1 Like

Dual boot is not supported yet, we are working on it.

Hello, i have tried mount plex server and it show error too as emby server.

Could anybody try to install these servers?


Did you test your network in both directions? ie swapping server and client mode in iperf3.

Hi all
I see screenshots in some messages where you see a stop on a video image.
How do you have all this technical information from the files that will appear when it’s on pause? It depends on the kodi skin or is it that other thing?
In advance thank you.
Good night.
Kind regards.

I like to post the results of some network tests. However, I have no idea how to add screenshots and datafiles to a post. Please help me out.


You can post your iperf3 results in pastebin.com and post the links here. Just do what Adam said and use iperf3 in both directions please.

This is the pastebin filename of my iperf3 results: iperf3 results.txt

Is there a way to post screenshots to this blog? Those screenshots are from samba file transfers which are far more telling and interesting then the iperf3 results.


I can say that you’re luckier than most of team members that received the box. They don’t get near those results both in CoreELEC and Android. Can you make a summary of file transfer results in both directions and systems? Please, in android, try to write to usb because if you use emmc it will be surely faster and not comparable to CE.