[S922X] Bee-link GT King

I have GT-king revB and perfect quality.

Hi all 907p0 with dual boot has been released on beelink forum can’t post the link now but I have installed on my gtking and it is working

Did you mean Beekink != quality?
I don’t agree with you, but … not too bad for the job.
Neither Brian Kernighan and Dennis Ritchie. :slight_smile:

I haven’t inspected a Ugoos box but I have had a few different Beelink GT-King units and the first batch had a number of issues from broken HDMI to broken LAN port.

All of them I have inspected including the GT-King Pro had no-name/recycled RAM and eMMC.

The only devices I have seen use premium components are those from Hardkernel, Khadas and Minix, all of which I have seen use Nanya or Samsung RAM and/or eMMC chips.

I’m not trying to bash Beelink as they have been very supportive to us and other open-source projects.

1 Like

Ugoos devices looks pretty good, well done, came with hynix memory modules and other good components, but they cost half more (150€ vs 100€) and bring half of internal storage (32GB vs 64GB) than the Beelink GT King.

The Beelink one with a CE TF is $10 cheaper on gearbest, the non-CE is actually same price as Ugoos. $129-$139.
In EU I guess the differences are higher?
Is more space on eMMC really necessary?

The prices are from geekbuying, 150€ Ugoos AM6 Pro (4G/32G/1G), 100€ Beelink GT King (4G/64G/1G), 130€ Beelink GT King Pro (4G/64G/1G).

I prefer more internal emmc memory than less, don’t you? With 64Gb you can split emmc and use half for CE and the other half for android.

I found the emmc on the King to be noticeably slower than my VIM2 which points towards a cheap component. Coupled to the lack of attention to cooling and I would choose something else.

Shoog

There are cheaper retailers, but of course you need to consider shipping/warranty/import taxes to see what works best price wise.
As for eMMC size, I think 32gb can hold android and CE with reasonable enough space left? Unless you store a lot of thumbnails or previews, install lots of apps etc. The space isn’t needed or useful for storing actual full length videos. I’d rather have a better but smaller eMMC than an unbranded/recycled/slower 64gb one.
Again, I have no experience with either boxes, just going by comments from others.

Super, working OK.

I am totally new to CoreELEC, sorry for noob questions. I had the B922* GT King box for a month, couldn’t make it show my 4K images without downscaling to 1080p (under Kodi or any other app). Looking through this thread it appears that you now have a stable port of CoreELEC for my player - correct? Can you also please confirm that

  • One can switch to 4K GUI (and use 4K under Kodi to display images, and videos)
  • SPDIF works under Kodi
  • The earlier Gigabit ethernet issue is resolved
  • IR control works
  • One can use standard Kodi add-ons (for example, the Artist Slideshow add-on, which I want to use for music slideshows of my 4k images).

Thanks a lot!

Yes to the first 4. You just need to confirm if you have the a or b revision (as mentioned in above threads). You may need edit remote.conf per above if you can’t turn box off using remote. Not tried the last one. Should do though.

1 Like

Thanks for the quick reply! My serial number starts with B922 - so presumably it is the “b” version?


B922 doesn’t mean nothing related to a and b revision…

1 Like

Thanks, I’ll check it when I get home.

Interesting - so my box is rev A (the serial starts with 290a). Thanks again for the tip.

It worked… Until I did something, and then it didn’t. Installation went fine, I booted into CoreELEC, switched System resolution to 2160p (no issues), but then when I changed to “render GUI in 4K” in the CoreELEC settings and rebooted the gadget, I can only see the initial CoreELEC logo, and then only black screen.

Is there a way to reset CoreELEC to the original state?

Never mind, I ran “systemctl restart kodi” from ssh, and it brought back kodi. It does looks sharper, so perhaps it does use 4K GUI. But it looks this mode is unstable. I’ll check if I need this mode to render my images in 4K without downscaling.

BTW I still have SSH access into the box.

Just to say that also Ugoos am6 is not shipped anymore with rev. B cpu, some users documented this in youtube video comments.

A question - does CoreELEC installed on this player (on a uSD card) use the built-in flush memory of the player? If yes, where is it mounted? If not, then I made a mistake using a very small SD card (only 2GB) for CoreELEC installation. Can I switch to a larger SD card after the initial installation? What’s the procedure?

CE uses only space on medium that is installed on, so in your case on uSD card.

To switch to larger uSD card when installation (on smaller one) is finished you make a System Backup (from CoreElec Settings) and copy it to some device. After you finish installation on larger one, then you restore from that device.

1 Like