[S922X] Bee-link GT King

This issue has been discussed multiple times in the 9.2.2 thread.

You need to update the Android firmware.

If you wiped the device to install to internal then you will have to restore Android and upgrade it then reinstall.

Hello everybody.
I just bought the GT King and started using CE; last night I updated to 9.2.2
I find a problem with USB HDD handling (don’t know if GT King or CE 9.2.2). I’ll try to explain.
I used Beelink GT1 until I bought the King; my home entertainment is configured as follows: the movies in a HDD connected to a W10 PC and the Beelink connects via Wi-Fi. As I now have a UHD TV, I started to watch UHD movies that cannot be streamed via Wi-Fi because of frequent caching problems, so I got an old HDD and attached it to the new BT King (and before, to the old GT1) and tried to copy the movie files to it using the W10 PC. Copying is always interrupting because of some kind of problems. It is only happening now, it didn’t happen with the old GT1 on CE 9.2.1.
Yesterday I tried copying the files using the Kodi File manager and it finished without errors.
Is there anything releated to GT King or CE 9.2.2 changed anything in USB HDD handling?

I had problem of lost ethernet IP adress under CoreElec 9.2.1
I update android firmware and problems decreased but was still present.

Since CoreElec 9.2.2 I never had another time this problem that seems to be solved.

1 Like

I got my new GT King a couple of days ago. All went smooth with updating Android to latest version and installing CE on an SanDisk USB 3.0 stick. After I had finished the full install incl. media and all, I started to see the following error on start-up: on the boot screen a text appeared saying (see video):

(X of 7) A start job is running…

after a while I got a lot of text on screen and no more action (see pic).

I did a fresh re-install on the USB Stick with same issue. I now moved to a Samsung uSD card, so far so good, normal boot.

Is there anyway to diagnose what is wrong with the USB Stick install from what I attached ? Maybe a bad stick or does the GT King just not like USB Sticks ?

I would try to reburn the install image with Rufus, it’s possible that the storage partition was not resized on first boot.

I did using the same stick, same result; uSD is working w/o issue for two days already - thus I think could be bad stick.


After changing the router I have a strange problem with the lan connection. On the old router lan worked nice, but now after applying the new router (ubee evw32c) I can’t get a working connection.
In the router settings I don’t see CE.
In sam time, when I reboot to android … lan works :astonished:
Lan ports of that router works too on all other devices which I connect.
I tried to set up the connection via dhcp and manually but no luck.
Connection status shows “ready”
Wlan 2.4g and 5g works too
Where to look for solution to get working lan?

Check in Android that you have firmware 905P0 or above. If not then update it to latest.

1 Like

I upgraded android from 904P0 to latest 905P0, but now I cant boot to CE on sd card.

When i insert sd card with CE into slot, after turn on, sistem boot android instead CE.

In android … Long press to remote power button give me popup menu without “switch sistem” card.

After Android upgrade you will need to push and hold reset button on power on until you see CE logo.

1 Like

Thnx for help.
Again everything working like it should

One year later, and I’m still enjoying the GTKing with CoreELECvery much. Everything works like a charm !

1 Like

if you haven’t seen it, Bee-link advertised a new tv-box with nas functionality:

My beelink gt king pro rev b serial:290b
In coreelec hardware info cpu speed:1800mhz
Is this normal?

Yes. The two A53 cores are in the “first” cluster, and they’re running at 1800MHz.
The 4 faster A73 cores are in the 2nd cluster, and do run at 2200MHz when you use the non-A DTB.

i’m using g12b_s922x_beelink_gt_king dtb

Then the CPU is running at 1800/2200MHz

1 Like

Then I can completely delete Android and install CE in the internal storage (ceemmc) … Will it have full ethernet? Thank you

You Android should be updated to level 905P0 or above before do it in any case.

1 Like

Tested and approved since several months. Go for it, you will never regret it !