Slow down of

Wow really really great job, today i will update to this new version.

But yesterday I’ve watched livetv and mkv movies about 4h and 0 slowdowns.

Now I only want to know if it’s possible to turn off the leds in kodi menus, my box is on 24h and I need to turn off they in the UI

1 Like

So if the grabbing frequency will be adjusted to the video - this means that the frequency set in the Hyperion config will be skipped?

I can confirm that this new verison works with H264 4K non-HDR movies as well, thanks for that!
The other file I was trying to test with was a hevc 4k HDR file, there the leds either remained blank or showed some random static color, so it seems that it is not (yet :wink: ) working.

I don’t think it is the same issue.

1 Like

Yes, it is more “user + developer friendly”!

I uploaded two more slow-mo vids of smoothing testing whilst a video grabbing (“video_” prefix). As i can see, smoothing doesn’t work for it either :frowning: Dear @Portisch, i express my deepest gratitude to your work, and i will use it “as is” with my pleasure for sure (coz it’s awesome)! But if you have an interest yet - please, look into this problem too :pray:

@benoe, it was discussed many many times before :wink: For example, here is described a simple solution for HEVC, but keep in mind, that it heavily loads the RAM’s I/O, so you can face some trouble (artifacts or even system hanging) on cheap boxes.

What I miss is the part what is on the TV screen. Otherwise I can not reproduce the issue.

Just instant (literally, per-frame) color change from blue to black. I use this video for testing, smoothing was set to 50Hz. My eyes pretty sensitive (above overage), especially as for strobing effects, and i can see the difference with an unarmed eye. That’s why i recorded slow-mo videos for you :slight_smile:

So by entering that single line hyperion and framegrabber will work on H265 files as well?

echo 1 | tee /sys/module/amvdec_h265/parameters/double_write_mode

This is not clear for me.
First: You know the framerate of this video? Remember the frame grabbing speed == frame rate. So do not use video’s with a low frame rate like 24Hz.
Second: You talked about OSD (user interface) and not video!?

I believe, it’s my bad English, sorry :slight_smile:

  1. Hyperion has built-in smoothing mechanism, which interpolate color changing. It calculates missing intermediate colors if the LED output FPS set higher than grabbed FPS. So for your latest implementation, it should be like that: video frame rate (f.e. 24Hz) == grabbing speed (same 24Hz) != LED output frame rate (50Hz thanks to smoothing). And resulting LED output should be stepless and fluent no matters how low original grabbed FPS is.

  2. Firstly i noticed and reported the problem with UI, and promised to check the video grabbing either. Later (today) i checked it and confirmed that video grabbing doesn’t use smoothing either.

No, this line actually makes the video output corrupt.

If you set your screensaver in kodi to black your leds will turn off.

That’s how i do it

Yes, I am doing the same at this moment, but if there’s an option to skip the UI grabbing like in standard Hyperion with kodicheck, it will be better

I’m using non modified and CE stable image and for me echo 3 (instead of 1) in my is working great for all content including 4K HDR. I haven’t noticed any performance issues yet.

echo 3 | tee /sys/module/amvdec_h265/parameters/double_write_mode


Will see what happens with this setting in the latest test build.

All these other problems are off-topic. Here we talk only about the slow-downs.
So for other features/bugs make a new thread or if related go to the hyperion support forum.

1 Like

Is this also addressed to me? But smoothing peculiarities are reproduced only with modified Hyperion :pleading_face:

I can’t reproduce, make a video of the TV & the LEDs the same time and send me a Link to the video. But it also for a new thread…

what i can say: it IS smoothing GUI and Video. i can not say if it is as smooth as before Portisch´s modifications - but i cant see any difference.
vevs: maybe you have to play with smoothing settings because they change with capture frequency as Portisch said…?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice