[SOLVED] Sometimes video starts in just 1/4th of the screen

As the title says sometimes video just shows in 1/4th of the screen. When jumping 10 seconds back the video goes fullscreen. See picture for what I mean. Anybody else with this problem and/or solution?

Do you use last nightly 20200702?

If you used las nightly please try this image: https://test.coreelec.org/Portisch/CoreELEC-Amlogic-ng.arm-9.2-devel-1593968901.tar
@roidy you maybe also want to try it?
Please be sure to disable hdmimode in config.ini again for the test, thx.

Unfortunately that doesn’t fix the issue I am having :frowning:

Thank you for testing it!

This issue is caused buy either resolution scaling in guisettings or by using a 3rd party skin. If it’s the later you have to set GUI for 4K.

@Portisch I run 9.2.3, but have seen this on 9.2.2 also. I will generate a debug log for you when it happens again.

@Ray I do run a third party skin (Eminence), no whitelist and GUI at 1080p. I don’t use whitelist because if I watch some 3840x2160 content it will for some reason upscale it to 4096x2160. This doesn’t happens when I leave the whitelist empty. Unfortunately that does mean 720p gets up scaled to 1080p. If I will set GUI to 4K everything below that will get up scaled unless I set the whitelist but then some 3840x2160 content will be up scaled to 4096x2160.

And it doesn’t happen with the default skin. You can either use that or use 4K in the GUI. At least that’s what I found. This didn’t happen in 9.2.1.

Okay, for now I will just stick to the 10 second jump back to solve the problem but thanks for the information.

@Portisch, here http://ix.io/2r33 is the log file you asked for.

I am seeing this behavior as well. On an N2 and a C4 is just got.i believe both have the UI set to 1080p. Which I believe was recommended when the N2 was released.

I guess I’ll just run the UI at 4k. Unless there is another negative that will produce.

I am currently also doing the skip forward skip back thing.

I have been running on 4K as @Ray has suggested for a couple of days now and I can confirm that it solves the problem. I have read that the UI is less snappy/responsive then running it on 1080p, but I use a Harmony remote with IR blaster so that setup causes delays on it own and therefore I can’t comment on that. But you can decide for your self by testing it. Another thing you have to keep in mind is that all video content with resolutions below 4K are getting up scaled by the N2/C4 and if you don’t like that you need to enable all resolutions your TV can display and you don’t want to get up scaled in the whitelist.

Yeah I currently have everything whitelisted and it switches as it should. I’ll bump the UI to 4k. Thanks

this fixed it for me

About | FAQ | Terms of Service | Privacy Policy | Legal Notice