Tanix TX5 plus S905x3 4/64GB 1000Mbps lan


i ve take a look on the forum , but nothing found .
does the tx5 plus (tanix) is supported ? ?

evry help , or advice will be appreciated ::slight_smile:


Go to coreelec.org and download the build for generic S905x3. Then you can try the corresponding dtb. If your box really has those features I would start with sm1_s905x3_4g_1gbit.dtb

OK :ok_hand:
Tanks ! :slight_smile:

Soir to Boring you , but , where car i find the coreelec noob guide ? (Beginer guide ?)

This should help

Thanks a lot , !!!
Will try it quicly.

Alain thanks for your help :slight_smile:

humm …
tried the toothpick method … led display say booting … screen stay black.

installed the terminal emulator apk and use the reboot update command , device is rebooting , few second after is display (on led display) boot … but nothing , screen stay black :-/ doh

Did you pick the right dtb and renamed it to dtb.img placing it in the root of the uSD card?

no , i m a stupide :frowning:

i must RTFM !!
for information using a usb stick drive only the left usb port is booting .
corelec is booted now, it s waiting on config screen , (just at this moment )

can t configure it , remote seems to be not working , curious .

Use USB keyboard to configure.
After this read how to configure the remote - pls use forum search

sorry .
i will take a look on the forum , before writing next time .

okay … i installed coreelec, with a usb keyboard , booting on 4gb sdcard
, it works pretty well! very good job !!!
very impressive ! a real linux mini distro , nice !

on the other hand kodi worries me, it can not read many videos (crash , hang , restart of videos ) , while they are opened by vlc or mpv?

where do i report “it works on this device”, thanks guys!

I need help :worried:

I’m using: sm1_s905x3_4g_1gbit.dtb and everything works perfectly but:

I have the same TV box, Tanix TX5 Plus Deluxe Edition, but when I run CoreELEC on the led display (of the TV box) “boot” is always displayed and when I turn off the TV box with the shutdown button on Kodi or with “shutdown -h now” (ssh), CoreELEC turns off the TV but on the led display (of the TV box) it does not turn off but continues to display “boot” – and – if I turn on the TV the TV box starts automatically, showing the boot logo of the box and after the CoreELEC logo.

How can I turn off the TV box completely when I click the shutdown button on Kodi or with ‘shutdown -h now’ (ssh)?

@guigux & @Betatester, do you also have my same problem?

See if the guide on configuring the VFD can help.

I’ve never hard of the deluxe version of this box but perhaps you have one with an updated spec of some kind.

Unless you configure VFD

Your box will always show boot on the LED screen when powering OFF from CoreELEC.

No startup/shutdown problems here with the TaNiX TX5 Deluxe Edition. Works fine with the TaNiX remote. For the display:

Tanix_vfd.conf (1.2 KB)

Thanks for your help.

I used this vfd.conf: link_to_vfd.conf

We’re preparing coreElec firmware for TX5 Plus “Deluxe Edition”. Also emuElec.

I’ll share ASAP


Your account suggests that you are a tanix representative. Make sure to post all source code to your builds when posting links.
EmuElec includes libretro software which have Non-commercial licenses. We respect libretro licenses and ask that no vendor use it commercially.
Rather than posting and maintaining fork builds commercially please consider contributing directly through GitHub to our codebase.


Just bought it from Amazon.es.
Hope CE support for the box will be good :slight_smile: