VIM3L using MCE remote

I managed to update to the latest Matrix and I want to use my MCE remote. I had it confiured ok in Lea, now trying to figure it out in Matrix. I read the mulit remote option, having somw problems getting it to work. Is it possible? Could someone point me to the correct way to do it for the VIM3L?
Thanks

Have you checked here?

Yes, first thing I tried. I selected RC6 and rebooted and remote won’t work. Selected NEC and reboot and the Khadas remote works fine. Also tried all the other protocols and none worked with the MCE remote. I used an RC6 USB dongle and with that the MCE remote works fine (power on and off also works) I have 3 of these boxes but sadly only one dongle and would like to get all 3 on Matrix.

Strange, I am able to use an MCE remote with Hardkernels Odroid N2+ and all I have to do is set the hardware to MCE (not RC6), reboot, and it works without needing the USB dongle.

Could you please try that and also ensure there are no Amlogic or Meson remote configuration files on the device?

Instructions are listed at step 2 of the troubleshooter.

image

On the VIM3L there is no “MCE” to select under the remote, there is RC6, RC5, NEC, SONY, and a few others, tried them all. I also have an N2+ and 2 C-4’s all running Matrix 19.4 using the MCE remote with no problems. With Lea running on the VIM3L, I had to make up the multi remote config to make it work. I did a fresh install using K-rescue to write it to the EEMC. It was Matrix 2, then updated to 4. I’ll look and remove any remote config files and run through step 2 that you referenced.
Thanks

Let me know if you have success.

I think you should start from scratch. Remove any custom remote config file and then reboot the device. And MCE remote should work without doing anything extra.

Also logs are always welcome.

I think I might know whats going on. I installed Matrix ver from there K-rescue recovery, not the generic ver from CE. I’m assuming that forces their remote to work. Couldn’t figure out how to remove it from thier ver, so ive been trying to install the official ver on and run it from the SD card. The problem now is, I can’t get the VIM3L to boot from the SD card with CE on it. I posted on their forum for any solutions… If anyone here knows how to do it PLEASE let me know…

Burn android and then you can use CE from the card or use ceemmc for dual boot (or only CE if you wish)

That was my thought too. I burned Android to the emmc, downloaded CE generic and used etcher to install it on the SD (tried 3 different ones), coppied the vim3l dtb to the root directory and renamed it .dtb.img, long pressed pwr, short pressed func, count 10, release pwr. It just hangs on the black screen with the Kahadas image. There was a post that the android image was the problem and v200030 woked. I found that, cleared the emmc, used the burn tool to install it on the emmc, same problem, wouldnt boot from the SD. (both ver of android booted ok).

Can you let me know if these instructions work?

Thanks for staying with me on this. Unfortunately no they do not. Still won’t boot from the SD with Android installed. It shows the Khadas splash screen and freezes there with the SD installed. I tried with the K-rescue SD and it boots from that installed. In fact, with the K-rescue SD I dont even have to enter the upgrade mode, it will jist boot to that SD.

It is also possible to use adb shell

adb connect 192.168.0.....
adb shell
reboot update
1 Like

Try what vpeter suggests or execute reboot update from terminal and if that doesn’t work logs are needed for further troubleshooting…

Yes, got the correct button sequence, also tried the function button 3 times, both het to the splash screen and freezes. I’ll try the app and thw other methods

I tried the procedures listed above on Vim3 with CoreELEC 19.4 on a clean 32 Gb µSD Card created by Rufus, using g12b_a311d_khadas_vim3.dtb, and booted CoreELEC successfully.

CoreELEC boot log.

From the Khadas User Forums I understand Vim3 and Vim3L use the same steps to enter upgrade mode.

The install procedure should work for Vim 3L.

MCE remote works OOTB, no dongle needed.

Please try with a clean SD Card or USB Flash Drive, and a fresh install.

I got it !!! Don’t know why it worked, but it did…
If finally got it to boot from the SD (same one I was using). I found this post on the Khadas forum it had to do with problems booting from the SD. In post #48 he got Coreelec to boot from the sd.

  1. I downloaded CoreELEC-Amlogic-ng.arm-9.2.3-Generic.img.gz, created the SD using Rufus and copied and renamed the dtb to the root of the SD

2.Booted using the latest Krescue and installed their Coreelec 9.5 to the Emmc, selected “reboot” when the image was done writing. That will bring up a menu to reboot or power off, I selected “power off”
the VIM3L shutdown but the blue led was still lit. (I did not remove the power)

3 With the VIM3L off and the blue led lit I swapped the Krescue sd with the sd that I created above that had 9.2.3 on it. Pressed the power button (once and didn’t hold it) and it booted to the SD card, installed 9.2.3 and auto down loaded 9.2.8., and I rebooted, once again it booted from the SD card showing 9.2.8

  1. I selected manual update and the Matrix19 update channel, and updated to Matrix 19.4. It rebooted again from the SD card.

  2. I removed the SD card and it booted from the Emmc showing 9.2.5. and then powered off and re-installed the SD card, powered on and it booted from the SD card to Matrix 19.4

  3. Used putty to ssh to the Vim3L and used ceemmc to write Matrix 19.4 to the Emmc.

Now boots from the emmc with official Matrix 19.4… AND AND… my MCE remote now works with no custom remote config’s needed…
Not sure why it worked or how, I used the versions that the poster used in the Khadas forum.
Thanks for all the help and advice…

2 Likes

One more thing I could add. I had a second Vim3l that was running 9.2.8 that I wanted to upgrade too. I inserted the same SD card that my first one booted on, and from a cold power off state, it too booted from the SD card to Matrix and I used ceemmc to flash it to the emmc. Took 10 minutes!

I did some further testing and found this issue only affects the CE images provided by krescue.

The only method that currently works with krescue is:

  • clean the eMMC module (options 7/8/3 of the menu)
  • flash the VIMX-Android-Pie_VXXXXXX.raw.img.gz from the downloads folder to the VIM3/3L (options 3/3 of the menu)
  • reboot to Android Pie (option b of the menu)

Once booted into Android Pie, follow the installation instructions from the CoreELEC Wiki.