WakeOnLan not working

This is excellent news if fixed, i use Kore remote to shut off the device when i go to sleep, but sometimes wake up and want to turn the tv on again, but cant be bothered to go into the other room to wake it up with the remote.

Anything special you have to do like mac codes or anything?


I have no idea why this code is in mainline Linux as it is not working. It was much better in 3.14 kernel.

Updated to 228. It’s working!

unfortunately WOL still not working here after suspending odroid n2, tested on 9.2.1 and also today after update to 9.2.2. no problem to wake it up with CEC remote.
when checking with ethtool, it shows wol d, then tried to change it - did so and shows wol g, but nothing changes in the behaviour.
WOL seems to be still broken…
wol d

  1. Check that wol is enabled in config.ini(or in CE settings), after go to step 2
  2. For clean experiment power off the box, unplug power cable for 10 seconds, plug it again.
  3. try to power off or suspend a box and check again.
    If nothing work then follow Portisch link to collect logs

ethtool output has nothing with WOL working state on box


well, i’m dummy, it was even disabled under CEC gui. thanks, you brought me to that with your hint.
it is indeed working now…

I just made the upgrade to 9.2.2 and i have had the Power out of the box the 10 second above explained and tried again, but WOL doesnt work. WOL is switched on in the CE settings and CEC is on (necessary?). I need to add i send the WOL from the Kodi official IOS app. When the Odroid N2 is on this app works flawlessly but when I try the WOL function in it towards a sleeping CoreElec it doesn’t fix to wake it up. Is this a Kodi app problem or I read above also people asking for where to put the MAC address. I haven’t used any MAC address in the app. The app finds the IP address for the ODroid machine and for everything else that works. Any ideas?

WOL is done by MAC address.
You can find the correct address in your DHCP server, or like by a SSH connection by command: dmesg | grep wol.
I have no idea how your IOS App is working so you need to contact the author of the app.

Of course, too many app’s :-). I will try to find that out. What is normally the way somebody sends a WOL? I have IOS units and Windows 10 PC. I prefer an IOS solution because the PC is in the wrong room. Thanks!

more options, app is quite handy, bulletproof is by the router, if it supports that function

1 Like

I still dont get it, where do we put the MAC address of the N2 lol

Hi, i found that place in my router which is a Asus router (std firmware). There is a section in the config talking about WOL and there I can put a MAC address.

I’m on the current stable 9.2.2, having wake on lan enabled in the CE settings, and if I try to wake the odroid N2 shortly after suspending it (couple of minutes), it works. However, a few hours later, I can’t get it to wake up anymore.
I have powered down the N2 and disconnected power a couple of times already.

I did notice that CEC Wake-Up settings automatically reset to on, even after I disabled them manually (I don’t use CEC on my devices). Even if I just exit the settings menu and enter it again right away, it is back on.

Do I need to install a nightly build?

Maybe, don’t remember exactly. There was a bug WOL worked only once. Best is to try nightly!

It does work several times in my case, definitely during the first hours of sleep. I’ll let it sleep for a couple of hours more until tonight and will report back. If it doesn’t wake up, I’ll try the nightly.

It worked for a couple of days, and then stopped again.
I now installed the nightly update and hope to see it continues waking up from WOL package.

I see no reason why WOL on CE should stop working after a long time. I think it’s more a issue about the LAN structure and release of clients after a long time.

All my devices have fixed IP’s in my network. I have now kept a keyboard attached to the N2, and when I’m unable to wake up the device from a WOL package, I also can’t wake it through the keyboard.
Strange though is that keyboard lights (numlock) do light up when pressing a key, but the N2 doesn’t react. Only way to get it back is to cut power.
I guess that for some reason the N2 powers down completely instead of remaining in the sleep mode? But would the keyboards still light up when powered down?

Just tried: if the system is shut down manually, there’s no way of getting lights on the keyboard. So it must be still in some suspended mode, but it just doesn’t wake, neither from the WOL package, nor from pressing the keyboard.