X96 X4 - S905X4 based box - any success?

If you mean it feels slower in operation rather than in benchmark numbers, the answer is probably that small size single queue depth one read performance (RND4K Q1D1) is the most important for running an OS and the Patriot is better there.

I’m testing the model: X96 X4 on the back says that it is:
TT TV Box / Model: X4 / Ram: 4GB / Rom: 64GB
But what is this model really? :slight_smile:
defects / problems (as it is Chinese production, it is not known what components it has inside and + recurring problem with overheating. Modification of the housing would be nice)
CoreElec version: CoreELEC-Amlogic-ng.arm-20.0-Nexus_nightly_20
Installed on a micro SD card: SanDisk (high endurance) 32GB
The box seems to be working properly.
Gigabit wired network is OK

ethtool eth0 | grep -i speed
Speed: 1000Mb/s

The display after installing openvfd + uploading the vfd.conf file works OK
x96-max-ultra-vfd.conf (1.2 KB)

The original remote that came with the BOX works OK with this file:
remote_2.conf (2.6 KB)

However, in my opinion, this pilot model works more smoothly in the CE: BPR1 BPR1S Plus 2.4G/USB ( you can program a button, e.g. on / off from the original remote control for any button, a triangle worked for me) good is also: G10S Pro BT Air Mouse 2.4G
more info: fw_printenv | paste / dmesg | paste
http://ix.io/4dPV / http://ix.io/4dQ3
On Android / Aida64 Box it is identified:
Developer: Droidlogic
Model: X96_X4_Pro
Brand: Droidlogic
Ethernet: RTL8211F_Gigabit_Ethernet
Flash: Samsung CKTM4R / size:64GB
WiFi: bcmsdh_sdmmc
board: sc2_s905x4_ah212-4g
on the info shop website:
Brand Name: BOXPUT … ? I think it’s the name of the remote and not the brand / manufacturer of the box :slight_smile:
WiFi - 2.4 / 5 GHz - The network works OK ! … but the speed probably depends on the advanced network settings, especially 5Ghz (router settings etc.) ?


I don’t think your LAN eth0 ist working properly, why it has so much “Retr”, and WLAN has 0 “Retr”?

I have also X96_x4 1000M Rev 1.3, it has other PHY.
And did iperf3 benchmark with coreelec-ne, Kernel 5.4.125, and got better results:

What Board Rev. is it?

What Board Rev. is it?

how to check ? in CoreElec? Android?
maybe a different version of CE will be better?

I do not know if this is reliable data from the CE menu

It is printed on the PCB near the heatsink. You can see in picture above, screenshot from video with red arrows around it, it is “V 1.3”, in other picture is one “V 1.2”.

OK … but unfortunately it’s not my BOX so it won’t be opened without permission.
One observation, I think we have different versions of CoreElec and what goes with other linux kernels.

On my X96max + (S905X3 rev b) the speed result is comparable so it can only be my individual network settings / router / switch device etc.
And the Retr parameter is only zero with a WiFi network, not a wired network

shows that at least the wired network is working properly

The second purchase of a friend (as with boxes from the Chinese from Ali) is a different version in the Kodi / CE menu, he writes: rev b … wifi and wired network do not work here :slight_smile: maybe someone will need photos:

  • the famous JL2101 :slight_smile:


This doesn’t help, no. You need to spend one device for debugging to get the driver fixed. I see no other possibilities.

Hehhh …I got a free hand what to do with this BOX … heh he :slight_smile: … maybe a garbage can? :slight_smile: If you really want to work on it, please provide data on PW / e-mail on how to deliver the BOX


I have a x96 Max+ Ultra 4GB/64 GB DualBand and Ethernet 100 MB

when coreelec starts with dtb sc2_s905x4_4g
The network card does not recognize me, most likely the Wi-Fi does not recognize it either

This problem is still unresolved, right?, at least from what I’ve read in this thread


This one looks like mine (x96 x4), which is also same rev 1.3, which works now flawless on CE-ng nightly 20.

And networking works with android, or not?

I do not know if this BOX model with rev. b is sometimes not broken :-(? … for now developers are working on it but will it be ok ???

Mine is also rev. b of Amlogic s905x4 chip.

maybe only my BOX/player is faulty ?

Does it (WLAN, LAN) work with pre-installed android?
If not, return it to shop.

The BOX is not really mine and the owner, in addition, damaged the flap when inserting the batteries into the remote control … and now it is difficult to advertise such equipment to the seller. So all that was left was testing. If it fails, it will probably end up in the trash, unless some dondle usb/wifi will work OK, but it’s such a forced prosthesis :slight_smile:

I have Wired network problem with my X96X4 4GB 32GB 1gbit run on 20.0-Nexus_nightly_20230113
Reboot the router many times
Please someone with experience help me in this case:

  1. Boot from MiroSD, connected to the network ethernet cable but no signal.
  2. Go to the Connections section and see Wired Interface: eth0, State: ready, Type: auto, Address: (every time the network has problem, I see this IP)
  3. Go to System Info >> Network and see Link: Connected, MAC=90:0E:B3:58…(exactly the MAC printed in the box). Gateway: blank. It seems that this error has never been caused by MAC.
  4. Go back to Power Option and click Reboot from eMMC/NAND
  5. The device boots into Android. Then…
  6. I turn off the device with the remote control.
  7. Turn on the box by remote control. It boots into CoreElec.
  8. Wired internet automatically connects with real IP address same as my network.
  9. Shut down and reboot with remote control, the device still has Wired internet. But…
  10. Unplug power and restart, bad thing is come back, no wired internet, have to repeat step 4.

I’m going to give up on this box because it’s been giving me a headache all week. But I regret the effort of remaping the remote control, so I’ll try again this time to see if anyone can help.

With such serious problems, it’s only for CoreElec developers. I did it with my friend’s BOX … if they have the time and willingness, they will help you, but you also have to take into account the fact that it may be necessary to physically deliver the faulty equipment. Sometimes it can be just faulty hardware or wrong android software uploaded because my BOX also worked badly on Android!.. I’m waiting and… maybe it will be OK?

Thanks for your suggestion. In my opinion, if this is a hardware failure then it will never be able to connect to the internet using the ethernet card. Is it possible if the driver of the ethernet card can recognize its presence without activation from Android?