9.2.4.2 Discussion

@skupi I have a new official build with bl301_inject reverted. Do you feel lucky to test an update from an 9.2.3 injected X96Max?

My KIII Pro s912 still not having a smooth playback on HD channels. It is freezing 1sec each 3sec

I don’t use sd card, I have Android on internal nand. I don’t enter recovery but just get correct boot to Android. I did Android update and after that my box start correctly.

I connect USB cable for burning tool to USB 3.0, connect power adapter and short those pin suddenly I saw boot on display. I found on freaktab that other pin someone suggest I will upload it later. I will be at home.

sd card was not inside box.

I tried get recovery but I can’t, only boot to Android.

Iam not sure. Cause I am luckly achieve only boot to Android not to recovery. And Android update help me.

damn, my TX5 Pro is dead too :frowning:
just after the update was installed. not even android is booting either, completely fubar :frowning:

ordered a usb-a to usb-a cable to try the burning too.
or anyone got another great idea?

first time that an update was that bad…but it happens

installed kodi on my TV (yuk) so my dauther won’t bite me :smiley: :smiley:

Here’s the top and bottom of my TR99 X2, any idea which pins I am looking to short? Any pointers on what to look for?

Solution:

Look on freaktab

Try to get into recovery. But probably you will need to short pins.

Hi,
Just auto updated on x3 max 96 plus 2. & so slow!!!

Never had this before after an update!

It’s ok until RSS feed begins to scroll.

thank you! but it seems I am the only one with this board?!?



there two pins next to the NAND are too easy?!? :smiley:

not even the recovery is loading :frowning:
still looking for confirmation for the two pins

Everyone who downloaded 9.2.4 already and didn’t perform a update please DO NOT!
Just delete the tar file in /storage/.update if already downloaded!

inject_bl301 has a error with G12A (S905X2) if BL301 got injected before update.
So only this constellation get bricked. Others are save like if another SoC type or BL301 is not injected.

It’s already fixed and a new release image will be published soon.

Sorry for that :frowning:

1 Like

@Saviq you see the lines left and right of the Samsung eMMC?
You need to try to find the pins by shorten every time only 2 when until it works.

I do it like DC power off, shorten two pins, DC power on, release the short after ~5 seconds.
If no recover is seen on screen: DC power off again and try next 2 pins. Same procedure again.

@1of16 this pins looks like it’s for this action. Also there are a lot others under the chip. Just do the same procedure as above to find the correct pins.

When you shorten pins and the LEDs stay off release immediately the shorten pins!

Remember: when performing a eMMC short out a micro SD card created by Burncardmaker have to be insert. Then the device will boot from this micro SD card instead of eMMC.

1 Like

I have also bricked a Beelink W95 S905W box. After inject with BL301, the box didn’t start anymore i must also shorten two pins for the recovery mode. Now the Box runs with 9.2.3.95.
My Nexbox runs very will with the inject.

thank you for the instructions, I’ll try that tomorrow.
with over 30°C it is a bit too hot for such things :wink:
and the worst part: already thought about buying a S905X3 box…but the cheap ones are out of stock…

I am always a lucky punk :-/

This type of SoC is not affected by this bug and GXL support is still experimental.

BL301 issues can only be solved by a UART log.

My MXQ Po 4k cant connect to wifi after update. I can see the networks but when i connect all i get is “associating” and “failure”

New 9.2.4.1 builds were uploaded to fix the bl301 injection issue. Please use that.

Installed, in fact updated my S905X box from -ng nightly to -ng 9.2.4 stable and everything works perfect for me. I don’t need nor use bl301 on this box, so should I also update to 9.2.4.1 or can stay on present 9.2.4?

It can’t hurt to update to 9.2.4.1.
But the bl301_inject bug was the only thing that got fixed and your S905X device wasn’t affected by this issue anyway.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice