A95X F3 Air Feedback Install CE

I’ve just bought this A95x F3 with 4Gb RAM & 32Gb ROM does anyone know which device tree would suit this box. I’ve looked at all the devices listed but only see the Nexbox A95 X3 in a couple of instances but not for this F3 model with4Gb RAM?
Any help would very much appreciated as I’m running another 2 boxes on CoreElec entirely satisfactorily and hate Android!

This is S905X3 box.
No support yet. Right now only VIM3L

1 Like

Hola, yo también estoy buscando CoreELEC para un A95X F3 Air. Estoy intentando un nocturno, pero no consigo que arranque. Gracias

Hello, I am also looking for CoreELEC for an A95X F3 Air. I’m trying a nightly, but I can’t get it to start. Thank you

Probably the same as [S905X3] X96Air_P2/P3 4/32GB 1Gbit Lan (How to config)

Hello I am new to this, I have an A95X F3 and I would like to pass it to COREELEC, I have tried it but it only works from the fully operational SD card, but I want it to work without SD from the internal EMMC, I have tried to record it with PUTTY with the CEEMMC commands -X, -V, -XV and I have not achieved anything, the device tree I use is the “sm1_s905x3_4g_1gbit.dtb”, any solution ???

I don’t know if this is where I have to ask this topic, if not, can you tell me where to do it.

Sorry for my English, it is a translator, I am Spanish.

Thanks in advance.

Has the same problem on the A95x f3 air. I’m just guessing that it could be an encrypted bootloader ?. Maybe someone will comment on this topic? See link://discourse.coreelec.org/t/which-affordable-s905x3-box/10842/24

I Yesterday install coreelec on a95x f3 air do you want some information about how to install?

Welcome on your first post.

Feel free to post your information.

You can open a new thread to cover the installation to include

Device Tree (Make sure you disclose the 2gb or 4gb box)

VFD Installation

The remote.conf

We know Bluetooth doesn’t work.

No internal CoreELEC eMMC installs have succeeded due to a possible encrypted bootloader.

Any other issues you have found.

I only just received the 2gb version today and booted it via SD Card CE.
I haven’t tried the remote yet or VFD setup.

Please advise if Kodi Netflix addon1080p works well or not. Any lag and cpu usage peak % when inputstream output is set at 1080p ? Thanks.

The S905X2 & X3 Will not software decoding @1080p which you will need for playback.

You’ll need A311D or S922 Chip Hardware.

Thanks for advice.
I got the A95XB7N S905X 2/16GB to software decode at 1080p but it is not smooth some times due to the one or two cpu cores reached 100% and lag appeared at that moment only.
I was hoping that the A95X F3Air 4/32GB with S905X3 running at a faster 1.7Ghz may overcome this deficiency.
I have already ordered one set but it has not arrived yet.

and with display on android box download from kodi repository openvfd and in root folder inset this file https://drive.google.com/open?id=1u7Karu3t4iCVNLSP_2vKlBNSrpR8qF33 restart android box and everything might start working

instalattion proces download coreelec nightly build from here https://relkai.coreelec.org/CoreELEC-Amlogic-ng.arm-9.2-nightly_20200520-Generic.img.gz after you download it burn it wih rufus to usb or sd card after you burn it search for deviace trees on usb or sd there may be sm_s905x3_2 or 4 gb rename it to dtb.img and copy it to your root folder then try to boot it with apk boot to libreelec search it in play store and it schoud boot to coreelec on pc search in explorer network and thre should be path named coreelec if you found it go toconfigfiles rc_keymaps and copy there this file https://drive.google.com/open?id=1Qo3t1hNkM8PFaKrfe5MHf0Xs5znbzgQZ after it in configfile folder may be file named rc_maps.cfg.something rename it to rc_maps.cfg open it in last line insert this: meson-ir * a95x after you done you must have alowed ssh connect to it with for example putty and type this commands: systemctl stop kodi, systemctl stop eventlircd, ir-keytable -a /storage/.config/rc_maps.cfg -s rc0, systemctl start eventlircd,
systemctl start kodi and wuala remote start working

Go to Arthur’s VFD repository here
And use a95x-f2-aml-vfd.conf

Instructions HERE

Not required with the 2gb box.

Reset button is inside AV port .

Use Toothpick method to activate reset button and cold power boot.

reset button didnt work for me

You have the 4gb right ??

Or a remote.conf attached below.

Unzip it and rename it remote.conf

SMB and copy it to config folder :wink:

A95x-Air-remote.zip (999 Bytes)

After reading through more posting, I understand your reply. Thanks. :ok_hand:

Just had my 24 HRS of running this A95X F3 Air 2gb / 16gb Model.

This thing is a real pleasant surprise performer running CE
(Android works great for what i use it for eg: Youtube and some subscriber Apps)

Automatic frame rate switching works using AFRd Auto Frame Rate Daemon
By Default Root Switcher is turned ON
Just Install the AFRd Apk

The GOOD:
The 2GB version has both 2.4 & 5Ghz Wifi which is not advertised when purchased.
On the bottom of the box it only reads 2.4Ghz as well.
It’s smooth and fast user interface with really good speed SD Card Reader.
Running CE using a Samsung EVO Plus 32GB sd card is as fast as any comparable higher priced hardware I own.
Remote works great using Amlogic remote.conf.
Powers Box ON /OFF.
The Factory Remote also has Learned Feature to learn your TV ON/OFF Volume/Mute
CEC all works with my Sharp Aquos Quatron TV.
Only glitch is when TV is turned on i have to toggle between HDMI source
back to this box port to wake it up and it powers on.
If i power on the box it powers on my TV as set in CEC settings.
VFD all good with Arthurs addon and a95x-f2-aml-vfd.conf

The BAD :
Typical Chinese Low Quality Control in assembly of the Heat Sink.
I’ll probably fix this when i get the motivation.
See pictures supplied.
This box runs into high 60c to 70c Network Movie Library playback .
I set the Governor to On Demand and that got it down to Low constant 60c
The other annoyance is the LED light is always on if it’s booted
in CE OS even when box is powered OFF.
Bluetooth chip (MT7668) is currently not working with CE.

I’m using that box with 4 GB RAM 3 months and can’t say bad words. For around 30$ with CE it’s very good deal. The only one thing I did is disconnected RGB led light. :stuck_out_tongue: