CoreELEC 19.1-Matrix_rc4 Discussion

Please use this thread for general 19.1-Matrix_rc4 discussion

Khadas VIM3l users

Please be sure you have a file /flash/dtb.img on your current eMMC installation before upgrade to CoreELEC-19-Matrix! Otherwise the device will stop booting and a recovery will be needed!

Open a SSH connection and check it by:

CoreELEC:~ # ls /flash/dtb.img
/flash/dtb.img

If the output look like this the system is compatible and can be upgraded to CoreELEC-19-Matrix. If you get a “file not found” please restore your system like with a Android image or a compatible krescue image before upgrade! Please keep in mind the VIM3L HTPC kit is including a not official image by Team CoreELEC so maybe it does not support the upgrade as well.

1 Like

Updated from rc2 my X96 S905X with 1/8 GB and 100 Mbit ethernet, all looking good.

Only G12*/SM1 with 100Mbit where affected by the bug in rc3.

GXL devices or devices with gigabit LAN did not trigger the bug.

Here updated a N2, pastrough to denon x3500h and lg c8, no probs so far…
I can test some if necessary, give a shout…

19.1 rc4 new installation - Tanix tx5 pro still not wifi (chipset Wi-Fi Broadcom QCA9377) :((

Driver is included and should work. Can you post url you get with ssh commands after reboot

dmesg | paste
udevadm info /sys/bus/sdio/devices/* | paste
journalctl -l | paste

On X96 air 4/64 1Gb the update went well, no issues so far.

Too noob for putty and ssh. There isn’t any IP to connect to. I don’t own any ethernet cable.
The “available networks window” is empty

Our crystal ball is broken and we cannot now why wifi is not there :slight_smile: As I wrote it should be.
From release notes:

Changes Since 19.1-Matrix_rc2
Updated Wifi driver QCA9377

It maybe you don’t need a crystal ball :slight_smile:

As I wrote wifi should work. It works on other devices but not on yours. So to get it working for you too you need to help us with some data. Or just live without. Or buy one device and send it to one of the devs.

It is completely your choice.

Then please do not request or expect any support.
Contact your box seller for support, thank you.

2 Likes

Btw: From LE forum

There are 3 Different wifi modules for the TX5Pro:
Qualcomm QCA9377 or QCA1023
Ampak AP6255
Fn-Link 8223A

This means fabri2 doesn’t have QCA9377 !

Ok, i opened my box and on wifi chip there was “FN-LINK 8223A-SR”

1 Like

Please post a request there with the debug information:

Do you have the access point thing turned on the in CE wi-fi settings? Try turning it off and reboot and see if you can see some networks… I see nothing there if I have the AP thing turned on (since CE19, it worked ok CE 9), when I turn it off, they come up (using the Odroid wifi adapator (5, I think?))

Thank you. No problem to upgrade the ugoos am6 plus :frowning: from rc2. This time I tried a Wireless connection. My AP uses the same SSID for both WiFi bands. At first, the ugoos connected to the 5 GHz band. But I had frequent buffering because there are several obstacles in between. Then I replaced the AP with another and the ugoos connected to 2.4 GHz and it was better, no more buffering as long as I played only full HD Blu-ray.

Is there a defined logic in CE to chose one or the other WiFi band or is this something at a lower level, out of (y)our control ?

If necessary, I can change the 5 GHz SSID to force the connection to 2.4 GHz.

I have trouble with CEC in the current build. Receiver and TV do not get switched off although it is enabled in the settings.

Using two different boxes: Odroid N2+ and a Tanix TX3 (S905x3)

About | FAQ | Terms of Service | Privacy Policy | Legal Notice