CoreELEC 19 Matrix Discussion (Kodi RC)

Just make 9.2.5 fresh install and update with the tars

Green issue resurfaced again?http://ix.io/2PXK

Also try different sd/usb card to exclude it too.

But wasn’t the idea to have more reliable testing from a fresh matrix install?

1 Like

I did do that with a basic install of a regular NG nightly.

1 Like

My first idea is also something like a bad boot media. Nobody else have such issue.

1 Like

Sir, Any solution? I fresh install new nightly and tried different nighties also but green screen issue resurfaced? I have s905x3 android tv box.

Try to find a newer Android firmware for your device.
The green screen issue is maybe caused by a “old” bootloader.

1 Like

Hi all,

is anyone having issue with the Kodi backup addon? it stopped working couple of weeks ago for me with the ‘too many open files’ issue, which prevented backup and restore. Since the last two nightlies at least, the too many open files errors are gone, and i can restore backup from my network share (although the gathering files part takes significantly longer than it used to), however, i cant create a back up, it just creates an empty folder on my smb share and in Kodi sits indefinitely at the ‘gathering files’ message, i have waited few hours and it does not move and i see same behavior on s905x and s905x3 boxes i have tried on. i don’t see anything of note in the logs. On RC1 droid on my Sony TV i can create a backup to the same share no problem…

Thanks!

In regards to the green screen issues:

I don’t know if it is related, nor am I sure if this would work with CoreELEC, but under LibreElec there were similar issues and this was the fix:

(a) Forcing RGB on older TV’s

The fix is to enable the Force RGB option

SSH into the box

cd .config 
nano autostart.sh

insert:

#!/bin/sh
echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb

Ctrl + X to exit and save

chmod 755 autostart.sh 
reboot

I can’t test nor confirm this would resolve the green screen issue because I do not experience the issue with any of my hardware.

I don’t see file /sys/class/amhdmitx/amhdmitx0/output_rgb so I assume the above will not work.

Hello, It is already official Kodi 19 Matrix. Great news.

After updating h96 x905x3 official latest firmware via amlogic burning tool but green screen issue remains there.
When I switch on my hisense Led and android tv box same time then screen becomes green
Solution:-

After shutdown android tv box via remote power off button and again on press power on button of android tv box’s remote then led screen becomes normal.
Previous stable build version named 9.2.5 working fine without green screen issue, but I want to use latest kodi 19 based coreelec.
I think that it’s strange issue, kindly help?

@vpeter i am aware the path could be different, that’s what I don’t know. The clue here is to force RGB and I don;t know if that would work in CE

Yup, the CoreELEC team was paid directly by HardKernel to hide these bugs for the N2 launch - that’s why they banned my account here after it was confirmed on the LibreELEC and CoreELEC pages :slight_smile:

This is actually completely fixed upstream, there’s just bad developers in this chain. My S905 still performs astronomically better than the S905X2, but that too is just ineptitude where there’s massive embarrassment of the current development team trying to carry the torch.

The reason I created a new account after the current maintainer continues to hide this basic information. This is to share because they’re basic driver bugs that they don’t give a shit about, and again I run CoreELEC but hiding these trivial issues from the greater public is a major disservice.

I don’t remember who you are but spreading conspiracy theories is a reason for being banned. Consider this your new first strike.
Noboby was paid to hide bugs. Nobody is forcing you to use CoreELEC. If it’s fixed “upstream” (whatever upstream is in your context) go and use upstream. Also insulting developers just because you think some problem is not fixed is not nice. Think about your actions and attitude.

EDIT: I think you are referring to this issue you posted. I’m posting it here for everyone to see so everbody can see it’s not hidden: Amlogic-ng (amcodec): 4k/60hz content corruption.
BTW to explain why a moderator “unlisted” your topic. You were posting links to content that is copyrighted.

9 Likes

Sorry, but this is really uncalled for.
Please be respectful. Or leave.

Could you also clarify full TV model?
And also dmesg log after you boot with green screen and the same for normal screen

Thank you, there’s no more skipping with the latest version.

so you bought a cheap Chinese s905x2 box and got some issues. its a chance you take on this type of HW. mostly they are good but not always. if you want flawless operation pay some extra cash for a better supported box