Odroid N2 test builds

Just got my N2 yesterday and I spent last evening setting everything up. My previous device was a C2.

I’ve noticed that on live tv, mpeg2 1080i at 59.94 the player info says 1080p and when first starting the video pauses and the audio continues. After maybe 5 seconds the video starts moving and all is fine. The 1080p thing used to happen on my C2 many builds back but now it correctly shows 1080i. Recorded tv has no issue and shows 1080i.

Just wondering if this has been seen yet before doing a debug log.

This is the last time I’ll post on the remote issue.

I’m completely lost here. I don’t know what rc core is. Are you saying that your official HK remote works fine straight away on a new build without doing anything? This has never been the case for me, and I’m not alone.

CoreELEC-Amlogic-ng.arm-9.0-devel-1555398703_catoon_fix.tar 8
Just turned on my TV and the N2 woke up from suspend.
I noticed a notification successfully removed storage device coreelec

No addons will open.
Clicked on Youtube and the screen went dim.
Box un responsive.
I ssh into box and the output reads
ssh_exchange_identification: read: Connection reset by peer
SMB the N2 shows up on my Mac as a shared device with all folders visible.
Only the Addons and Userdata folders open with nothing inside them.
All other folders , I get all The operation can’t be completed because the original item
for “Backup” can’t be found.
backup%20cant%20be%20found folders%20open%20Odroid

Unplugged from power / Plugged back power and everything came back.

I stopped using “Suspend” for other reasons. It just isn’t dependable enough with my addons and settings…

When a movie (UHD)is playing , then bring out OSD, the remote response gets laggy, and another question@Ray ,is the last test build disabled 4K@24hz output? because I can’t playback 4k@24hz movie ,the TV lost hdmi signal.

CoreELEC (community): devel-1555398703 (Amlogic-ng.arm)
CoreELECoDroid:~ # dmesg


I have seen this issue too on live TV from a DVBViewer Media Server. (1080i, 720p) Sometimes it happens that the video stay at the first frame, audio is running. After a few seconds video starts to run. It does not happen every time - just sometimes. Is on my todo list :wink:

i have seen micro stutters about every 5 seconds during Live TV playback (UK DVB-T) of SD live broadcasts, strangely Live TV recordings (also MPEG 2 SD) seem unaffected. This doesn’t happen every time, but i have seen it more often when channel switching, could this be related to incorrect 1080p selection?. I can supply logs and possibly a small video displaying the issue if that is of any use. One thing i did try was turning off hardware acceleration for MPEG 2 (broadcast format) and this did seem to ‘fix’ the issue, so maybe related in some way to hardware acceleration.

Im running TVHeadend server and client with 2 x DVB-T USB (dual) receivers, ive had these tuners for several years and not seen the issue on previous HTPC hardware so im confident its not directly related to the tuners.

It has the attention of the Devs.
All the above symptoms you have described are present in my setup.
I used hardware acceleration for mpeg2 HD and up in player settings to stop the frame drops with Live TV Streams.

1 Like

I am having problems with this build. The screen goes intermittently dark every few minutes. I changed my cable to a better quality one but still have the same problem. It does not happen with your previous build which contains only the cartoonfix.

Thank you for that update and the work you and everyone has done adding support for the N2 to CoreELEC. The N2 is a zippy device for sure.

Thank for the comment, i appreciate it, if you want me to test an early build with a fix then im happy to do so.

This is basically the same build with the same HDMI patches just meson-ir fixed.

Yes, now I am facing the same problem with three previous build. It happens only on 1080p not 4k. Any idea how to solve it? Has the hdmi signal bandwidth changed?

This is very helpful. I’m using emmc. You are using SD? Something hangs out your storage partition. On emmc no issues.

I’m using SDHC and these builds, maybe it is one of the following:

  • SD card issue/corruption. Try rewriting fresh image. Works perfectly writing the images with RUFUS here.
  • Is it a new UHS-II card perhaps, these might need more testing, the S922X/N2 added support for actual UHS mode operation, maybe its weird. I can confirm UHS-I works.
  • No brainer here but… is the card pushed in 100%?

Suspend working for you? Because we had several people report GUI issues after suspend and the thing kostaman describes about disk being removed makes kinda sense to me.

I do have a n2+sundtek dvb-s2 tuner. I just installed it and found the channel switching times to be longer than the one of s905 with the build in tuner. Could anyone tell me something about it? I thought the sundtek tuner would be faster?!

Question @Ray
How can I run your script “odroidn2toemmc.bash” ?
Tried it today without success:

CoreELEC (community): devel-1555398703 (Amlogic-ng.arm)
CoreELEC:~ # cd download
CoreELEC:~/download # ./odroidn2toemmc.bash
-sh: ./odroidn2toemmc.bash: Permission denied
CoreELEC:~/download # chmod +x odroidn2toemmc.bash
CoreELEC:~/download # ./odroidn2toemmc.bash
-sh: ./odroidn2toemmc.bash: not found

Hello, is the April 14 version the last ?